Issues with ARM9 and Luma

Discussion in '3DS - Flashcards & Custom Firmwares' started by Smokerino, Nov 8, 2016.

  1. Smokerino
    OP

    Smokerino Newbie

    Newcomer
    3
    0
    Nov 8, 2016
    Hello all,

    Yesterday night i halped a friend to install arm9loaderhax + luma3ds to and Old 3ds with a 4.5.0 following https://plailect.github.io

    Everything went smooth up untill the part where you need to do a backup of your sysnand to nandmin.bin https://plailect.github.io/Guide/2.1.0-ctrtransfer -> Section III part 3. My friend skiped this part not backing up the sysnand, but we continued with the guide, as he had a nand backup from before we started the tutorial (i think this is where our issue lies).

    So we continued with https://plailect.github.io/Guide/installing-arm9loaderhax up to the point of Section IV. At this point, since he forgot to make a backup as said before, i told him to just skip that part and inject the FBI to H&S but it didn't work. (He injected FBI to H&S as guide says but the H&S app was still the normal one).

    So since we were unable to continue, we decided to use the old nand backup he had, that as i said, was made before we did anything to the 3ds (in other words, not following the guide), and after using that backup as it states in Section IV, as soon as he turns his 3ds up he gets the following error:

    An error has ocurred:
    An old unsupported FIRM has been detected.
    Cppy a firmware.bin in /luma to boot.

    We tried several fixes like starting again from the top of https://plailect.github.io/Guide/installing-arm9loaderhax with no success at all, so here i'm, asking you for some help.

    Edit: if it helps, we used https://plailect.github.io/Guide/2.1.0-ctrtransfer

    Edit 2: 3ds was updated to 11.2.0 while restoring the nand he had as stated in the guide.

    Edit 3: If start is hold while prowerng 3ds, it boots into Hourglass 9, if select is hold, it boots into Luma3ds config menu.

    Edit 4: the issue is the 3ds being stuck when powered normal with the following message:
    An error has ocurred:
    An old unsupported FIRM has been detected.
    Cppy a firmware.bin in /luma to boot.

    SOLVED: following #5
     
    Last edited by Smokerino, Nov 10, 2016
  2. Cody090909

    Cody090909 GBAtemp Regular

    Member
    189
    25
    Jan 16, 2015
    United States
    Here
    You needed to update your 3ds to a version more recent to inject FBI and such. (IIRC <9.2)
    Since you don't have a backup, you cant boot luma, so idk what you would do but you somehow need to upgrade your firm.

    Lesson Learned, follow the guide no matter what?
     
  3. Quantumcat

    Quantumcat Dead and alive

    Member
    11,916
    6,410
    Nov 23, 2014
    Australia
    Canberra, Australia
    You can do a system update from 2.1 on an old 3DS. That should be detailed there - for people that don't have NAND backups. The pre-injected FBI apps will work then.
    Or, I have a tool for helping you inject in any firmware. For download at quantumc.at (InjectorHelper.jar)
     
  4. Smokerino
    OP

    Smokerino Newbie

    Newcomer
    3
    0
    Nov 8, 2016
    3ds was updated to 11.2.0 while using the backup he had, and after updating is when the problem arised.

    Note: If start is hold while powering the 3ds, it boots into Hourglass 9, if select is hold, it boots into Luma3ds config menu.

    — Posts automatically merged - Please don't double post! —

    The problem is not FBi atm, is the 3ds being stuck after turning it on with:

    An error has ocurred:
    An old unsupported FIRM has been detected.
    Cppy a firmware.bin in /luma to boot.


    Note: redowloading the file thats on the Section IV part 1 (https://plailect.github.io/Guide/installing-arm9loaderhax) and renaming it to Firmware.bin doesn't work.
     
  5. Windylacine

    Windylacine GBAtemp Fan

    Member
    348
    96
    Apr 15, 2016
    found firmware.bin files for 4.5

    https://gbatemp.net/threads/gateway-and-luma-questions.440873/#post-6663200

    Choose Old 3DS one, use any mirror links instead since current links are deleted.
     
    Smokerino likes this.
  6. HyperT

    HyperT GBAtemp Advanced Fan

    Member
    674
    169
    Jun 4, 2016
    Your nand [at least some of it] is on 4.5 still.

    https://github.com/AuroraWright/Luma3DS/wiki/Installation-and-Upgrade look through that
     
  7. Smokerino
    OP

    Smokerino Newbie

    Newcomer
    3
    0
    Nov 8, 2016
    Sorry for the late reply, my frind was sleeping like a bear in winter.

    You sir, nailed it. Indeed the firmware.bin solved the issue.

    I want to thank everyone who helped, and say hi to the community, since this post was my first one!