1. Biff627

    OP Biff627 GBAtemp Addict
    Member

    Joined:
    Aug 15, 2015
    Messages:
    2,081
    Country:
    United States
    So this may seem a little odd to ask on here but I have a weird issue with my switch atm

    I am running a build of SwitchRoot Pie and it has been working fine for a while now. One main thing that I like about it is that TWRP's MTP actually works and shows the sd card and internal storage while the switch is booted to TWRP and is plugged into my PC.
    Recently I installed the tinfoil driver and .reg for NUT to install some nsp's and all seemed well for a while. But just recently when I booted the TWRP recovery on my switch, it started saying that the USB had malfunctioned and that the USB was not recognized.

    It normally shows up in device manager as "ADB Interface" like this
    unknown.png
    But it just shows up as this now
    Capture.PNG

    What ive tried so far:
    Removing the Tinfoil driver from control panel and what was added in regedit
    Using Zadig to install drivers over the broken USB Composite Device
    I found something that said that a file named wpdmtp.inf in windows/inf could fix my issue if I right clicked it and hit install (didnt wortk)
    Tried installing adb drivers over the device in device manager but it says that its either not compatible or that the drivers arent x64???

    I kinda just feel stuck since everything that seems like it would fix the issue hasnt... Side note, all drivers currently work for HOS.

    If anyone has any suggestions for me to try they would be appreciated :)
    No im not gonna reinstall windows....
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - installing, switchroot, Tinfoil