Is it possible to run CIAs for developer consoles on retail consoles?

Discussion in '3DS - Flashcards & Custom Firmwares' started by ariss, Feb 13, 2017.

  1. ariss
    OP

    ariss Advanced Member

    Newcomer
    95
    8
    Dec 30, 2014
    United States
    I have a CIA that normally is supposed to run with developer hardware.
    I have emunand installed on my 3ds and when I try to install the cia, I get an error:
    "DESCRIPTION_INVALID_NCCH (0x25)"
    Is it even possible to do this?
     
  2. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,280
    Jan 28, 2016
    United States
    Use the latest luma version and turn on "UNITINFO"
    It should install now
     
  3. zenamez

    zenamez GBAtemp Regular

    Member
    154
    101
    Sep 7, 2016
    Should be noted - if you turn that on, you can't install retail CIAs (it'll give you an error, much like the one you got trying to install a Dev CIA onto a non-dev unit) and any installed Dev CIAs won't work properly until you turn UNITINFO back on again (but then retail CIAs won't launch).
     
    Last edited by zenamez, Feb 13, 2017
  4. Shawnj

    Shawnj Advanced Member

    Newcomer
    83
    11
    Jan 22, 2017
    United States
    Los Angeles
    So it's like a switch for dev mode, then.
     
  5. zenamez

    zenamez GBAtemp Regular

    Member
    154
    101
    Sep 7, 2016
    Basically, yeah. It's a pity you can't have retail functionality under Dev mode like you can with other consoles (like CEX to DEX CFW PS3s. Retail functionality, paired with Developer features like RTMing (real time modding) etc) though.
     
  6. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,280
    Jan 28, 2016
    United States
    What? I've installed every .cia from the sdk (just downloaded from nintendo, not modified in anyway) using UNITINFO and they launch fine without it...
     
    iAqua likes this.
  7. ariss
    OP

    ariss Advanced Member

    Newcomer
    95
    8
    Dec 30, 2014
    United States
    Thanks for the feedback :)
     
  8. zenamez

    zenamez GBAtemp Regular

    Member
    154
    101
    Sep 7, 2016
    The last time I tried to do that, FBI gave me an installer error. It could have changed, I dunno (I gave up trying to install them and went with community made CIAs instead (like JKSM etc)).
     
  9. ariss
    OP

    ariss Advanced Member

    Newcomer
    95
    8
    Dec 30, 2014
    United States
    I just successfully installed a developer CIA with luma :)
     
  10. Fishaman P

    Fishaman P Speedrunner

    Member
    3,244
    510
    Jan 2, 2010
    United States
    Wisconsin
    From what I understand, the UNITINFO only needs to be set during installation. It doesn't matter what it's set to when launching already installed CIAs.
     
  11. ariss
    OP

    ariss Advanced Member

    Newcomer
    95
    8
    Dec 30, 2014
    United States
    exactly