Installing boot9strap on 11.4+

Discussion in '3DS - Flashcards & Custom Firmwares' started by CanIHazWarez, Jul 16, 2017.

  1. CanIHazWarez
    OP

    CanIHazWarez Advanced Member

    Newcomer
    55
    18
    Jan 21, 2016
    United States
    I got a refurbished Hyrule edition n3ds (dual IPS, eat your heart out!) that's on 11.4. I have an o3ds xl on 11.2 with boot9strap installed with luma and gateway payload. In the 3ds.guide for the DSiWare hack, it says:
    • The source 3DS: the 3DS running some kind of custom firmware (such as boot9strap or arm9loaderhax) on the latest version
    Is it talking about the latest version of boot9strap or the latest system firmware? What I really want to know is, can I hack my new system without updating the firmware on my old system. I don't want to update past 11.2 and lose the ability to use gateway on my old system. Thanks in advance for any information or related tips.
     
  2. proflayton123

    proflayton123 Undeclared Shitposter 2.1

    Member
    5,873
    2,215
    Jan 11, 2016
    Japan
    日本
    To do system transfers both systems have to be on the latest being 11.5, backup your 11.2 NAND and update, do the process then restore the 11.2 backup?
     
    Quantumcat and CanIHazWarez like this.
  3. Yepi69

    Yepi69 Vivid and busy gamer

    Member
    2,443
    1,041
    Nov 29, 2010
    Portugal
    Behind you
    First, why still use Gateway?
    Second, you need to update to perform a system transfer with an exploitable DSiWare game, thus DSiWare hax.
    Third, DSiWare hax still works in 11.5
     
  4. CanIHazWarez
    OP

    CanIHazWarez Advanced Member

    Newcomer
    55
    18
    Jan 21, 2016
    United States
    I've had gateway since before a9hl and luma were a thing, as soon they had 9.2 compatibility. It's not that it's better, it's that I'm lazy and I already have all my games and saves in GW. Obviously, I can't use GW on my new system as of now, but I'll slowly build my cia collection.
    I would love if the GW team would support the latest firmware so I could actually swap my GW card back and forth between systems, but I'm not holding my breath.
     
  5. Majickhat55

    Majickhat55 The Red Woman

    Member
    4,401
    2,164
    Mar 28, 2016
    United States
    Asshai
    Last edited by Majickhat55, Jul 16, 2017
  6. jaeman109

    jaeman109 GBAtemp Regular

    Member
    136
    48
    Feb 15, 2017
    United States
    CanIHazWarez likes this.
  7. Ominous66521

    Ominous66521 GBAtemp Maniac

    Member
    1,156
    297
    Feb 7, 2016
    United States
    Create a emunand with the 11.2 firmware if you want to use gateway for cheats.That way you can update your sysnand to the latest version.
     
  8. CanIHazWarez
    OP

    CanIHazWarez Advanced Member

    Newcomer
    55
    18
    Jan 21, 2016
    United States
    To clarify, are you saying that I can somehow get emuNAND that's 11.2 on my new system that came with 11.4 on it?
     
  9. Majickhat55

    Majickhat55 The Red Woman

    Member
    4,401
    2,164
    Mar 28, 2016
    United States
    Asshai
    Yeah, once you have CFW you can create an Emunand and then downgrade it with Sysupdater and a CIA pack of Firmware 11.2 downloaded from 3DNUS for your region, or you can perform a CTRNAND tranfer of 11.2 if you can find one. The tutorial I linked above explains everything you need to know about making it work. Just make sure you read the whole thing. :D
    https://gbatemp.net/threads/3dnus.376488/
    https://github.com/profi200/sysUpdater/releases
    https://gbatemp.net/threads/3down-ctrnand-downgrade.467877/

    — Posts automatically merged - Please don't double post! —

    Oh BTW I just checked 3Down and they only have a N3DS 11.2 CTRNAND transfer for the EUR region. So, I'm pretty sure you'll have to use 3DNUS.
     
    Last edited by Majickhat55, Jul 16, 2017
    CanIHazWarez likes this.
  10. CanIHazWarez
    OP

    CanIHazWarez Advanced Member

    Newcomer
    55
    18
    Jan 21, 2016
    United States
    If I am able to to this, I will name my first born child after you.
     
  11. Majickhat55

    Majickhat55 The Red Woman

    Member
    4,401
    2,164
    Mar 28, 2016
    United States
    Asshai
    If you need help feel free to PM me and I'll walk you through it.
     
  12. CanIHazWarez
    OP

    CanIHazWarez Advanced Member

    Newcomer
    55
    18
    Jan 21, 2016
    United States
    Thanks, this is what I ended up doing. The DSiWare boot9strap guide doesn't mention anything about updating the firmware on the source system, and definitely doesn't mention backing up the NAND before updating so I'm glad you mentioned this.
    I ended up doing this in case I couldn't revert my source system back to 11.2 and lost access to gateway. Thanks for the nudge ;)
     
  13. Quantumcat

    Quantumcat Dead and alive

    Member
    11,466
    6,155
    Nov 23, 2014
    Australia
    Canberra, Australia
    Yes it does, it is even in italics so you can't miss it:
    Because most people will have an updated system already, and there's no benefit to being on 11.2 (unless you're in the minority using Gateway, which you can't use for the guide anyway since it won't boot on 11.5). And if you want to return to 11.2 you can use a CTR transfer or sysupdater. There's no point confusing loads of people to cater to the tiny percentage of people using Gateway (can't you just imagine all the people saying, "but my source system isn't on 11.2, does that mean I can't follow this guide?")
     
    Lilith Valentine likes this.
  14. gamesquest1

    gamesquest1 Nabnut

    Member
    GBAtemp Patron
    gamesquest1 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    14,148
    9,501
    Sep 23, 2013
    Psssst....you lost your glasses again B-).....or maybe they're just black glasses....I guess it could be that
     
    Quantumcat likes this.
  15. Quantumcat

    Quantumcat Dead and alive

    Member
    11,466
    6,155
    Nov 23, 2014
    Australia
    Canberra, Australia
    Yep black glasses :ph34r:
     
    gamesquest1 likes this.
  16. gamesquest1

    gamesquest1 Nabnut

    Member
    GBAtemp Patron
    gamesquest1 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    14,148
    9,501
    Sep 23, 2013
    It's the green dickie bow . . . It make quantum look smarter than other "cats"
    .

    ..

    ...
     
    Quantumcat likes this.
  17. CanIHazWarez
    OP

    CanIHazWarez Advanced Member

    Newcomer
    55
    18
    Jan 21, 2016
    United States
    "the 3DS running some kind of custom firmware (such as boot9strap or arm9loaderhax) on the latest version"
    This says that the CFW needs to be on the latest version, which makes it sound like it's not talking about this system firmware. Especially because it specifies that the target system needs to be on 11.5.0. It's not very clear, which is why I asked for clarification in the OP.
    As for backing up your NAND before you update, I think it would be helpful to mention in the guide. Obviously, the author is under no obligation to include it. That's why I thanked @proflayton123 for giving me the idea. Your post seemed a bit defensive. I wasn't bashing the guide, simply thanking another user for the help.
     
  18. Quantumcat

    Quantumcat Dead and alive

    Member
    11,466
    6,155
    Nov 23, 2014
    Australia
    Canberra, Australia
    It says this because it is possible it will not work on 11.6. The 11.5 is specified for the target system so that if an update comes and the guide isn't updated immediately, nobody gets confused. The source system says latest version because you have to be on the latest version to do a system transfer. The interpretation that the CFW has to be on the latest version doesn't make sense, because "some kind of CFW" would have to mean any CFW, including outdated ones. For example, a9lh is mentioned and it can no longer boot the most up-to-date Luma. So that would disqualify it immediately as needing to be on the latest version. I haven't ever seen someone have this misunderstanding before but now that you have pointed it out I can see how it could happen.
     
    CanIHazWarez likes this.