Homebrew I need help installing CIA files

MartinDocNewland

Searching for the truth
Member
Joined
Jul 7, 2012
Messages
594
Trophies
0
XP
491
Country
Well that be why it can't install them. Your have to hard mod your system, wait for soundhax to be released or find another hax that works on firmware 11. A Google search should help you as I'm not too sure what ones if any are out at the moment
 
  • Like
Reactions: Dped404

Intronaut

A star maker
Member
Joined
Nov 18, 2014
Messages
772
Trophies
0
Age
29
XP
993
Country
Chile
don't make a thread for noob questions like that. there's a particular thread for that kind of questions.

also, please read the stickies.
 

Swiftloke

Hwaaaa!
Member
Joined
Jan 26, 2015
Messages
1,770
Trophies
0
Location
Nowhere
XP
1,334
Country
United States
don't make a thread for noob questions like that. there's a particular thread for that kind of questions.

also, please read the stickies.
^ what I was trying to say
Also, a simple Google would have given you your answer. It bothers me that these days people find it simpler to make new threads than Google. In fact, when creating a new thread, it tells you you can't install cias above 9.2.... Whyyyyyyyyyy:hateit: I thought you had to be capable of reading to write
 

MartinDocNewland

Searching for the truth
Member
Joined
Jul 7, 2012
Messages
594
Trophies
0
XP
491
Country
^ what I was trying to say
Also, a simple Google would have given you your answer. It bothers me that these days people find it simpler to make new threads than Google. In fact, when creating a new thread, it tells you you can't install cias above 9.2.... Whyyyyyyyyyy:hateit: I thought you had to be capable of reading to write

Does someone want a cuddle?
 

Swiftloke

Hwaaaa!
Member
Joined
Jan 26, 2015
Messages
1,770
Trophies
0
Location
Nowhere
XP
1,334
Country
United States
Screenshot_20160802-185411.jpg
Screenshot_20160802-185441.jpg

What you saw when you made this thread @Dped404
 
Last edited by Swiftloke,

Ghassen-ga

Well-Known Member
Member
Joined
Jul 21, 2016
Messages
783
Trophies
0
XP
1,705
Country
Well that be why it can't install them. Your have to hard mod your system, wait for soundhax to be released or find another hax that works on firmware 11. A Google search should help you as I'm not too sure what ones if any are out at the moment

Dude , Why would he need to wait to soundhax ? if he already has access to FBI that means he already have access to homebrew via some hax ,Also Browserhax works on 11.x :wacko:
 

Dped404

Member
OP
Newcomer
Joined
Aug 1, 2016
Messages
11
Trophies
0
Age
21
XP
43
Country
Canada
^ what I was trying to say
Also, a simple Google would have given you your answer. It bothers me that these days people find it simpler to make new threads than Google. In fact, when creating a new thread, it tells you you can't install cias above 9.2.... Whyyyyyyyyyy:hateit: I thought you had to be capable of reading to write
Actually I had tried Google and was somewhat aware of the fact that cias weren't usable on 11.0 but usually to get an answer you have to ask
 
Last edited by Dped404,

TheCyberQuake

Certified Geek
Member
Joined
Dec 2, 2014
Messages
5,012
Trophies
1
Age
26
Location
Las Vegas, Nevada
XP
4,386
Country
United States
Why is this one of the most asked noob questions? The top of the forum LITERALLY GIVES THE ANSWER.
It states:

"IMPORTANT: IT IS NOT POSSIBLE TO INSTALL (MOST) CIA FILES ABOVE SYSTEM MENU VERSION 9.2!"
I'm not too bothered by noob questions, but when it's the same thing being asked over and over it really gets to me, especially when the answer is at the top of the page.
But in case you need some clarification, I will go into some detail as to why.
Homebrew Launcher uses an arm11 userland exploit. This means we can run unsigned code, but only under the permissions of the application we exploit. We do not have full access to the kernel. With an arm11 kernel exploit, we gain the ability to access the kernel giving us access to title installation (which allowed downgrading and legit CIA installation), but the problem is that arm9 basically does console security. Without access to arm9 to bypass security checks, we are stuck with universally signed CIA files, ones that are signed to work with any console they are put on (again most notably firmware up/downgrade and legit CIAs). With arm9 kernel exploits (currently only exists on 9.2 and lower) we are able to bypass the arm9 security checks, which allows us to install unsigned files, meaning we can install and run whatever we want with nearly full access to the system other than items that are locked like OTP and bootrom.

If I made any mistakes in this explaination someone can let me know and I'll fix said errors.
 
Last edited by TheCyberQuake,

Swiftloke

Hwaaaa!
Member
Joined
Jan 26, 2015
Messages
1,770
Trophies
0
Location
Nowhere
XP
1,334
Country
United States
Why is this one of the most asked noob questions? The top of the forum LITERALLY GIVES THE ANSWER.
It states:

"IMPORTANT: IT IS NOT POSSIBLE TO INSTALL (MOST) CIA FILES ABOVE SYSTEM MENU VERSION 9.2!"
I'm not too bothered by noob questions, but when it's the same thing being asked over and over it really gets to me, especially when the answer is at the top of the page.
But in case you need some clarification, I will go into some detail as to why.
Homebrew Launcher uses an arm11 userland exploit. This means we can run unsigned code, but only under the permissions of the application we exploit. We do not have full access to the kernel. With an arm11 kernel exploit, we gain the ability to access the kernel giving us access to title installation (which allowed downgrading and legit CIA installation), but the problem is that arm9 basically does console security. Without access to arm9 to bypass security checks, we are stuck with universally signed CIA files, ones that are signed to work with any console they are put on (again most notably firmware up/downgrade and legit CIAs). With arm9 kernel exploits (currently only exists on 9.2 and lower) we are able to bypass the arm9 security checks, which allows us to install unsigned (or unofficiall signed? I'm not quite sure...) meaning we can install and run whatever we want with nearly full access to the system other than items that are locked like OTP and bootrom.

If I made any mistakes in this explaination someone can let me know and I'll fix said errors.
Actually, you're completely right. Anyway, the way sig patches work is that we just turn them off. No need to "unofficially" sign them.
Anyway, as for the Google/top page part, bro you got ninja'd :ph34r:
 

ADS3500

Well-Known Member
Member
Joined
Jul 27, 2016
Messages
330
Trophies
0
XP
266
Country
Canada
Well that be why it can't install them. Your have to hard mod your system, wait for soundhax to be released or find another hax that works on firmware 11. A Google search should help you as I'm not too sure what ones if any are out at the moment
Why would waiting for soundhax work? I know it is releasing with an arm11 exploit, but it's not possible to downgrade on 11.0 with an arm11 exploit unless someone can find a way around the firmware checks. The only way to downgrade on 11.0 would be an arm9 exploit, but there would be no point in downgrading if there was an arm9 exploit on 11.0.
 

Swiftloke

Hwaaaa!
Member
Joined
Jan 26, 2015
Messages
1,770
Trophies
0
Location
Nowhere
XP
1,334
Country
United States
Why would waiting for soundhax work? I know it is releasing with an arm11 exploit, but it's not possible to downgrade on 11.0 with an arm11 exploit unless someone can find a way around the firmware checks. The only way to downgrade on 11.0 would be an arm9 exploit, but there would be no point in downgrading if there was an arm9 exploit on 11.0.
Ssssssshhhhh ;)
 

You may also like...

General chit-chat
Help Users
  • No one is chatting at the moment.
    KenniesNewName @ KenniesNewName: https://www.servethehome.com/pny-cs3140-1tb-nvme-ssd-review/2/ damn bruh