How to play Dark Souls?

Discussion in 'Switch - Backup Loaders & Modchips' started by djricekcn, Oct 18, 2018.

  1. djricekcn
    OP

    djricekcn GBAtemp Maniac

    Member
    5
    May 29, 2009
    United States
    I'm not sure what firmware it requires but i assume it's 6.0.. i can't seem to get it to boot on SXOS.. how do i go about booting it? I have tried it on cart too but the cart doesnt' seem to have a firmware update file?
     
  2. Wiiunator

    Wiiunator GBAtemp Fan

    Member
    4
    Nov 13, 2015
    Australia
    use tinfoil to install the NSP version and bypass firmware requirement
     
    Ty_ likes this.
  3. uludag

    uludag Advanced Member

    Newcomer
    3
    Jun 5, 2018
    Fiji
    It's 6.0
     
  4. djricekcn
    OP

    djricekcn GBAtemp Maniac

    Member
    5
    May 29, 2009
    United States
    Thank you but I have cart version and I can only make that a xci (I think)
     
  5. wurstpistole

    wurstpistole GBAtemp Psycho!

    Member
    11
    Nov 19, 2015
    Gambia, The
    thats not how it works
     
  6. Sasori

    Sasori GBAtemp Addict

    Member
    9
    Jan 28, 2015
    United States
    What error are you receiving ? I booted it on 5.0.1 fine
     
  7. chocoboss

    chocoboss GBAtemp Fan

    Member
    4
    Jun 25, 2016
    France
    FRANCE
    I have used the firmware bypass on tinfoil and installed it + update and it work nice on 5.1 + hekate
     
  8. Cubuss

    Cubuss GBAtemp Fan

    Member
    8
    Aug 4, 2017
    Netherlands
    High Quality Shitposter
    Base game works on 5.1 if you install update it requires 6.0

    as said above use tinfoil to install the game update to bypass firmware requirement
     
    CymraegAce likes this.
  9. djricekcn
    OP

    djricekcn GBAtemp Maniac

    Member
    5
    May 29, 2009
    United States
    I'm not receiving an error, it's just telling me to update and it tries to take me online. I'm on 5. Something and using sxos. FYI . Like other games I can't bypass it by clicking play without update or what ever it is in English . It is forcing me to update to play
     
    Last edited by djricekcn, Oct 18, 2018
  10. bi388

    bi388 GBAtemp Maniac

    Member
    6
    May 29, 2015
    United States
    Yes it is. I installed the game, tried to launch it (on 6.0) and it said it needed to update. Uninstalled, reinstalled selecting to bypass firmware requirement in tinfoil, and it ran.
     
    Ty_ likes this.
  11. lolcatzuru

    lolcatzuru GBAtemp Fan

    Member
    4
    Apr 20, 2012
    United States
    you can also just update.
     
  12. Ty_

    Ty_ GBAtemp Fan

    Member
    5
    May 22, 2018
    United Kingdom
    Can confirm this also works with DZ on 5.1, and that was with the update
     
  13. Zumoly

    Zumoly GBATemp Analyst

    Member
    7
    Apr 27, 2018
    Mali
    Yorosso
    At this point if one is on 5.1.0 is there any harm updating to 6.0 or even 6.0.1?
     
  14. djricekcn
    OP

    djricekcn GBAtemp Maniac

    Member
    5
    May 29, 2009
    United States
    No I can't, it required me to connect to the internet.

    Also, I'm using a cart, not a nsp. Anyway to get around this with a cart or a xci made from the cart? As far as I'm aware, there's no cart or xci to nsp that's working properly
     
    Last edited by djricekcn, Oct 19, 2018
  15. lolcatzuru

    lolcatzuru GBAtemp Fan

    Member
    4
    Apr 20, 2012
    United States

    im not sure if you are aware, but there is a way you can update without having to connect from the internet.
     
  16. bi388

    bi388 GBAtemp Maniac

    Member
    6
    May 29, 2015
    United States
    Uninstall the game and reinstall it with tinfoil. When asked, select to bypass the firmware requirement. I did this and it allowed the game to launch.
     
  17. Milenko

    Milenko GBAtemp Advanced Maniac

    Member
    9
    Oct 16, 2017
    Australia
    Have you tried xci to nsp or are you just assuming it doesn't work
     
  18. Nerdtendo

    Nerdtendo Your friendly neighborhood idiot

    Member
    7
    Sep 29, 2016
    United States
    Left analogue to move your character. Right analogue for camera. Hold A to dash, tap it while moving to roll. Tap A while standing still to back jump. Attack with R and strong attack with ZR. L is shield
     
  19. Wiiunator

    Wiiunator GBAtemp Fan

    Member
    4
    Nov 13, 2015
    Australia
    I’m on 5.1.0 with SXOS 2.2, I have converted dark souls base game XCI to nsp, installed it with the SXOS installer then i installed the NSP update which requires 6.0 with tinfoil 0.2.1 and ignored firmware requirement when installing and it’s working perfectly here.
     
Loading...