Horizon Zero Dawn crash - shaders on Intel?

emcintosh

On the internet, everyone knows I'm a cat
OP
Member
Joined
Dec 4, 2016
Messages
267
Trophies
0
XP
1,203
Country
United Kingdom
I bought a licence for Horizon Zero Dawn from someone who bought a graphics card with it bundled. I started it and IIRC it crashed during the optimisation (building shader cache) step. I found a pre-built set of shaders (from someone with a dedicated graphics card) https://www.nexusmods.com/horizonzerodawn/mods/3?tab=files and copied them to LocalCacheDX12 in the game's folder. I was then able to get to the title screen without my computer building its own shader cache, running out of memory and crashing. Performance was poor as expected, even on minimum graphics settings, as my computer is a 2017 MacBook Pro with integrated Intel Iris 650 graphics, running the latest Windows 10 via Boot Camp. So I looked into improving things by making sure my GPU drivers were up to date (i had version 27.20.100.7990 and updated to the current 27.20.100.8587 from https://downloadcenter.intel.com/download/29808/Intel-Graphics-Windows-10-DCH-Drivers?product=98912 [which no longer lists 7990… it has 7985 and 8141 but not my previous 7990]) and limiting the target framerate with Special K rather than the built-in limiter. On loading the game again, it started the optimisation process again, and has not been able to get beyond 60% or so before crashing. I believe the crash happens when all my 16 GB of RAM is used.

I have tried:
re-copying the cache i downloaded before
verifying the game's files in steam
running HZD as administrator
making my page file for my internal SSD boot volume (not the external drive I keep the game on - AIUI there's no point having another page file on there) 16 GB and then 24 GB manually, as the automatic value was <1 GB.
removing the Special K .dll and .ini
reducing my display resolution before launching
downgrading the intel Graphics driver to the versions either side of 7990
upgrading to the latest 8587 again
upgrading to the latest beta version
limiting my CPU usage to 70% in advanced power settings, as I have read that full CPU usage and high GPU usage (which doesn't seem to be the case - I've looked in Task Manager and GPU usage is around 27%) during the optimisation step could be causing the crash
disabling non-vital Windows services
disconnecting wifi and temporarily disabling Windows Security's always-on scanning
adding '-no-browser' to the command of my Steam desktop shortcut to reduce the number of WebHelper processes (which otherwise take about 500 MB of memory even when I don't have any Steam windows open) and launching HZD from within Steam

but none of this has enabled me to skip the optimisation step or let it reach 100% without crashing.

AIUI the game must run the optimisation step again if you update graphics drivers. Can anyone suggest how to get the precise version I had before (7990)? Microsoft Update Catalog has the individual files for this version https://www.catalog.update.microsoft.com/Search.aspx?q=7990, but no installer, and I'm wary of replacing files manually.

Has anyone else with Intel integrated graphics managed to launch the game? Would you be able to take a copy of your LocalCacheDX12 folder and upload it somewhere I could get it?

Is there anything else I could try? Would uninstalling and reinstalling it have any different effect from verifying the files I have already?
 
Last edited by emcintosh,

nex86

Active Member
Newcomer
Joined
May 19, 2017
Messages
42
Trophies
0
Age
35
XP
94
Country
Gambia, The
install more ram. that fixed the issue on my Intel NUC 8.
it went through without crashing after upgrading from 16 to 32GB.
Although framerate is like mostly in the mid 20s with all on low and 720p but its sorta playable
 
Last edited by nex86,

ColinMacLaren

Member
Newcomer
Joined
Sep 22, 2014
Messages
9
Trophies
0
Age
37
Location
Chemnitz, Germany
XP
92
Country
Gambia, The
I have been trying for weeks in order to get it running on my GPD Win Max (i5-1035G7 with Iris Plus Graphics).

It always crashes at 73% shader compiling. I also tired increasing the Page Size Limit by 32GB, which did not do anything. I also disabled my dedicated graphics card on my desktop PC with 32 GB RAm and an i7 10700k, but it still did not compile.

Can you send me/us your shader cache file and tell us which driver version you have been using? Or is your NUC one of those that have an Radeon RX Vega M GPU?
 
Last edited by ColinMacLaren,

emcintosh

On the internet, everyone knows I'm a cat
OP
Member
Joined
Dec 4, 2016
Messages
267
Trophies
0
XP
1,203
Country
United Kingdom
I have been trying for weeks in order to get it running on my GPD Win Max (i5-1035G7 with Iris Plus Graphics).

It always crashes at 73% shader compiling. I also tired increasing the Page Size Limit by 32GB, which did not do anything. I also disabled my dedicated graphics card on my desktop PC with 32 GB RAm and an i7 10700k, but it still did not compile.

Can you send me/us your shader cache file and tell us which driver version you have been using? Or is your NUC one of those that have an Radeon RX Vega M GPU?

It might be worth trying again - the 1.07 patch changes how the shader compilation works, supposedly making it optional (presumably it does it more slowly in the background? Or at least lets you get to the main menu).

I'm afraid I solved my problem by getting an external GPU, which doesn't really help anyone else who had the same problem as me…
 
General chit-chat
Help Users
    Veho @ Veho: Apply orally for Aspergers, apply rectally for COVID.