Help! My 3DS won't load homebrew!

Discussion in '3DS - Homebrew Development and Emulators' started by Ledbylight, Jun 24, 2017.

  1. Ledbylight
    OP

    Ledbylight Advanced Member

    Newcomer
    69
    5
    May 24, 2017
    United States
    Hi! I followed the guide at 3ds.guide for my New Nintendo 3DS XL. Original firmware was 11.0.3.6 (or something close to that). I used soundhax to get into homebrew, got AL9H (armloader9hax, idk what the abbreviation is) working and installed Luma CFW v8.0. Then I updated via System Settings (to the latest firmware from Nintendo) All sucedded and I used the Download Play application to launch the homebrew app. Now none of my homebrew apps launch! Everything I've tried (Decrypt9, FBI, and all other stuff) just won't work. I can post .dmp logs if needed. Thanks!
     


  2. godreborn

    godreborn GBAtemp Addict

    Member
    2,695
    468
    Oct 10, 2009
    United States
    luma 8.0 doesn't work with a9lh. r u sure that's what u have?
     
  3. Ledbylight
    OP

    Ledbylight Advanced Member

    Newcomer
    69
    5
    May 24, 2017
    United States
    Oh um yeah I followed that guide and when I hold select during boot it says "Luma v8.0"
     
  4. godreborn

    godreborn GBAtemp Addict

    Member
    2,695
    468
    Oct 10, 2009
    United States
    do u get an error message? what happens when u try to load one of those apps?
     
  5. Ledbylight
    OP

    Ledbylight Advanced Member

    Newcomer
    69
    5
    May 24, 2017
    United States
    Here is a pic when trying to load Decrypt9, although it's the same for every app (idk about all those numbers though).
     

    Attached Files:

  6. godreborn

    godreborn GBAtemp Addict

    Member
    2,695
    468
    Oct 10, 2009
    United States
    I think luma 8.0 is buggy for a number of users. I've personally not encountered any errors by updating, but I also don't play on my 3ds very often. I ran freeshop earlier today, and it updated and ran just fine. I'm not sure if anyone knows y this affects certain people, a lot of people by the looks of it, so u might try updating luma to an hourly build. those are essentially betas before a proper release can be done.
     
  7. Ledbylight
    OP

    Ledbylight Advanced Member

    Newcomer
    69
    5
    May 24, 2017
    United States
    Ah ok. Testing now. And oh danget, I have B9S. So sorry!
    EDIT: Same issue using Luma Nightly.
     
    Last edited by Ledbylight, Jun 24, 2017
  8. godreborn

    godreborn GBAtemp Addict

    Member
    2,695
    468
    Oct 10, 2009
    United States
    does godmode9 work by holding start?
     
  9. Ledbylight
    OP

    Ledbylight Advanced Member

    Newcomer
    69
    5
    May 24, 2017
    United States
    Yeah, I replaced it with Decrypt9WIP, but before gm9 worked.
     
  10. godreborn

    godreborn GBAtemp Addict

    Member
    2,695
    468
    Oct 10, 2009
    United States
    try godmode9 again. remember it goes in luma/payloads . it should boot right up with no other payloads present. if u have two or more payloads present, the chainloader screen will appear.
     
  11. Ledbylight
    OP

    Ledbylight Advanced Member

    Newcomer
    69
    5
    May 24, 2017
    United States
    Ok that works, what should I try now?
     
  12. godreborn

    godreborn GBAtemp Addict

    Member
    2,695
    468
    Oct 10, 2009
    United States
    did u backup your NAND?
     
  13. Tenshi_Okami

    Tenshi_Okami GBAtemp Maniac

    Member
    1,362
    556
    Nov 3, 2015
    Puerto Rico
    If you're going to boot Decrypt9, use Luma3DS's Chainloader and not the .3dsx file.
     
  14. Ledbylight
    OP

    Ledbylight Advanced Member

    Newcomer
    69
    5
    May 24, 2017
    United States
    I did, it gave me NAND.bin and NAND.bin.sha. And yes, I use the chainloader for Decrypt9 but I need to boot FBI from the homebrew channel.
     
  15. Tenshi_Okami

    Tenshi_Okami GBAtemp Maniac

    Member
    1,362
    556
    Nov 3, 2015
    Puerto Rico
    What Homebrew Launcher are you using? Smea's or the New HBL 2.0 made for Rosalina?
     
  16. Ledbylight
    OP

    Ledbylight Advanced Member

    Newcomer
    69
    5
    May 24, 2017
    United States
    Uh I'll be honest, I don't know. How can I check?
     
  17. sleepymanakete

    sleepymanakete GBAtemp Regular

    Member
    124
    39
    Mar 10, 2016
    United States
    By the way you're entering it. If you're holding L+Down+Select, you're using Rosalina. If you're using something else to get in the launcher, you're using smea's.
     
  18. Ledbylight
    OP

    Ledbylight Advanced Member

    Newcomer
    69
    5
    May 24, 2017
    United States
    Ok I go into Download Play and hold L+Down+Select, then go to miscellaneous options, then switch current app. Then I exit the Rosalina menu, close Download Play, and volia it's the homebrew lanucher.
     
  19. XxShalevElimelechxX

    XxShalevElimelechxX GBAtemp Regular

    Member
    159
    86
    Mar 30, 2016
    Israel
    If you can load luma3ds 8.0 the you have b9s 1.2, not a9lh.
    D9WIP doesnt support b9s 1.2 currently, but you can compile the latest commit that does by yourself, or find a pre-compiled build (i found one at reddit).
     
  20. Ledbylight
    OP

    Ledbylight Advanced Member

    Newcomer
    69
    5
    May 24, 2017
    United States
    Yeah that's what I figured out. Sorry for the confusion! Oh D9WIP doesn't support the homebrew channel...
     
    Last edited by Ledbylight, Jun 24, 2017
    XxShalevElimelechxX likes this.