Help Me Decide!?

Discussion in 'EZ-Flash' started by Unoalpho, Aug 14, 2009.

Aug 14, 2009

Help Me Decide!? by Unoalpho at 5:54 PM (1,149 Views / 0 Likes) 8 replies

  1. Unoalpho
    OP

    Member Unoalpho GBAtemp Regular

    Joined:
    May 27, 2009
    Messages:
    169
    Location:
    United States
    Country:
    United States
    I had a Dstti and upgraded the dsi firmware to v1.4 =(. And then i heard this can support v1.4 and has an updatable bootloader.
    I have like $25.00 but I am not sure if I should get the EZ5i or get this really cool game. I know I can pirate the rom once it comes out,but I want to support them with the Game.
    The Game is c.o.p the recruit
    http://www.youtube.com/watch?v=LpbanBvm2dA
    http://www.youtube.com/watch?v=bqeISWI013M...feature=related
    I've been looking forward to the C.o.p Game for a month now

    On the Other Hand I had Loved my Dstti. I loved the homebrew I had on thier and my game backups
    I brought it everywhere i brought my dsi barely ever took it out.
    But with the new upraded dsi firmware i cannot play it anymore. And the EZ5i has surpassed the block so I have been looking into it.

    Plz Tell me what I should Do?
    [​IMG]
     
  2. anaxs

    Member anaxs got milk, got candy

    Joined:
    Mar 23, 2009
    Messages:
    2,208
    Location:
    your moms jeans pocket
    Country:
    Canada
    well now the ezflash v1 works on 1.4 and their the only ones who have released their update so far but i wouldnt recommend it

    u should either get ace kard 2i or m3i zero ( they will release update soon )
    but id recommend ak2i cuz ive been usin it since release and it hasnt givin me any problems
    n i wouldnt buy the game
    i would jus dowwnload it
     
  3. rommy667

    Member rommy667 GBAtemp Advanced Fan

    Joined:
    Mar 21, 2008
    Messages:
    514
    Location:
    Down the road around the corner
    Country:
    Ireland
    Get the EZVi they are the first out of the block so you know you can trust the team to react fast in the future & the new 2.0 kernal is ultra fast you cant go wrong [​IMG]
     
  4. KidIce

    Member KidIce Smart Ass

    Joined:
    Dec 22, 2005
    Messages:
    935
    Country:
    United States
    $25 is not likely to be enough to buy you a copy of The Recruit when it is released... Get an EZVi.

    Thing is though, you are probably going to need access to a pre-1.4 DSi or a DS (non i) to flash the EZVi w/ then new 1.4 compatible firmware, as I doubt the one you will get will come w/ it on there. If the person you order it from is the freakin' king of customer service they may be willing to flash it for you prior to shipping, but I wouldn't expect Deal Extreme or the like to do it. :-)

    anaxs has no idea about the quality (or lack there of) of the EZV and really shouldn't be recommending to buy one or not based on the OH SO related fact that he owns an AceKard.

    The EZFlash line has always been great stuff all the way back to their GBA carts. They've been making flash carts longer then just about anyone currently making them, so you know there not going disappear. (Really, how many orphaned cards are out there now?). Almost every review I've seen for the EZV is for old kernels and claim the EZV lacks features (eg RTS, in game guides) the other carts have or has this or that problem that has been added or fixed since... The new 2.0RC4 rocks. :-P
     
  5. Unoalpho
    OP

    Member Unoalpho GBAtemp Regular

    Joined:
    May 27, 2009
    Messages:
    169
    Location:
    United States
    Country:
    United States
    I have A Ds Phat but y do i need to have access to that when I am flashing it?
    Is it so that it can update the bootloader to work on the dsi update?
    Thanks for the advice but I am probably going to download C.o.p then when i get enough money actually Buy it
     
  6. KidIce

    Member KidIce Smart Ass

    Joined:
    Dec 22, 2005
    Messages:
    935
    Country:
    United States
    Yes that's exactly why. Somone like Kicktrading ordered and received their current stock of EZV's some time ago, and they were manufactured sometime before that (obviously). The fix was released a couple days ago, if you were to order an EZV right now you would most likely end up w/ one that wouldn't have the fix on it and need a DS that was capable of running it to do so.
     
  7. Unoalpho
    OP

    Member Unoalpho GBAtemp Regular

    Joined:
    May 27, 2009
    Messages:
    169
    Location:
    United States
    Country:
    United States
    Would I need to do this with every dsi update?
    Lol I feel like such a noob
     
  8. KidIce

    Member KidIce Smart Ass

    Joined:
    Dec 22, 2005
    Messages:
    935
    Country:
    United States
    As long as you don't update your DSi firmware to a version that blocks the EZVi before you flash working EVi firmware... No.

    Meaning don't update your DSi till one of two things happen:

    1) It's been confirmed the new DSi update does not block the EZVi
    2) If a DSi update does block the EZVi, wait for a fix to be released and flash it to the EZV before updating the DSi

    Other wise, yes, you'll need access to a DS(i) that the card will still work on to flash it when a fix is released.
     
  9. Hitsuagaya

    Member Hitsuagaya GBAtemp Regular

    Joined:
    Aug 15, 2009
    Messages:
    253
    Location:
    Somewhere
    Country:
    United States
    i wouldn't buy it just download it
     

Share This Page