[Help] a9lh -> b9s: secret_sector invalid file

Discussion in '3DS - Homebrew Development and Emulators' started by Brutalanda, Jun 10, 2017.

  1. Brutalanda
    OP

    Brutalanda Member

    Newcomer
    31
    5
    Mar 11, 2016
    Gambia, The
    Hello community,

    I'm currently trying to update my brother's 3DS from a9lh to boot9strap. I followed Plailect's guide on preparing the SD Card but everytime I launch the payload, it says "Secret Sector - invalid file".

    Things used:
    3DS: New 3DS XL, arm9loaderhax, Luma 6.6
    SafeBSInstaller 0.0.7
    Boot9strap 1.2
    Luma 8.0 firm
    Torrent client: qBittorrent 3.3.13 on Windows 10 Pro 1703

    [​IMG]

    I hope you guys can help me to install b9s :c
     


  2. Petraplexity

    Petraplexity Fidget-Spinning Spicy Memelordâ„¢

    Member
    379
    786
    Sep 5, 2015
    United States
    Over There
    The SHA256 hash is right. Are you sure the file is in the right place? It should be in the boot9strap folder. Try copying the file again.
     
  3. Brutalanda
    OP

    Brutalanda Member

    Newcomer
    31
    5
    Mar 11, 2016
    Gambia, The
    The file is in the "boot9strap" Folder and recopying does not fix the Problem.
     
  4. pandavova

    pandavova @pandavova FOLLOW ME ON TWITTER

    Member
    561
    249
    Oct 27, 2015
    Germany
    Windows 10 Pro
    Tryed several times?
    Tryed to redownload other files?
     
  5. Brutalanda
    OP

    Brutalanda Member

    Newcomer
    31
    5
    Mar 11, 2016
    Gambia, The
    Other files, no. Not sure where to get them from. I used the one linked in the guide.
     
  6. pandavova

    pandavova @pandavova FOLLOW ME ON TWITTER

    Member
    561
    249
    Oct 27, 2015
    Germany
    Windows 10 Pro
    Maybe redownload? Idk ._.
     
  7. Brutalanda
    OP

    Brutalanda Member

    Newcomer
    31
    5
    Mar 11, 2016
    Gambia, The
    Petraplexity said the SHA265 hash is correct, meaning that the file has been downloaded without errors.
     
    Zidapi likes this.
  8. pandavova

    pandavova @pandavova FOLLOW ME ON TWITTER

    Member
    561
    249
    Oct 27, 2015
    Germany
    Windows 10 Pro
    If its not working, just try things xD
     
  9. Brutalanda
    OP

    Brutalanda Member

    Newcomer
    31
    5
    Mar 11, 2016
    Gambia, The
    redownloading does not solve my problem.
     
  10. pandavova

    pandavova @pandavova FOLLOW ME ON TWITTER

    Member
    561
    249
    Oct 27, 2015
    Germany
    Windows 10 Pro
    Sorry, when downloading all other things doesn't fix it, idk...
     
  11. GizmoTheGreen

    GizmoTheGreen GBAtemp Fan

    Member
    405
    113
    Oct 8, 2009
    can you post a screenshot of the folder?
     
  12. gnmmarechal

    gnmmarechal Kirigiri > Naoto

    Member
    GBAtemp Patron
    gnmmarechal is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,545
    2,722
    Jul 13, 2014
    Portugal
    https://gs2012.xyz
    Could it be an issue with the SD card itself?
     
    pandavova likes this.
  13. Brutalanda
    OP

    Brutalanda Member

    Newcomer
    31
    5
    Mar 11, 2016
    Gambia, The
    [​IMG]
    [​IMG]

    — Posts automatically merged - Please don't double post! —

    How can I check?
     
  14. windhazard

    windhazard GBAtemp Regular

    Member
    267
    67
    Mar 23, 2016
    Gambia, The
    Does dumping your own console's secret_sector work? With Decrypt9 for example, then use it to install BS9.
     
  15. wsquan171

    wsquan171 GBAtemp Regular

    Member
    GBAtemp Patron
    wsquan171 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    284
    89
    Feb 14, 2015
    China
    No. A9LH corrupts secret sector in a certain way to utilize it and that's why b9s needs the file containing a good sector.

    I guess OP could try using another smaller SD card only putting in files necessary for the installation. Probably the one you're using now is fragmented and the installer somehow fails to verify the file and refuse to install.
     
  16. Brutalanda
    OP

    Brutalanda Member

    Newcomer
    31
    5
    Mar 11, 2016
    Gambia, The
    I've tried a 4 GB SD Card, freshly formatted, but it still does not work.
     
  17. wsquan171

    wsquan171 GBAtemp Regular

    Member
    GBAtemp Patron
    wsquan171 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    284
    89
    Feb 14, 2015
    China
    I
    That's weird. I can also confirm the hash is correct. The file itself shouldn't be the problem.
     
  18. Petraplexity

    Petraplexity Fidget-Spinning Spicy Memelordâ„¢

    Member
    379
    786
    Sep 5, 2015
    United States
    Over There
    Hmm. This is weird.
    I think most of us are out of reasonable ideas. Maybe try using B9Sinstaller 0.0.6? Or post a picture of the error itself, if you can...

    Or update to boot9strap 1.0 first, then to 1.2.
     
    Last edited by Petraplexity, Jun 11, 2017
    wsquan171 likes this.
  19. wsquan171

    wsquan171 GBAtemp Regular

    Member
    GBAtemp Patron
    wsquan171 is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    284
    89
    Feb 14, 2015
    China
    Agreed. This is also the only thing I can think of that worths a try.
     
  20. Brutalanda
    OP

    Brutalanda Member

    Newcomer
    31
    5
    Mar 11, 2016
    Gambia, The
    SafeB9SInstaller 0.0.6 with Boot9Strap 1.0 and 1.1 also do not work.

    Edit:
    [​IMG]
     
    Last edited by Brutalanda, Jun 11, 2017