GW A9LH to (normal?)A9LH

Discussion in '3DS - Homebrew Development and Emulators' started by voddy, Jun 5, 2016.

  1. voddy
    OP

    voddy No Title Available

    Member
    250
    72
    Jul 14, 2013
    United States
    Well, I tried to setup my old3dsxl with gwa9lh.

    it went all smoothly so i m running a 4.4 a9lh gw styled.
    well.. it all does the job right... but i m a bit in doubt now and want to switch to the normal one..
    sadly .... i don't know how.

    since my sysnand is 4.4 homebrewlauncher does not work (at least not 2.x)
    so what can i do to change? it boots straight into gwa9lh - no chance of modifying it.
    it does not rely on normal bin files i guess
     
  2. Quantumcat

    Quantumcat Dead and alive

    Member
    9,804
    5,123
    Nov 23, 2014
    Australia
    Canberra, Australia
    How did you set it up? If you used Plailect's guide then used GW's arm9loaderhax.bin (as recommended) then you just have to swap it for Luma's arm9loaderhax.bin. If you set it up using all GW's stuff, unfortunately your console is now married to GW. You might be able to update your sysNAND to 9.2 using sysupdater and the launcher.dat from 4.0b (very important, any other launcher.dat will brick your console when you upgrade). Then you can access the homebrew version of Decrypt9 and restore your pre-a9lh sysNAND backup. If you don't have one of these, there's nothing you can do - you're stuck on GW forever (I could be wrong - wait and see if there's any other replies agreeing or disagreeing before you lose hope).
     
    Last edited by Quantumcat, Jun 5, 2016
  3. Hunter Guimont

    Hunter Guimont GBAtemp Fan

    Member
    331
    34
    Jan 5, 2016
    Fiji
    I think you would be able to use devmenu.3ds to install plaisysupdater and use 3dnus to update to 9.2. Install homebrewlauncherloader.ca Then use decrypt9 to restore your sysNAND.bin (Assuming you made one).
    You can also try to convert homebrewlauncherloader to .3ds and use it through your Gw card. I'm not sure if it would work, but it can't hurt to try. :)

    @Quantumcat Correct me if I am wrong please.

    — Posts automatically merged - Please don't double post! —

    I think you would be able to use devmenu.3ds to install plaisysupdater and use 3dnus to update to 9.2. Install homebrewlauncherloader.ca Then use decrypt9 to restore your sysNAND.bin (Assuming you made one).
    You can also try to convert homebrewlauncherloader to .3ds and use it through your Gw card. I'm not sure if it would work, but it can't hurt to try. :)

    @Quantumcat Correct me if I am wrong please.
     
    voddy likes this.
  4. Quantumcat

    Quantumcat Dead and alive

    Member
    9,804
    5,123
    Nov 23, 2014
    Australia
    Canberra, Australia
    Yes, this is basically what I said. Except, 3Dnus no longer has 9.2 files (they can be gotten from Plailect's guide), and it is very important to use the launcher.dat from 4.0b. I don't think a .3ds homebrew launcher would work, I'm pretty sure you can't access the homebrew launcher on less than 9.0. You can't convert from .cia to .3ds (CIA is a stripped-out .3ds), but if you had the source maybe you can compile as a .3ds.
     
  5. voddy
    OP

    voddy No Title Available

    Member
    250
    72
    Jul 14, 2013
    United States
    Okay i try. Should i Boot Gateway or Classic Mode (sysnand?) and why 4.0b and not any other ?

    I was wondering if i could try the downgrade function of Gateway launcher ( the old one) to overwrite the nand and delete a9lh of gateway

    Btw cia hblauncher is installed But cant be run. Theres no payload for 4.4. so even a 3ds version would not help
     
    Last edited by voddy, Jun 6, 2016
  6. Quantumcat

    Quantumcat Dead and alive

    Member
    9,804
    5,123
    Nov 23, 2014
    Australia
    Canberra, Australia
    It has to do with firm protection. In all Gateway releases until now, if you updated in Gateway mode you would brick. That's why 8.1J N3DS consoles were so tricky to update (no browser, no 9.0+ firmware meant no homebrew, Gateway was all they had). However 4.0b has the firm protection problem gone so that consoles could be downgraded to 2.1 and not brick. So it means you can update also (and 8.1J N3DS consoles can now be upgraded easily).
     
    voddy likes this.
  7. voddy
    OP

    voddy No Title Available

    Member
    250
    72
    Jul 14, 2013
    United States
    Oh, I see.
    makes sense sort of.
    the old downgrading used .dg files
    the new method is .bin (with title ids).

    i will try to upgrade using your method. Hope it works... would be a waste to do a hardmod just to reflash my 4.4 Nand... :s
    and theres no reliable hard modder in germany anyway...
     
  8. voddy
    OP

    voddy No Title Available

    Member
    250
    72
    Jul 14, 2013
    United States
    alright.
    i tried it now.
    I m on 9.2 now and i can access my usual homebrew launcher now.
    (so i can confirm that you indeed can update using Gateway SYSNAND Classic mode)
    So it opens up but cant access anything useful :s

    If i open Kernel - Tools like Luma or Decrypt 9 it just flashes red and returns to homebrew channel.

    i guess my firm (Native_Firm) is still old somehow.
    So i m a bit worried now... maybe i should reflash Native_Firm 9.2 alone ....? not sure if it will result in a brick ... hm... any other idea ?
     
  9. Bedel

    Bedel The key of the blade

    Member
    981
    330
    Oct 28, 2015
    Wow could it be a frankenfirmware? Never heard about it using the gateway tools. Well shit happends. Maybe you could use paisysupdater and try again idk. I still don't get hoy could you have an old firmware but you can access the hbl...
     
  10. voddy
    OP

    voddy No Title Available

    Member
    250
    72
    Jul 14, 2013
    United States
    well ... it updated some title ids and i m still having the same issue :o
    Homebrew Channel launches completely
    i can select everything and when i launch decrypt9wip it flashes red then shows some crashy white black mess and then it turns red again and i m back to homebrew channel ^^
    everything else seems to work ... strange behaviour :x

    maybe i need to update native_firm to 9.3 and downgrade somehow to 9.2 again
     
  11. memomo

    memomo ( ͡° ͜ʖ ͡°)

    Member
    1,070
    548
    Nov 30, 2013
    GW launcher menu had an option to restore NAND backup to sysNAND.. I think by pressing (up+click on downgrade).. try to restore your old NAND backup if you have one
     
    Last edited by memomo, Jun 7, 2016
    voddy likes this.
  12. voddy
    OP

    voddy No Title Available

    Member
    250
    72
    Jul 14, 2013
    United States
    Wow,
    i didnt even know about that function.
    I put my nand.bin (4.4 virgin one) onto my sd.
    pressed Up + Clicked on downgrade.
    it shows Restore System Nand.
    i clicked yes and it went through "restoring" my nand.
    it didnt show any error.
    after 100 % it said: "Done! Press a to exit"
    so i pressed a and started into Sysnand using the menu
    it booted perfectly into 4.4 sysnand
    so i shut down my 3ds and rebootet and its gone!
    fuck yeah :D
    thanks a lot! <3
     
    memomo likes this.
  13. Luglige

    Luglige Resident Hell Spawn

    Member
    1,335
    1,482
    Jan 24, 2016
    Antarctica
    under your bed
    You made the mistake of not using our savior Plailect's guide ;-;
     
  14. voddy
    OP

    voddy No Title Available

    Member
    250
    72
    Jul 14, 2013
    United States
    true... never again lol.... got away with a shot in the knee i guess ^^
     
    Luglige likes this.
  15. Luglige

    Luglige Resident Hell Spawn

    Member
    1,335
    1,482
    Jan 24, 2016
    Antarctica
    under your bed
    It's ok atleast your out of that dark dark hole!
     
    voddy likes this.