GW.3dsx black screen

Discussion in '3DS - Flashcards & Custom Firmwares' started by escequi, Jan 28, 2016.

  1. escequi
    OP

    escequi GBAtemp Regular

    Member
    292
    52
    Apr 4, 2014
    Brazil
    Osasco, Sao Paulo
    Hello guys, i'm having problems booting emunand (gateway mode) using the gw.3dsx, i ALWAYS get a black screen and it doesn't boot, tried menuhax/browserhax HBL and ctrbootmanager, same black screen and never booting (tried alot of times). Booting through go.gateway-3ds.com works fine.
    After downgrading and setting up menuhax/ctrbootmanager, it wasn't working (so i couldn't even install emunand), so someone suggested using go.gateway-3ds.com. It worked, so then i isntalled emunand and updated it to 10.5, then gw.3dsx started working for like a day, now it's back to black screen issue...

    Sysnand: 9.2 (downgraded from 10.1)
    Emunand: 10.5 (unlinked)
    Model: o3ds
    Gateway: 3.7.1

     
    Last edited by escequi, Jan 29, 2016


  2. Tomy Sakazaki

    Tomy Sakazaki GBAtemp Advanced Fan

    Member
    766
    207
    Oct 23, 2006
    Brazil
    When you launch GW.3dsx can you see the "Gateway Red Dragon" loading screen? Or your 3DS lock before that?
    And please, do post the contents of your boot.cfg file used by ctrbootmanager. I think that this forum have a CODE tag.
    Also, does you setup of menuhax and ctrbootmanager actually works to launch other things than GW.3dsx file, like the homebrew launcher .3dsx file?
     
    Last edited by Tomy Sakazaki, Jan 28, 2016
  3. escequi
    OP

    escequi GBAtemp Regular

    Member
    292
    52
    Apr 4, 2014
    Brazil
    Osasco, Sao Paulo
    Nope, no logo, black screen before that. It was working until today, nothing changed i think... ctrbootmanager works fine with hbl boot.3dsx, i haven't changed anything related to ctrbootmanager/menuhax.
    Code:
    // Boot menu configuration
    boot_config =
    {
        // Default timeout in seconds
        // If timeout = -1, disable autoboot
        timeout = 3;
    
        // Some devices (n3ds?) seems to have
        // some timing problems when using timeout=0 (autoboot).
        // You may increase this value to improve boot success rate.
        // Default delay (8) should be good for o3ds, 2 seems good for n3ds
        autobootfix = 8;
    
        // if timeout = 0 (autoboot),
        // hold this key to enter the menu
        // keycode list : https://goo.gl/4XLDIL
        recovery = 2; // SELECT
    
        // Default boot entry
        default = 0;
    
        // Boot menu entries (11 max)
        entries =
        (
            {
                title = "GatewayMode";
                path = "/3ds/GW/GW.3dsx";
            },
            {
                title  = "HomeBrewMenu";
                path = "/boot_hbl.3dsx";
            },
            {
               title  = "Reboot";
               path = "reboot"; // magic path for reboot, do not change
            },
            {
               title  = "Shutdown";
               path = "shutdown"; // magic path for poweroff, do not change
            }
        );
    
        // RGB colors
        theme =
        {
            bgTop1 = "4a0031";
            bgTop2 = "6f0149";
            bgBottom = "6f0149";
            highlight = "dcdcdc";
            borders = "ffffff";
            font1 = "ffffff";
            font2 = "000000"; // selection
            bgImgTop = "/yourimage.bin"; // 400x240 pixels
            bgImgBot = "/yourimage2.bin"; // 320x240 pixels
        };
    };
    
    Now it seems to boot at random when i hold L (it doesn't work at all when launching w/o holding L), like less than 20% boot rate, seems to boot more often if launched through HBL other than directly through ctrbootmanager... 100% boot rate so far with browser go.gateway-3ds.com. While booting through ctrbootmanager, there are times (more often than not) that it doesn't boot at all with 5+ tries, then i just give up and try with HBL, if it doesn't work i just use the browser go.gateway-3ds.com which always work. (if using either ctrbootmanager or HBL i always hold L, no sucess without gateway menu). Problem is that i want to play my games while not at home, so i won't have a internet connection to launch through the web...
     
    Last edited by escequi, Jan 29, 2016
  4. escequi
    OP

    escequi GBAtemp Regular

    Member
    292
    52
    Apr 4, 2014
    Brazil
    Osasco, Sao Paulo
    BUMP (if thats allowed :P)

    Now it seems it's not working at all, tried atleast 10 times varying from ctrbootmanager and HBL and not a single boot, as always, go.gateway-3ds.com is working flawlessly
     
    Last edited by escequi, Jan 29, 2016
  5. Columbo2811

    Columbo2811 GBAtemp Maniac

    Member
    1,279
    751
    Jul 19, 2015
    It works for me fine. is your sd ok. Pop the 3dsx on the root of your sd and edit config to remove it finding it from folder. So
    Path= /GW.3dsx and try that. Or your sd card may be faulty. That's about all the help there is.
     
  6. SockNaste

    SockNaste My Little Pony Fetish

    Banned
    301
    107
    Jan 9, 2016
    United States
    2 High To Remember
    For menuhax the .3ds that you boot it has to be 4 characters long. Exampel: loli.3dsx
     
  7. Columbo2811

    Columbo2811 GBAtemp Maniac

    Member
    1,279
    751
    Jul 19, 2015
    Only if you hex edit the payload to auto boot from menuhax. He's trying ctrbootmanager
     
    Last edited by Columbo2811, Jan 29, 2016
  8. escequi
    OP

    escequi GBAtemp Regular

    Member
    292
    52
    Apr 4, 2014
    Brazil
    Osasco, Sao Paulo
    Tried moving it, no good. How come the sd is faulty though? everything works fine except for this (which actually works sometimes). I can move stuff normally on the SD, emunand works fine and all the data on it...

    — Posts automatically merged - Please don't double post! —

    Mine works fine as is (i can boot to hbl normally with ctrbootmanager)
     
  9. Sora Takihawa

    Sora Takihawa AFF (Akiba Freedom Fighter)

    Member
    1,355
    183
    Oct 11, 2015
    Germany
    Akiba (Akihabara)
    i have a problem i have n3ds 9.2 sysnand and 10.5 emunand but reinand.3dsx gives me a blackscreen

    — Posts automatically merged - Please don't double post! —

    i need reinand because i want to play fire emblem fates with eng patch and the dlcs dont work on gw
     
  10. Columbo2811

    Columbo2811 GBAtemp Maniac

    Member
    1,279
    751
    Jul 19, 2015
    I don't no then. You could try downloading it again. But this time get the 3.6.1 release. The 3dsx is in there too. Other than that I don't know. If the launcher.dat is on sd and your under 9.3 firmware there's nothing else to suggest sorry.
     
  11. escequi
    OP

    escequi GBAtemp Regular

    Member
    292
    52
    Apr 4, 2014
    Brazil
    Osasco, Sao Paulo
    Cool, i'll try the 3.6.1 .3dsx, not sure if it's any different though
     
  12. Biff627

    Biff627 GBAtemp Maniac

    Member
    1,031
    371
    Aug 15, 2015
    United States
    By any chance did you forget to get the firmware.bin file for reinand?
    I had that problem too. When it happened alls i did was before it booted i would take the gateway card out of my 3ds and hope for the gateway logo to pop up. It booted fine for me through HBL but the card wouldnt read through ctr for some reason until I took it out while it booted into the Gateway selection area and then I would put the card back into the 3ds and then go into emunand. It eventually fixed the problem entirely but I moved onto Reinand bc Gateway just seemed weird to me.
     
  13. Sora Takihawa

    Sora Takihawa AFF (Akiba Freedom Fighter)

    Member
    1,355
    183
    Oct 11, 2015
    Germany
    Akiba (Akihabara)
    i use gw for the ingamemenu and i need reinand for fire emblem fates dlc working cause gw cant boot the dlc

    — Posts automatically merged - Please don't double post! —

    i have gw coldboot
     
  14. escequi
    OP

    escequi GBAtemp Regular

    Member
    292
    52
    Apr 4, 2014
    Brazil
    Osasco, Sao Paulo
    Removing the gw card when it starts booting (bottom screen red) actually seems to have improved boot chance, thanks, lol
     
  15. Sora Takihawa

    Sora Takihawa AFF (Akiba Freedom Fighter)

    Member
    1,355
    183
    Oct 11, 2015
    Germany
    Akiba (Akihabara)
    i think it dont work because i am on emunand
     
  16. Biff627

    Biff627 GBAtemp Maniac

    Member
    1,031
    371
    Aug 15, 2015
    United States
    Yea eventually after doing that quite often it actually started to boot up with the card in. and np
    Gateway should see the dlc? What did you use to install the dlc with? and if you go to the eshop at all the dlc will disappear and you would need to install it again
     
  17. thedude28

    thedude28 GBAtemp Advanced Fan

    Member
    527
    97
    Jul 28, 2015
    Canada
    If you can use CTRBootManager to boot into reinand then you're fine.
     
  18. escequi
    OP

    escequi GBAtemp Regular

    Member
    292
    52
    Apr 4, 2014
    Brazil
    Osasco, Sao Paulo
    Does installing game updates also does this? (through the update prompt)
     
  19. thedude28

    thedude28 GBAtemp Advanced Fan

    Member
    527
    97
    Jul 28, 2015
    Canada
    No he's trying to use modified DLC, which doesn't work with Gateway.
     
  20. Sora Takihawa

    Sora Takihawa AFF (Akiba Freedom Fighter)

    Member
    1,355
    183
    Oct 11, 2015
    Germany
    Akiba (Akihabara)
    oh man i wanted to keep gw as coldboot because i only need reinand for fire emblem fates dlc........
    (it is possible to use dlc when i boot ntr cfw in gateway)?