GBA Exploader problems on Acekard 2.1

Discussion in 'Acekard' started by Sendoh, Aug 28, 2009.

Aug 28, 2009
  1. Sendoh
    OP

    Member Sendoh GBAtemp Regular

    Joined:
    Jul 30, 2007
    Messages:
    253
    Country:
    Singapore
    I'm currently using AKAIO firmware v1.4.1 and using Gba Exploader 0.57 to load my gba games because my previous flashcart was an R4 (and because my freaking save on my NOR got deleted when I tried to load it from the AKAIO menu).

    My problem is that whenever I load up the PSRAM mode from Gba Exploader, when I select the game, the screen will freeze. This is remedied by restarting my DS and selecting the game again. The same thing happens when I try to write a game to my NOR, except this can't be remedied.

    I tried using v0.58b but NOR doesn't work, and PSRAM still has minor problems.
     
  2. Pendor

    Member Pendor GBAtemp Advanced Fan

    Joined:
    May 11, 2008
    Messages:
    567
    Country:
    United States
    AKAIO's DLDI is broken. Use the official DLDI file.
     
  3. Sendoh
    OP

    Member Sendoh GBAtemp Regular

    Joined:
    Jul 30, 2007
    Messages:
    253
    Country:
    Singapore
    I'm sorry, I don't understand. Can you elaborate?
     
  4. Another World

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    dldi is a file that allows homebrew to run on multiple flash linkers. this makes it much easier for homebre authors to get their homebrew working with the file system of your flash linker. they no longer have to compile 1 version for each card.

    if you want to learn more give these sites a read:
    http://chishm.drunkencoders.com/DLDI/
    http://dldi.drunkencoders.com/index.php?title=Main_Page

    the dldi file that comes with akaio 1.4.1 proper causes some issues, on some homebrew, for some people. a fix that you can use until akaio 1.5 is released (if it is released, thanks to jakob95) is to use the official dldi file.

    download the official acekard homebrew. you can use their website or the gbatemp download center. grab the file called "ak2_sd.dldi" from the "_ak2" folder. now drag/drop or copy/paste that file into the "_aio" directory. keep in mind that some operating systems will simply append to the old file. for best results, delete the file from the "_aio" folder and then simply drop in the official file from the "_ak2" folder.

    if you are still having issues give these files a look....
    http://gbatemp.net/index.php?download=4802 (MemTest (for Slot2 Expansions))
    http://gbatemp.net/index.php?download=3024 (Hyperlisk's NOR Eraser)

    goodluck.
    -another world
     
  5. Sendoh
    OP

    Member Sendoh GBAtemp Regular

    Joined:
    Jul 30, 2007
    Messages:
    253
    Country:
    Singapore
    I replaced the firmware, and it's working fine now. Thanks a lot guys.
     

Share This Page