Gateway 3DS, News and Information

Another World

Emulate the Planet!
OP
Former Staff
Joined
Jan 3, 2008
Messages
10,578
Trophies
0
Age
46
Location
From Where???
Website
wiki.gbatemp.net
XP
5,346
Country
Colombia
3ds-png.2833

The Gateway 3DS has gone into production and is available for pre-order. The team has reached out to me and provided a bit more information. I have quoted them below. Please read what they have to say and then discuss your opinions in this thread.

1) Yes, we are exploit based (Yay !?) and therefore very dependent on console firmware version: Our current plan is to release for firmware version 4.5 while continuing work on a solution for 6.x + after release. (please see note below)
2)Gateway will be shipped with 2 cards, the red Gateway shown in our video, which will handle 3ds backups, and a blue ds cart which will be used to prepare the console. ( more demo videos showing save game compatibility as well as setup procedures to follow soon )
3) Your console can be safely updated to 4.5 by using an original title released after March 2013 till current. Please double check the update message (version) before proceeding !

Note:
We currently have a very convenient and user friendly way to enter into our Gateway mode, while this entry point has been tested up to 6.0 we expect it to be shut off shortly after we release. We can not stress enough the importance of staying away from any further updates! ( 6.0 compatibility is only valid for our initial entry point, as stated in point (1) we currently only support firmware version 4.5 )

Update 7/12/13
The Gateway 3DS team has reached out once again to answer some questions. Instead of making a new thread I am simply going to quote their comments as an update to this news post.

For save game, we are transferring and saving the save game onto the 3DS big SD card. So it is ok to swap titles using the same micro sd card.

Currently we have tested 4.2 , 4.3 and 4.5 and they all work. All games released after March 2013 will force an update to 4.5 (even backup roms). If a console is lower than 4.2 then it will need to be updated by using an original game released after March 2013. If a console is between 4.2 and 4.5 then there is no need to update, but when a newer rom is loaded it will force the update to 4.5 (again fine).

They closed their comments by stating that the launch is only a few days away. They hope to add updated support and more features shortly after launch.

:arrow: Gateway 3DS Homepage
 

KenniesNewName

Village Idiot
Member
Joined
May 26, 2013
Messages
884
Trophies
2
Age
30
XP
569
Country
United States
Actually it's kind of smart that they're throwing an update out on a older firmware. This way tons of people won't buy it and won't have to worry about Nintendo.
 
  • Like
Reactions: pasc

mat^-1

Member
Newcomer
Joined
Jul 11, 2013
Messages
7
Trophies
0
Age
28
XP
33
Country
United States
Sometime soon hopefully.
But let me get this straight: If you have firmware 5.X or 6.X you will be able to use Gateway, but the team will not provide updates (support) your firmware?

The reason I am asking this is because I have some eShop credit left which I would like to spend on Fire Emblem DLC. But in order to buy DLC I have to be on the latest firmware. Is it a good idea to update now from 5.X to 6.X (and buy the DLC I want) before Nintendo will release another update which will not be supported by Gateway?
 

Vengenceonu

Revenge is beneath me but accidents do happen.
Member
Joined
Jun 20, 2013
Messages
2,211
Trophies
1
Location
The C Standard Library
XP
2,280
Country
United States
Their Homepage says they hopefully will rollout the first units within a fortnight (that's 14 days for those of you who weren't born in the middle ages).

Lmao they just disabled the comments on their youtube page... guess they learned from gbatemp. Shut it down before the shitstorm begins
 

Pedeadstrian

GBAtemp's Official frill-necked lizard.
Member
Joined
Oct 12, 2012
Messages
3,960
Trophies
1
Location
Sandy Eggo
XP
3,545
Country
United States
But let me get this straight: If you have firmware 5.X or 6.X you will be able to use Gateway, but the team will not provide updates (support) your firmware?

The reason I am asking this is because I have some eShop credit left which I would like to spend on Fire Emblem DLC. But in order to buy DLC I have to be on the latest firmware. Is it a good idea to update now from 5.X to 6.X (and buy the DLC I want) before Nintendo will release another update which will not be supported by Gateway?
Well, it's risky, but if you really want it, go ahead. Any time you deal with flashcards, you deal with risks.
 

Foxi4

Endless Trash
Global Moderator
Joined
Sep 13, 2009
Messages
29,392
Trophies
2
Location
Gaming Grotto
XP
27,284
Country
Poland
Before people start crying that they won't be able to launch newer games on the system I'd like to point something out. According to a certain developer, the minimum firmware version check is in the unsigned portion of the ROM and can be patched without breaking signature integrity. This means that newer ROM's could theoretically be patched to work on firmwares lower than the ones required, much like on the PS3 or the Wii. If this turns out to be true, you won't need to update your system at all (unless online interaction will require it) so practically you're good to go and the Gateway shouldn't become obsolete anytime soon, even if the loophole is patched.

Denounced after testing.
 
General chit-chat
Help Users
    KenniesNewName @ KenniesNewName: Was his name big bob behind a brick wall?