Gateway 3DS and firmware 4.1

Discussion in '3DS - Flashcards & Custom Firmwares' started by SickPuppy, Dec 22, 2013.

  1. SickPuppy
    OP

    SickPuppy New Member

    Member
    1,792
    452
    Jul 29, 2009
    United States
    I keep reading different posts of how the Gateway 3DS doesn't work correctly with firmware 4.1, but haven't seen a definitive post about why the cart don't work or what the problem is. The Gateway team says that 4.1 is compatible. My firmware is 4.1.0-6 and I believe that I don't experience any more problems that somebody with 4.5 firmware. If you have 4.1 firmware please post here what your problems are and I will see if I have the same problem too. And then somebody with 4.5 can verify that it is actually a problem with 4.1, :mellow:
     
  2. betakoopa

    betakoopa Newbie

    Newcomer
    5
    0
    Jun 12, 2010
    United States
    Firmware and region spoofing doesn't work on 4.1 firmware with gateway v2.0b1, all previous gateway releases work fine with 4.1 firmware.

    Examples:

    1) try and run a game that is not the same region as your 3DS, game won't get recognised at all (region spoofing problem)
    2) run a game that requires > 4.1 firmware, it will ask you to update your 3DS firmware (firmware spoofing problem)
     
  3. kyogre123

    kyogre123 Mexican Pride

    Member
    2,919
    1,261
    Sep 23, 2013
    Mexico
    I was talking to a person via inbox and he had the same issue as the user above described.

    He has an American 3DS in 4.1 and most of his roms are European. He said that, when using the beta launcher, the 3DS wouldn't recognise the roms of the red GW card, but after this, he tried the 1.2 launcher and they worked again.

    Let's see if they fix this issue in the next beta.
     
  4. ground

    ground GBAtemp Advanced Fan

    Member
    909
    281
    Mar 22, 2007
    Netherlands
    i have a 4.1 and experienced those problems. i am almost sure that they will fix it by the next update, cause it worked in the older releases. for now there are 2 options:

    - update to 4.2 or higher using a game rom with the update in it ( of course, go not higher than 4.5)
    - use emunand.

    i chosed to use emunand, couse i am am almost sure ( based on feeling, not confirmed) that it will be fixed, and i didnt want the effort of updating ( updating is still a possibility, and maybe 4.5 shows other issues next beta or something)
     
  5. SickPuppy
    OP

    SickPuppy New Member

    Member
    1,792
    452
    Jul 29, 2009
    United States
    You have not stated if your 3DS is on 4.1, and stop it with the beta firmware, there is a reason it is call beta. Beta firmware is for testing purposes, and not all features may work correctly. You also go on to mention that region free worked fine with stable gateway firmwares and 3DS 4.1 so we can safely say that this is not a problem with 4.1 vs 4.5 3DS firmware but more of a gateway beta firmware problem.
     
  6. betakoopa

    betakoopa Newbie

    Newcomer
    5
    0
    Jun 12, 2010
    United States
    The only issue with the 3DS 4.1 firmware is with Gateway 2.0b1 beta firmware as I have mentioned above. I have tested all other versions of Gateway firmware on a 4.1 3DS, they work fine.

    The reason people are complaining about the beta firmware is that hopefully Gateway is made aware of the issue and it is fixed in the final 2.0 firmware.
     
  7. SickPuppy
    OP

    SickPuppy New Member

    Member
    1,792
    452
    Jul 29, 2009
    United States
    I just tested a retail cart to see if I get a prompt to update. Retail Pokemon X cart don't require an update when playing with Gateway retail function and fw2.0b1, I do have the latest updated emunand installed, I cannot see the version number because it locks up when I try to enter the setting menu.
     
  8. betakoopa

    betakoopa Newbie

    Newcomer
    5
    0
    Jun 12, 2010
    United States
    This issue only happens if you are using 3DS fimware 4.1 (original NAND or emuNAND) with gateway 2.0b1. The reason you are not seeing the issue is because you have updated your emuNAND. Basically the firmware and region spoofing patches don't work on 3DS 4.1 firmware, as far as I know all other 3DS firmwares > 4.1 work OK.

    And remember this is only on the BETA Gateway v2.0b1 firmware. If you want to reproduce the problem try pokemon backup on your 4.1 system NAND in Gateway mode. Be carefull NOT to accept the update because it will update your system NAND.
     
  9. SickPuppy
    OP

    SickPuppy New Member

    Member
    1,792
    452
    Jul 29, 2009
    United States
    I have 4.1 installed and can run Luigi's Mansion on stable or beta firmwares without an update prompt. Remember that Luigi's Mansion has the 4.5 update which is higher than 4.1 that is installed. I do believe I tested with an SD card that only had the beta launcher.dat on it without the emunand partition.
     
  10. betakoopa

    betakoopa Newbie

    Newcomer
    5
    0
    Jun 12, 2010
    United States
    I just tested Luigi's Mansion now on original 4.1 NAND, it works fine with gateway v1.2 (as expected). It prompts for 4.5 update with gateway v2.0b1 (also does the same on 4.1 emuNAND).

    I wonder if this can be used to update emuNAND, that will be interesting.

    Are you sure you ran it with Gateway v2.0b1. If you keep the left shoulder button down when booting into gateway mode you should see the gateway menu come up, on gateway v1.2 it runs a hardware test instead.
     
  11. SickPuppy
    OP

    SickPuppy New Member

    Member
    1,792
    452
    Jul 29, 2009
    United States
    oh, I see. I loaded luigi's mansion with a 4.1 emunand and also get the prompt to update. I just did the update and only my emunand got updated, my real nand is still at 4.1, this would be useful to tell what update is on a retail cart, if it's higher that 4.1.

    With the 4.5.0-6 emunand on the SD card, I entered the gateway retail cartridge function and tried to play Pokemon X from a retail cart and get a prompt to update to 6.1.0-6, I'm guessing that it will update the emunand but I'm not going to try it because I don't have a tool to downgrade in case my real nand gets updated.
     
  12. ground

    ground GBAtemp Advanced Fan

    Member
    909
    281
    Mar 22, 2007
    Netherlands
    it is fixed now with the new beta released today