Question FTp Application

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by luius, Jun 5, 2018.

  1. m4xw

    m4xw Ancient Deity

    Member
    16
    May 25, 2018
    Germany
    LibnxError_BadGfxDequeueBuffer

    Don't use it docked
     
  2. Vorenu5

    Vorenu5 Newbie

    Newcomer
    4
    Dec 4, 2016
    United States
    While running the FTP server over wifi and being connected to it on my PC, my switch idled out and entered sleep mode. I have not been able to connect to the FTP server again when it is running over wifi. I have rebooted every way I can think of, tried different versions of ftpd and I am still unable to connect when using wifi. Has anyone run into a similar issue or have a possible solution to this problem? (Using hekate and FW 2.3.0 btw)
     
  3. sirAnger

    sirAnger GBAtemp Fan

    Member
    5
    Dec 4, 2002
    United States
    Michigan
    I wasn't using it docked, but it may have been plugged into my phone for hekate.
     
    Last edited by sirAnger, Jun 24, 2018
  4. aerik

    aerik Member

    Newcomer
    3
    Jan 6, 2004
    Brazil
    You have the link for the special DNS servers ?
     
  5. Vorenu5

    Vorenu5 Newbie

    Newcomer
    4
    Dec 4, 2016
    United States
    I fixed my issue by deleting the wifi network in the switch settings and adding it again :D
     
  6. morrison22

    morrison22 GBAtemp Advanced Fan

    Member
    8
    Nov 26, 2005
    United States
    nevermind
     
    Last edited by morrison22, Jun 26, 2018
  7. Drejj

    Drejj Advanced Member

    Newcomer
    4
    Dec 31, 2006
    I also get Error code 2345-0021 when transfering bigger files. Not docked. Nothing connected to USB-C port.
     
  8. sirAnger

    sirAnger GBAtemp Fan

    Member
    5
    Dec 4, 2002
    United States
    Michigan
    I'm getting that with an exfat card. Are you exfat or fat32 drejj?
     
  9. Drejj

    Drejj Advanced Member

    Newcomer
    4
    Dec 31, 2006
    exfat
     
  10. sirAnger

    sirAnger GBAtemp Fan

    Member
    5
    Dec 4, 2002
    United States
    Michigan
    I'm planning on reformatting my cart FAT32 when I get a few minutes then trying again.
     
  11. Drejj

    Drejj Advanced Member

    Newcomer
    4
    Dec 31, 2006
    Sure, worth a try. Otherwise i think we have to wait for the new version:
     
  12. m4xw

    m4xw Ancient Deity

    Member
    16
    May 25, 2018
    Germany
    Just recompiled try it
     

    Attached Files:

    • ftpd.zip
      File size:
      133.6 KB
      Views:
      1,596
  13. Drejj

    Drejj Advanced Member

    Newcomer
    4
    Dec 31, 2006
    Works. No crash. It's still very slow tho. Around 500KB/sec. 531MB took 15min 36sec to transfer.
     
  14. kavid

    kavid GBAtemp Advanced Fan

    Member
    3
    Sep 28, 2008
    Switzerland
    it works 。thank you
     
  15. hamrawk

    hamrawk Content Creator

    Member
    5
    Oct 18, 2014
    United States
    Just updated to that new file and am still getting the same error -

    [​IMG]
     
  16. morrison22

    morrison22 GBAtemp Advanced Fan

    Member
    8
    Nov 26, 2005
    United States
    The issue is definitely 100% with the hidden license file on the sd card. A format will fix it for sure if u can’t see and remove it by unhiding files.

    I know that will work because I have done it. After you format, use the updated ftpd.
     
    Last edited by morrison22, Jul 4, 2018
    Tomobobo likes this.
  17. hamrawk

    hamrawk Content Creator

    Member
    5
    Oct 18, 2014
    United States
    I thought you said OSX creates that file. I've never used OSX with this card, I don't even have access to a Mac. This is a great suggestion, but I'm hesitant because my microSD is huge and it will take a while to move everything off, format, then move everything back on. If you're SURE there's a hidden file, shouldn't there be a way to delete it on Windows? I have hidden files visible and am not seeing it, so is there some trick?
     
  18. morrison22

    morrison22 GBAtemp Advanced Fan

    Member
    8
    Nov 26, 2005
    United States
    I was using OS-X to deal with it. So I can’t say for sure in Windows. I did format the sd card in a Windows virtual machine though to avoid any issues with exFAT.

    I was also able to physically see the license file via FileZilla browser in Windows VM and OS-X and it’s size was 0. I wasn’t able to delete it via FileZilla FTP browser, so that’s when I decided to format.

    Also, in windows you want select all content on the sd card before ejecting the card and clicking properties and navigating to the check box where u can uncheck archiving... as this has been known to some users to cause further issues because it creates hidden files that are not needed by sx os.

    In the time it takes to troubleshoot though, in all honesty you could back up, format and put your files back on the card. Might as well. Cleanest solution. And prolly quickest if nothing else is working.
     
    Last edited by morrison22, Jul 4, 2018
  19. hamrawk

    hamrawk Content Creator

    Member
    5
    Oct 18, 2014
    United States
    The only license file I can see in FileZilla is 64 bytes, not 0 bytes. I deleted it anyway and am still having the same issue.

    An awesome way to prevent going forward, so thank you for that, but doesn't necessarily fix the issue at hand.
     
  20. sirAnger

    sirAnger GBAtemp Fan

    Member
    5
    Dec 4, 2002
    United States
    Michigan
    Just got around to trying this build from m4xw. Works great for me, no speed issues.
     
    morrison22 likes this.
Loading...