FreeTheWads Problem

Discussion in 'Wii - Hardware, Devices and Utilities' started by Mariko, Jul 5, 2014.

  1. Mariko
    OP

    Mariko GBAtemp Regular

    Member
    190
    113
    Oct 13, 2009
    So, I was doing some experimenting, and tried to region-convert some WADs, using freethewads program. Actually, I wanted to do some experimenting (no, not that kind of experimenting), but I couldn't get freethewads to run. I know what I'm supposed to do, and I know which files I need, but it simply does not work. The files I have are as follows:

    Code:
    cygcrypto-0.9.8.dll
    cygwin1.dll
    freethewads.c
    freethewads.exe
    FreeTheWadsGUI.exe
    I do know what each and every one of those files does. I downloaded the GUI out of desperation, and I know the "c" file is the source. I'm running this under Windows 8.1 x64, but I did try it on Windows XP x32, and got same results, or lack thereof. What's happening is this: I run the command line, and input

    Code:
    freethewads.exe mywad.wad change
    At this point I should be getting the following (where XXX are different values, depending on the game file):

    Code:
    Free the WADs *testing version* by Superken7
    
    tmd_len XXX
    Patching ...
    Region is set to XXX
    New region:
    0- JAP/NTSC-J
    1- NTSC-U
    2- PAL
    3- *FREE*
    Enter your new choice: (oh man you gotta save him!):
    What I get is this:

    Code:
    Free the WADs *testing version* by Superken7
    
    cannot open file freethewads
    I get the same result under both systems, with or without GUI (which isn't surprising, as it is just a frontend application). I did try looking for a solution, but the answers I found were utterly useless, like this one, or this one. If it matters, hashes for the executable are:

    Code:
    CRC32: 5567A9BB
    MD5:   0C3F12AB3EF6B435B51A777CAFBBBF5D
    SHA-1: E062C78B2D4E0E1E5B2A6876BD27BCA4D5941B35
    Any ideas? If you have had this problem, and you've managed to fix it, I need you. If you want to reply with "it works for me", or "try looking for another file", or "try another computer", don't bother. I didn't spend this much time looking for a solution on my own just to hear one of these. Thanks!

    P.S. - If you know of any other way of region-converting WADs, on a PC, not by installing something on the Wii itself, feel free to post it as well.

    Also, my console won't run "illegal" WADs from the SD card, only from console memory. How can I remedy that, without risking a complete brick?
     
  2. Roadrunner92

    Roadrunner92 Newbie

    Newcomer
    3
    1
    Dec 23, 2014
    Cote d'Ivoire
    Check that the Wad is not "read only" in file properties.