Firmware autoupdated by games?

Discussion in '3DS - Flashcards & Custom Firmwares' started by nicko, Jul 22, 2014.

  1. nicko
    OP

    nicko GBATemp Ha Do Ken

    Member
    558
    1
    Oct 24, 2002
    France
    France
    Hi all,
    I've just bought a black 3DS XL with 4.5.0-10E firmware and planning to buy a Gateway in a few days.

    But, I'm also planning to buy Mario Kart 7 tomorrow.
    And before that, I'd like to know if the game will auto-update the 3DS firmware or not?

    Thanks for your answer! :bow:
     
  2. gamesquest1

    gamesquest1 Nabnut

    Member
    14,134
    9,478
    Sep 23, 2013
    No, mario kart is < 4.5
     
  3. drfsupercenter

    drfsupercenter Flash Cart Aficionado

    Member
    1,898
    234
    Mar 26, 2008
    United States
    It will always ask you anyway. Even if you get a newer game that requires a newer firmware, you can just use Classic Mode in the Gateway launcher to override it.
     
  4. Abcdfv

    Abcdfv What comes around goes around.

    Member
    1,453
    590
    Dec 24, 2013
    United States
    You can play retail carts in classic mode without actually having possesion of a gateway. (Still need a DS-mode cart to install the exploit though)
     
  5. nicko
    OP

    nicko GBATemp Ha Do Ken

    Member
    558
    1
    Oct 24, 2002
    France
    France
    Thanks for your answer!

    drfsupercenter and Abcdfv : Thanks also for your advices but, at the moment, I don't have DS-mode cart, waiting to order (and receive) the Gateway ;)
     
  6. drfsupercenter

    drfsupercenter Flash Cart Aficionado

    Member
    1,898
    234
    Mar 26, 2008
    United States
    Look for the version of MK7 that has the update included so you can play online :P

    It's super common here in America, but I believe if you look at the back of the box, you will see an A or a B in the product number. You want the one with a B (not sure about Europe but at least here that's how you can tell)
     
  7. jonthedit

    jonthedit GBAtemp Advanced Maniac

    Member
    1,691
    438
    May 30, 2011
    Bangladesh
    This is one of the few reasonable question relating to Gateway. Remember, read the FAQs so you don't do something stupid and lose the exploit.
     
  8. nicko
    OP

    nicko GBATemp Ha Do Ken

    Member
    558
    1
    Oct 24, 2002
    France
    France
    Which is the part of the FAQ I must not miss please?
     
  9. Abcdfv

    Abcdfv What comes around goes around.

    Member
    1,453
    590
    Dec 24, 2013
    United States
    Most of the stickies
     
  10. tjexp

    tjexp Happy New Year!

    Member
    735
    233
    May 20, 2012
    England
    MK7 needs the 1.1 update from eshop so you'll need to find a cartridge with the update built in
     
  11. gamesquest1

    gamesquest1 Nabnut

    Member
    14,134
    9,478
    Sep 23, 2013
    Yeah he will need the 1.1 patched version if he wants to play online, but the box as a way to identify would be hit and miss if he is buying the game used, in the uk at least most shops have the empty boxes out and just pick any copy to put in the box....so the box he would get would be unlikely to have the exact cart that got bought in with that box, only 100% way I know of checking would be booting it up and seeing if it says 1..1 in the corner of the multi player box on the main menu

    There's probably a sequence to the serial on the back of the carts too that would work similar to how the finding out if a console is 4.5 or lower but in reverse I.e looking for a higher serial
     
  12. noki@

    noki@ GBAtemp Regular

    Member
    118
    11
    Mar 14, 2010

    If only the FAQs were updated,,,,

    Anyway I am in the same position as the OP so the way I understand it is that if for example you buy Mario Kart (or anygame thats <4.5) then you can play it offline with no worries, however if you buy the older version then you would need a update from the store which will update your firmware to the latest.
    Is it right that in my understanding however even if you buy the older version then you can play online using the "classic mode" and play online anyway once you get a gateway card....

    I am hoping my Gateway comes soon, I ordered it now I am waiting...
    I also have a feeling that I might have to update my 3ds to at least 4.1 its coming tomorrow :)
     
  13. nicko
    OP

    nicko GBATemp Ha Do Ken

    Member
    558
    1
    Oct 24, 2002
    France
    France
    Same here ;)