Famicom

Discussion in 'Other Consoles & Oldies' started by Sheimi, Mar 26, 2014.

  1. Sheimi
    OP

    Sheimi A cute Vixen!

    Member
    1,981
    887
    Oct 22, 2009
    United States
    So, after much fiddling around with it. I got it to display either a snowy white or a pinkish snowy screen. It seems like the RF port is bad. I do have a CRT tv, but it will be a couple days before I can use it.

    Should I just go do the AV Mod or try and fix the RF?

    Pics of the board http://imgur.com/a/Wo5PW
    Pic of it on the tv http://i.imgur.com/1xmO6nU.jpg
     
  2. Foxi4

    Foxi4 On the hunt...

    pip Reporter
    23,640
    21,704
    Sep 13, 2009
    Poland
    Gaming Grotto
    Famicoms display on Japanese channel 1 - this is the equivalent of US channel 95 and 3/4 or so. It's entirely possible that your Famicom is perfectly fine and the issue is not connected to the console, rather the RF switch. Try getting your hands on an RF switch for an American NES or try to fine-tune between channels 95 and 96 if that's possible. That said, RF signal is far from perfect, so an AV mod doesn't sound like a shabby idea. More info here.
     
  3. Sheimi
    OP

    Sheimi A cute Vixen!

    Member
    1,981
    887
    Oct 22, 2009
    United States
    I do have a American RF modulator NES. Maybe mine is completely shot. I do have a NES in my closet that I am not allowed to take out of the box due to reasons. I'll see if I can get my friends cord off of him for a few hours tomorrow.
     
  4. Foxi4

    Foxi4 On the hunt...

    pip Reporter
    23,640
    21,704
    Sep 13, 2009
    Poland
    Gaming Grotto
    Consider performing the radio test in the link I attached in an edit, provided you have a radio laying around - this might make things more clear.