"Exception (DSI) occurred" error

Discussion in 'Wii - Emulation and Homebrew' started by Timbro98, May 27, 2014.

  1. Timbro98
    OP

    Timbro98 Newbie

    Newcomer
    2
    0
    May 27, 2014
    United States
    Iowa City, Iowa
    Hello,

    I'm new to this forum, and new to wii homebrew and hacking in general. I'm sorry for the long story I'm about to tell, but hopefully it will provide some context. A friend of mine helped me get a pretty sweet setup on my wii, and then the other day I pretty much ruined it, and now I am living far away from him so I have to fix it on my own.

    I had set up HBC and I was running USB Loader GX, SNES9xgx, FCE Ultra GX, and DIOSMIOS from an external 500 GB HD. I have a white wii running version 4.3u. I had all my wii games running from an NTFS partition on my HD, and the Gamecube games running from a FAT partition on the same HD. Everything was working beautifully. The other day I was playing Super Metroid (I believe the roms for that may have also been on the FAT partition). Normally, I just save all my games in-game, and I don't remember exactly what happened, but I went to exit Super Metroid, and I pressed the home button, which brought me to a SNES9xgx menu of some sort. I think I then pressed the home button a second time, but I'm not sure. At that point I may have been prompted to save, or it may have started to save on its own. Anyway, it saved. Immediately after that, I got an error message, saying something to the effect of there not being any files. I exited to the wii menu and from that point on nothing has worked. There are no apps whatsoever displayed on HBC. Anytime I try to load USBLoader, SNES9xgx, or FCE Ultra GX, it takes me to the screen where I can select start. After selecting start, the wii loading screen appears and I'm taken back to the wii menu.

    I connected the HD to my pc, and looked at the two partitions. The NTFS partition appears fine - all my wii games appear to be intact. The FAT partition, on the other hand, had a problem. There were only two files, and they were basically gibberish. I tried using recuva, and that program found about 1250 files, but only about 350 of them were recoverable. I tried to recover them, but when recovered, they were only more of the same gibberish. Then, upon attempting to format the FAT partition to start over, I noticed that it looked like the FAT partition was now NTFS. It was like SNES 9xgx assumed the partition was NTFS and saved over the partition in that format.

    Anyway, I formatted the FAT partition, and it is now an exFAT partition (it wouldn't let me choose FAT). I loaded USBLoaderGX, SNES9xGx, and FCE Ultra GX onto the partition and tried to run it on HBC. I got an error that said "Exception (DSI) occurred". Tried it a few times but it didn't work. Any tips to getting it to work? If not, I was thinking I would use this guide to try to get USBLoader going again.

    http://gbatemp.net/threads/how-to-s...backup-wii-gamecube-and-wiiware-games.360687/

    Any other thoughts on how to get USBLoader working, or on using the above guide?

    Thank you in advance!

    Tim