Errors trying to install libwiisprite

Discussion in 'Wii - Emulation and Homebrew' started by Magicrafter13, Aug 25, 2018.

  1. Magicrafter13
    OP

    Magicrafter13 GBAtemp Regular

    Member
    2
    Feb 19, 2017
    United States
    I don't want to hear anything about how I should just figure out GX. It's not important to me right now, and this is a one-off project, I don't plan to make more Wii Homebrew.
    Anyway:
    I downloaded the latest version of libwiisprite (which iirc, hasn't been updated in years) and it said to install it, on windows anyway, to use make win. So I did, and got this error.
    Code:
    C:\Users\Matthew\Downloads\libwiisprite-0.3.0.d\libwiisprite-0.3.0.d>make win
    Installing libwiisprite for Windows...
    make: copy: Command not found
    make: *** [Makefile:36: win] Error 127
    I read somewhere I think, that the issue may be due to the fact that copy.exe isn't a thing, copy is a built in command of command prompt, which would make sense I suppose.
    So I figured since I have the Windows Linux subsystem installed or whatever it's called, I would try make linux.
    Code:
    C:\Users\Matthew\Downloads\libwiisprite-0.3.0.d\libwiisprite-0.3.0.d>make linux
    Installing libwiisprite for Linux...
    cp: cannot stat 'libpng/lib/*': No such file or directory
    make: *** [Makefile:29: linux] Error 1
    Pretty much the same error. And for the record yes, I can run both copy or cp from the command line without problem.
    The only thing I do understand here is that libpng is not a folder... and that's true, the zip file for libwiisprite did not come with a folder named libpng.

    Now I figured based on how basic the "installer" was, that it pretty much was just copying files, so I copied the stuff into C:\devkitPro\libogc
    What I mean is, there is a folder in the current directory called libwiisprite, and inside libwiisprite is an include folder and a lib folder. So those matched up with the include and lib folder in libogc.

    Now, I went into the examples, and first tried the template. It compiled fine, and ran fine in Dolphin. Then I tried the spritetest example, and here's where the problem comes in, I go to compile that one, and it compiles fine, but at the linking step it fails. Presumably due to something I did wrong with my "installation" of libwiisprite.

    Code:
    C:\Users\Matthew\Downloads\libwiisprite-0.3.0.d\libwiisprite-0.3.0.d\examples\spritetest>make
    linking ... spritetest.elf
    spritetest.o: In function `main':
    C:/Users/Matthew/Downloads/libwiisprite-0.3.0.d/libwiisprite-0.3.0.d/examples/spritetest/source/spritetest.cpp:42: undefined reference to `wsp::LayerManager::LayerManager(unsigned long)'
    C:/Users/Matthew/Downloads/libwiisprite-0.3.0.d/libwiisprite-0.3.0.d/examples/spritetest/source/spritetest.cpp:52: undefined reference to `wsp::Sprite::SetImage(wsp::Image*, unsigned long, unsigned long)'
    C:/Users/Matthew/Downloads/libwiisprite-0.3.0.d/libwiisprite-0.3.0.d/examples/spritetest/source/spritetest.cpp:53: undefined reference to `wsp::Sprite::SetImage(wsp::Image*, unsigned long, unsigned long)'
    C:/Users/Matthew/Downloads/libwiisprite-0.3.0.d/libwiisprite-0.3.0.d/examples/spritetest/source/spritetest.cpp:67: undefined reference to `wsp::Quad::SetWidth(unsigned long)'
    C:/Users/Matthew/Downloads/libwiisprite-0.3.0.d/libwiisprite-0.3.0.d/examples/spritetest/source/spritetest.cpp:68: undefined reference to `wsp::Quad::SetHeight(unsigned long)'
    C:/Users/Matthew/Downloads/libwiisprite-0.3.0.d/libwiisprite-0.3.0.d/examples/spritetest/source/spritetest.cpp:73: undefined reference to `wsp::LayerManager::Insert(wsp::Layer*, unsigned long)'
    C:/Users/Matthew/Downloads/libwiisprite-0.3.0.d/libwiisprite-0.3.0.d/examples/spritetest/source/spritetest.cpp:130: undefined reference to `wsp::LayerManager::Draw(long, long) const'
    C:/Users/Matthew/Downloads/libwiisprite-0.3.0.d/libwiisprite-0.3.0.d/examples/spritetest/source/spritetest.cpp:137: undefined reference to `wsp::LayerManager::Draw(long, long) const'
    collect2.exe: error: ld returned 1 exit status
    make[1]: *** [/opt/devkitpro/devkitPPC/wii_rules:25: /home/Matthew/Downloads/libwiisprite-0.3.0.d/libwiisprite-0.3.0.d/examples/spritetest/spritetest.elf] Error 1
    make: *** [Makefile:100: build] Error 2
    Now this shit has been out for years from what I can tell, so that tells me two things. One - it may not function as well as it used to with other possible updates to things like libogc, (though I would hope it still works fine). And two - there's gotta be someone on this forum who knows exactly what to do at this point.

    So yeah, what can I do, or what should I be checking to make sure this works?
     
Loading...