Emulators on SD Card and Roms on USB?

Discussion in 'Wii - Emulation and Homebrew' started by Phil123, Apr 20, 2017.

  1. Phil123
    OP

    Phil123 Member

    Newcomer
    12
    0
    Apr 20, 2017
    Hi,

    I downloaded the latest version of mGBA and placed the apps folder onto my SD card where all my other apps are located. I then took the mGBA folder that contains roms etc and placed that onto my USB HD. None of the roms show up and it says that my HD isn't connected despite me being able to play the Wii and GC games off of it. I don't know what I'm doing wrong. Any help would be appreciated. My HD is fat32.
     
    Last edited by Phil123, Apr 20, 2017


  2. TarkinMX

    TarkinMX GBAtemp Regular

    Member
    174
    45
    Nov 4, 2009
    United States
    I can't speak for mgba since I don't use it but I know retroarch won't see the hdd if the drive's in stealth mode, could that be your problem?
     
  3. Phil123
    OP

    Phil123 Member

    Newcomer
    12
    0
    Apr 20, 2017
    How do I check if the drives in stealth mode? I have it set to show hidden folders in windows.
     
  4. TarkinMX

    TarkinMX GBAtemp Regular

    Member
    174
    45
    Nov 4, 2009
    United States
    if you've never used ustealth then it isn't
     
  5. Phil123
    OP

    Phil123 Member

    Newcomer
    12
    0
    Apr 20, 2017
    I just tried a USB stick and it worked when using that. I guess my HD is incompatible with the Wii yet it works great with Gamecube and Wii games so maybe I can get it to work with emulators? By the way, when I pressed '1' on my wii remote on the HBC and selected USB, it would just revert back to SD when my HD was plugged in. When I tried that with my USB stick it didn't revert back to SD.
     
    Last edited by Phil123, Apr 21, 2017
  6. Byokugen

    Byokugen Unit_01

    Member
    963
    526
    May 16, 2016
    Serbia, Republic of
    Just a bit to the right, or was left...
    Just ignore me....
     
    Last edited by Byokugen, Apr 21, 2017
  7. Phil123
    OP

    Phil123 Member

    Newcomer
    12
    0
    Apr 20, 2017
    I just tried again with a different external HDD and it doesn't work with that either. Please, does anyone have any idea what I'm doing wrong or know of a guide I can follow? I just don't understand how it works with a USB stick or SD card but not an external HDD.
     
  8. Byokugen

    Byokugen Unit_01

    Member
    963
    526
    May 16, 2016
    Serbia, Republic of
    Just a bit to the right, or was left...
    How is it formated? How do you transfer games to it? Folder structure? I had some problem with external hdd, the one with it's own power supply adapter.
     
  9. ScarletDreamz

    ScarletDreamz [Debug Mode]

    Member
    2,385
    987
    Feb 16, 2015
    United States
    California
    Try VbaGX
     
  10. Byokugen

    Byokugen Unit_01

    Member
    963
    526
    May 16, 2016
    Serbia, Republic of
    Just a bit to the right, or was left...
    I second that! mGBA only reads from sd if Im not mistaken
     
  11. Phil123
    OP

    Phil123 Member

    Newcomer
    12
    0
    Apr 20, 2017
    My SD and USB are both fat32 and the HDD has 32kb clusters. I am going to use snes9x as an example as that doesn't work either:

    The SD contains my apps folder and in that folder is the snes9xgx folder that contains boot.dol, icon.png, meta.xml and readme.txt

    My HD contains the other snes9x folder that has roms, cheats and saves. I just checked the cluster size of the USB stick that worked and that is 16kb, maybe that is the problem?
     
  12. ScarletDreamz

    ScarletDreamz [Debug Mode]

    Member
    2,385
    987
    Feb 16, 2015
    United States
    California
    i have the GX emulators, and they do work without issues as this, apps on SD and roms on USB.

    But just out of curiosity, why not put the apps on the usb? apps are regularly under 10mbs.
     
  13. Phil123
    OP

    Phil123 Member

    Newcomer
    12
    0
    Apr 20, 2017
    I tried transferring the apps folder to USB but bootmii didn't work and when I clicked on the HBC it crashed. I read something about apps only booting from SD...
     
  14. Byokugen

    Byokugen Unit_01

    Member
    963
    526
    May 16, 2016
    Serbia, Republic of
    Just a bit to the right, or was left...
    Apps such as emulators work from usb.
    Why put 32k cluster? Just leave it default
     
  15. Phil123
    OP

    Phil123 Member

    Newcomer
    12
    0
    Apr 20, 2017
    I thought you needed 32k for Gamecube games? So do I create another apps folder on USB and just put the emulators there?
     
  16. Byokugen

    Byokugen Unit_01

    Member
    963
    526
    May 16, 2016
    Serbia, Republic of
    Just a bit to the right, or was left...
    Leave them on the sd, they are small, but roms you can put on the usb.
    Try GX emulators
     
  17. ScarletDreamz

    ScarletDreamz [Debug Mode]

    Member
    2,385
    987
    Feb 16, 2015
    United States
    California
    This is getting WAY out of hand.

    How old its your softmod? what version of HBC its installed? Apps can go on USB without issues. only very old apps support SD only.
     
  18. tbb043

    tbb043 Member

    Member
    1,025
    442
    Jan 30, 2008
    United States
    Wii or Wii U's Wii mode? Which USB slot are you plugging into? What exactly (including version number) are you loading Wii/GC with?
     
  19. Phil123
    OP

    Phil123 Member

    Newcomer
    12
    0
    Apr 20, 2017
    After going back to the previous HD that I was using before, it suddenly started working properly (I always plugged it into the correct port on the edge of the console near the rubber feet). I had reformatted it three times prior to that using minitool partition wizard, fat32 and 32kb clusters and the file structure was exactly the same for everything. The moment I booted it up and pressed the HBC with my GC controller it displayed no channels. The USB option on the '1' key had highlighted USB whereas before it would just revert back to SD. Very strange. I wish I could say that I changed something to fix this but I honestly don't think I did. I just unplugged everything again and loaded everything that I had backed up before and it's still working properly. Thank you to everyone that responded in this thread.
     
    Last edited by Phil123, Apr 22, 2017
  20. MarioMasta64

    MarioMasta64 welcome~

    Member
    1,539
    305
    Dec 21, 2016
    United States
    only the outer usb slot works with ios58 the one thats closer to the middle wont. just a note. (reason why im not too sure of)