DSTTi firmware update

Discussion in 'NDS - Flashcarts and Accessories' started by JohnPeter, May 17, 2014.

  1. JohnPeter
    OP

    JohnPeter Newbie

    Newcomer
    5
    0
    May 17, 2014
    Mexico
    The problem start when I update my console DSi, I have a fake ttdsi, when I update my ttdsi I note that I can't play after that because a message appear saying to turn off the console and consulting the manual

    I look how to fix that problem and I found I need a firmware update, I spent a lot of time looking for an update that would not damage my fake card, but I dont found nothing

    I'm looking for a patch .nds for the DSi version 1.4.5U, if you can leave a link I would appreciate it a lot
    Please answer as fast as you could, if you have an answer of my dstti say it to me

    The only page I found is this http://www.r4wood.com/pages/TTi-DSTT-Kernel.html but the last patch is for the 1.4.3 but I don't know if it work with the 1.4.5U, I dont think so because I read about an 1.4.4 but I dont found it, so please answer
     
  2. 4coolday

    4coolday Member

    Newcomer
    48
    4
    Jul 21, 2009
    Switzerland
    DSTTi is a dead card, haven't updated for years.
    And can't support your V1.4.5.

    You'd better choose the R4i gold 3Ds instead.
     
  3. Rizzorules

    Rizzorules "What are you doing?" "Something unexpected."

    Member
    917
    366
    Aug 17, 2013
    Netherlands
    I would buy a Dstwo is the best Ds Flashcard in the market . Good luck
     
  4. JohnPeter
    OP

    JohnPeter Newbie

    Newcomer
    5
    0
    May 17, 2014
    Mexico
    Well, thanks for answering my question but I have a similar problem, my sister have the same problem she update the console, shes's TTDSi is fake, and she can not play with the DSTTi but she's DSi version is the 1.4.3U, so when I was reading I check and DSTTi make an update or a patch for the versions who has 1.4.3, so if you know a link to fix this problem i will appreciate it to much
    Answer please :)
     
  5. JohnPeter
    OP

    JohnPeter Newbie

    Newcomer
    5
    0
    May 17, 2014
    Mexico
    But, did they reached to make an update or a patch for the 1.4.3 (I'm referring to the .nds file for the 1.4.3)
     
  6. full-hopeness

    full-hopeness Advanced Member

    Newcomer
    53
    2
    Apr 9, 2014
    Armenia
    DSTTi has long time no update now,it can not support v1.4.5 now, recommend you buy some card which update frequently like r4i gold rts cards, it is really very popular now.