Gaming DSi XL Screen Quality and Acekard Query

Bart Lemming

Gēmu Bōi mikuro
OP
Member
Joined
Feb 25, 2004
Messages
352
Trophies
0
Location
Mute City
XP
550
Country
United Kingdom
These days I tend to just use my DS Lite for NES and SMS emulation but I'm tired of the ghosting that goes on in most games.

I'm thinking of upgrading to a DSi XL as I've read that the screens are better quality. I know they're obviously bigger and therefore more pixellated. That doesn't bother me. If it did, I wouldn't be playing NES and SMS games! The thing that interests me is the screen update quality. Is the screen faster than on the DS Lite? Is the ghosting less of an issue or is that more to do with the way the emulators work?

The second question is: I have an Acekard 2i with the latest akaio installed. Can I just drop the cart into a new DSi XL and have it work as it does on my DS Lite or do I need some other version of akaio specific to the DSi?

Thanks for any advice. :)
 

ipwndeveloper

Well-Known Member
Member
Joined
Jun 3, 2013
Messages
276
Trophies
0
Age
33
Location
San Fransisco, CA
Website
gb4iphone.x10.mx
XP
169
Country
United States
Can confirm, acekard user here. If your DSi is at the latest version IT WILL NOT WORK. Look into supercarddstwo and other R4 clones, that support the latest version.

If on a dslite, or an unupgraded DSi, the acekard works brilliantly for NES emulation, not sure about SMS though.
 

metroid maniac

An idiot with an opinion
Member
Joined
May 16, 2009
Messages
1,863
Trophies
0
XP
1,257
Country
Is the ghosting less of an issue or is that more to do with the way the emulators work?

No, it's the physical screens. Can confirm from playing on my 3DS that the screens on the DS Lite are pretty bad with regards to ghosting. However, I still prefer playing some games on the DS Lite due to the small screen space offered by the 3DS with 1:1 pixel mapping, and the blurred image provided when it's scaled-to-fit.
The second question is: I have an Acekard 2i with the latest akaio installed. Can I just drop the cart into a new DSi XL and have it work as it does on my DS Lite or do I need some other version of akaio specific to the DSi?

Yes, but you need to update your bootloader by following these instructions.
http://wiki.gbatemp.net/wiki/Updating_the_AK2i_Bootloader
Even after having done that, it will only run if the DSi is on 1.4.3 and below or 1.4.4 and below, depending on your AK2i hardware revision.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    Dark_Phoras @ Dark_Phoras: Pixar Mom has got it going on