DLC BOTW not perssistent

Discussion in 'Wii U - Hacking & Backup Loaders' started by lalame, Jul 19, 2017.

  1. lalame
    OP

    lalame Member

    Newcomer
    11
    0
    Feb 7, 2017
    Antigua and Barbuda
    Hi, i'm using redNand with Haxchi (EUR wii u in 5.5.1) and i've installed zelda botw on the redNand i updated the game to the lastest version and installed the dlc (downloaded from wii u usb helper), when i install the dlc with wup installer and launch the game the content of dlc are available but when i shutdown the wii u and relaunch the game the DLC disappear and i have to install it again. how to fix this ? thanks and sorry for my bad english.
     
  2. Lush

    Lush GBAtemp Regular

    Member
    233
    119
    Jul 16, 2007
    Canada
    Ditch rednand. It's useless...
     
    dimmidice likes this.
  3. lalame
    OP

    lalame Member

    Newcomer
    11
    0
    Feb 7, 2017
    Antigua and Barbuda
    redNand is fine for me i just want to have the DLC of zelda breath of the wild, any solution ? thanks.
     
  4. Lacius

    Lacius GBAtemp Guru

    Member
    6,293
    2,582
    May 11, 2008
    United States
    You probably need to unlink your sysNAND and your redNAND. As already mentioned, however, redNAND isn't really worth the time nor effort.
     
  5. lalame
    OP

    lalame Member

    Newcomer
    11
    0
    Feb 7, 2017
    Antigua and Barbuda
    What would be the best then ?
     
  6. Lacius

    Lacius GBAtemp Guru

    Member
    6,293
    2,582
    May 11, 2008
    United States
    Edit: How long have you been using redNAND?
     
    Last edited by Lacius, Jul 19, 2017
  7. lalame
    OP

    lalame Member

    Newcomer
    11
    0
    Feb 7, 2017
    Antigua and Barbuda
    since February 2017.
     
  8. Lacius

    Lacius GBAtemp Guru

    Member
    6,293
    2,582
    May 11, 2008
    United States
    I would recommend deleting redNAND and using sysNAND, since redNAND provides no real benefit. Which version is your sysNAND on, and which version is your redNAND on?
     
  9. lalame
    OP

    lalame Member

    Newcomer
    11
    0
    Feb 7, 2017
    Antigua and Barbuda
    5.5.1 eur for both
     
  10. Lacius

    Lacius GBAtemp Guru

    Member
    6,293
    2,582
    May 11, 2008
    United States
    Well, the way I see it, you have three choices. I should also note that I have no experience doing any of this, and you should consult someone else before trying Option #2 or Option #3.
    1. Remove your redNAND partition completely and do everything on sysNAND. That will also solve your original problem, but you might have to reinstall some titles.
    2. Format either your sysNAND or your redNAND, which will unlink them. After that, your original problem should stop. If you have an NNID, I imagine you'll have to log into it again on whichever NAND you format before it will work again on either NAND.
    3. Copy your redNAND to your sysNAND, and then delete your redNAND partition. That will solve your problem, and you won't have to reinstall anything.
     
    Last edited by Lacius, Jul 20, 2017
  11. lalame
    OP

    lalame Member

    Newcomer
    11
    0
    Feb 7, 2017
    Antigua and Barbuda
    Thanks for your propositions, i'll dig them. if any one experiment cross by this post feel free to give some extra details.
     
  12. Marko76

    Marko76 GBAtemp Psycho!

    Member
    3,678
    2,067
    Aug 19, 2015
    United Kingdom
    Clydebank
    Doing number 2 is pointless as any installed game onto a hdd will not work after you unlink the Sysnand from rednand and will need to be reinstalled. This is due to the wiiu giving the hdd a unique code when you format it the first time it is plugged in.The code is stored on the hdd and SEEPROM chip on the WiiU and each time the wiiu is switched on the check that both codes match and that is also the reason the hdd will only ever work on the WiiU it was formated on. When you format sysnand to unlink the SEEPROM deletes the previous code and generates a new one and as the hdd has the old code it won't work until you reformat the hdd. Because of this the OP would just be as well ditching rednand and reinstalling everything in sysnand.
     
    Last edited by Marko76, Jul 20, 2017
  13. Lacius

    Lacius GBAtemp Guru

    Member
    6,293
    2,582
    May 11, 2008
    United States
    If OP were to format his sysNAND, sysNAND wouldn't be able to launch anything on the HDD; however, redNAND would function just fine with all of the titles currently on the HDD, and the original problem would disappear.
     
  14. Anfroid

    Anfroid GBAtemp Fan

    Member
    410
    171
    Sep 30, 2011
    United States
    Had the same issue, rednand had nothing to do with it. What I did was delete the update dlc through the settings. Then redownloaded them with wii U helper and installed them again.
     
    Lacius likes this.
  15. lalame
    OP

    lalame Member

    Newcomer
    11
    0
    Feb 7, 2017
    Antigua and Barbuda
    the game is installed on the memory card so on redNand, i'm not using an eternal hdd.

    — Posts automatically merged - Please don't double post! —

    Anfroid : in the setting i don't have the DLC juste the game, the update and the save.
     
  16. Anfroid

    Anfroid GBAtemp Fan

    Member
    410
    171
    Sep 30, 2011
    United States
    The system deleted it already. Just delete the update and redownload both the update and dlc.
     
  17. lalame
    OP

    lalame Member

    Newcomer
    11
    0
    Feb 7, 2017
    Antigua and Barbuda
    Thanks for the information i'll test it.
     
  18. Marko76

    Marko76 GBAtemp Psycho!

    Member
    3,678
    2,067
    Aug 19, 2015
    United Kingdom
    Clydebank
    [
    Oh yes you are right it seems that Mocha and haxchi now have SEEPROM emulation which they never had when rednand first came out. Sorry for the mistake I have had very little to do with rednand due to the fact it is pretty much useless lol.
     
    Last edited by Marko76, Jul 20, 2017