DIOS MIOS tries to load from DVD

Discussion in 'Wii - Backup Loaders' started by isPersonShooter, May 3, 2014.

  1. isPersonShooter
    OP

    isPersonShooter Newbie

    Newcomer
    5
    0
    May 3, 2014
    Iceland
    Buenos Aires, Argentina
    With my drive slowly dying I told myself I will get DIOS MIOS to finally work. Problem is that whenever I try to boot a game with a disc in the drive, DIOS MIOS will boot the DVD instead. With no disc in the drive it will just freeze or display "Apploader size is 0". I tried ripping my games (Metroid Prime and Mario Party 7) and with modified isos with DiscEx.
    I tried with USB loader gx r1215 and 1222. Partition is formatted to FAT32 with 32KB cluster, and set to primary. USB loader displays DIOS MIOS 2.9+ is installed.
    Am I missing something?
     
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    17,684
    8,293
    Oct 27, 2002
    France
    Engine room, learning
    install DIOS MIOS 2.10 (it will say DIOS MIOS 2.10+ in USBLoaderGX)

    It boots from Disc if the settings are wrong or if the game ISO is not found.
    Reset your gamecube settings in the loader to default values
    Try with another loader to know if the issue is the loader or your setup (try with DMBooter, it's an easy and small loader. If it doesn't work, it's your setup which is the problem)
    be sure you correctly renamed the games and folders on your HDD
    Try with DIOS MIOS Lite 2.10 and SD card.
     
    isPersonShooter likes this.
  3. isPersonShooter
    OP

    isPersonShooter Newbie

    Newcomer
    5
    0
    May 3, 2014
    Iceland
    Buenos Aires, Argentina
    I did install DIOS MIOS 2.10, yet USB loader gx displays it's "2.9+". I tried to boot Metroid Prime with DMbooter, with the same result.
     
  4. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    17,684
    8,293
    Oct 27, 2002
    France
    Engine room, learning
    I think you didn't really installed 2.10 (you though it's 2.10 but it's 2.9).

    And if it doesn't work with DMBooter either, your setup is the issue.
    Verify where your ISO are located.
    it should be
    /games/whatever you want/game.iso (the 4 letters g + a + m + e, not the game's title, and iso in lowercase)
    In the "whatever you want" part, don't use special characters, the path must not be bigger than 255 characters.

    Your FAT32 partition MUST be the first partition on your drive.
    not the first letter on windows, but the first physical partition of the drive. (but USBGX 1222 should have a check for that, if working fine).


    Try with DML+SD card if your HDD is not working.
    DM doesn't work with all HDD, and if it can't mount the partition, it can't find the game and gives "apploader is 0"
     
    isPersonShooter likes this.
  5. isPersonShooter
    OP

    isPersonShooter Newbie

    Newcomer
    5
    0
    May 3, 2014
    Iceland
    Buenos Aires, Argentina
    I changed the disc image name to game.iso. Metroid Prime 2 is working. Metroid Prime and Mario Party 7 just freeze at the DIOS MIOS screen with no error message.
     
  6. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    17,684
    8,293
    Oct 27, 2002
    France
    Engine room, learning
    At least now it detects the games correctly and don't boot the disc anymore.
    try to launch the game few time if you have freezes, sometime it's just random issue.
    Always keep a disc in the drive too, or some games will not work.
     
    isPersonShooter likes this.
  7. isPersonShooter
    OP

    isPersonShooter Newbie

    Newcomer
    5
    0
    May 3, 2014
    Iceland
    Buenos Aires, Argentina
    Thank you Cyan. The Metroid Prime rip was corrupt. The games work with a disc in the drive. Hope the drive still has some life in it.
     
  8. Jayro

    Jayro MediCat DVD and Mini Windows 10 Developer

    Member
    GBAtemp Patron
    Jayro is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,738
    2,493
    Jul 23, 2012
    United States
    Octo Canyon
    DM 2.10 flat-out refuses to install for me in ANY wad manager, even MMM. gives a ticket error. all cIOS/IOS are up to date and present. 2.8 installs, but it's old as fuck, and doesn't boot games.