CRTbootmanager freezes

Discussion in '3DS - Homebrew Development and Emulators' started by NoGamer, Mar 25, 2016.

  1. NoGamer
    OP

    NoGamer Newbie

    Decrypt9WIP.bin or emuNAND9.bin don't launch with CTRbootmanager, after i press the A button to launch app it just freezes on the menu (purple menu). Starting PastaMode, HBL, reboot and shutdown works perfect from CTRbootmanager. HBL can be launched from CTR and i can start Decrypt9WIP and emuNAND9 from HBL without problems. Apps like HBL, Decrypt9WIP, emuNAND9, CHMM2, etc works fine from HBL in PastaMode SysNAND. Current set up: MenuHax to autoboot rxTools emuNAND, press select for CTR, press L for rxTools Menu and press R to boot regular SysNAND.


    Is there anyone that has this issue in the past and now how to fix it ? I use the files from the guide of samiam144 and he say's it working fine for him. I just did the exact steps and the only thing that is not working (freezes) is CRTbootmanager. I also changed it back to the boot.3dsx file but then i can not longer launch CRT with holding select, it just boot straight to HBL menu.

    BOOT.CFG config:
    Code:
    // Boot menu configuration
    boot_config =
    {
        // Default timeout in seconds
        // If timeout = -1, disable autoboot
        timeout = 0;
    
        // Some devices (n3ds?) seems to have
        // some timing problems when using timeout=0 (autoboot).
        // You may increase this value to improve boot success rate.
        // Default delay (8) should be good for o3ds, 2 seems good for n3ds
        autobootfix = 8;
    
        // if timeout = 0 (autoboot),
        // hold this key to enter the menu
        // keycode list : https://goo.gl/4XLDIL
        recovery = 2; // Hold SELECT at boot
    
        // Default boot entry
        default = 0;
    
        // Boot menu entries (11 max)
        entries =
        (
            {
                title  = "rxTools";
                path = "/rxTools/sys/code.bin";
                offset = "0x12000";
            },
            {
                title = "PastaCFW (sysNAND)";
                path = "/3ds/PastaCFW/PastaCFW.3dsx";
                offset = "0x12000";
            },
            {
                title = "MiniPasta (= Devmode) (sysNAND)";
                path = "/3ds/MiniPasta/MiniPasta.3dsx";
                offset = "0x12000";
            },
            {
                title = "EmuNAND9";
                path = "/EmuNAND9.bin";
                offset = "0x12000";
            },
            {
                title = "Decrypt9";
                path = "/Decrypt9WIP.bin";
                offset = "0x12000";
            },
            {
                title = "Homebrew Launcher";
                path = "/boot.3dsx";
                key = 1; // Hold B at boot
            },
            {
                title  = "HomeMenu";
                path = "homemenu"; // magic path for homemenu, do not change
            },
            {
                title  = "Reboot";
                path = "reboot"; // magic path for reboot, do not change
            },
            {
                title  = "Shutdown";
                path = "shutdown"; // magic path for poweroff, do not change
            }
        );
    
        // RGB colors
        theme =
        {
            bgTop1 = "4a0031";
             bgTop2 = "6f0149";
            bgBottom = "6f0149";
            highlight = "dcdcdc";
            borders = "ffffff";
            font1 = "ffffff";
            font2 = "000000"; // selection
            bgImgTop = "/yourimage.bin"; // 400x240 pixels
            bgImgBot = "/yourimage2.bin"; // 320x240 pixels
        };
    };
    
     
    Last edited Mar 25, 2016
  2. NoGamer
    OP

    NoGamer Newbie

    Just changed the boot.cfg file a bit and edit the lines for Decrypt9WIP.bin & EmuNAND9.bin to rederict to the 3dsx files instead. Now it's working perfect. I don't have any idea why the bin files are not working but i'm just going to forget it.
     
    Last edited Mar 25, 2016