CPS2 v2.3.1, exit emulator crashing psp

Discussion in 'PSP - Hacking & Homebrew' started by Another World, Feb 20, 2013.

Feb 20, 2013
  1. Another World
    OP

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    i have a psp 3000 with 6.20 pro b10 installed. the model is 03g. i can open, load, play, cps2 games just fine. i can return to the file browser and choose new games to play. when i try the "exit emulator" option (either from the in-game menu or by pressing triangle) the hdd led stays a solid orange and then the psp crashes with a clicking sound and shuts off. i am not having this issue with nj's cps1 emu at all. i am also not having this issue with the same files running on a psp 3000 with 6.60 pro b10 installed.

    here is the vsh.txt:
    ms0:/seplugins/category_lite.prx 1
    ms0:/cxmb/cxmb.prx 1

    nothing has ever caused an issue before and nothing else on the system is causing this to happen. i tried to close the emu after i disabled the theme, but that did not change anything.

    i'm rather confused, because as i said these exact same files work great on another psp and cause absolutely no issue. that psp has the same set-up of the category plug-in. the roms have been verified against a mame dat, i know they are good.

    any suggestions?

    cheers,
    -another world
     
  2. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Category plugins have caused some homebrews to crash on exit for me, see if that's the case here too.
     
  3. Another World
    OP

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    i reloaded the files off my pc, and tested. it is still crashing when i exit.
    i disabled the plug-in and moved the cps2 folder outside the category folder, it is still crashing when i exit.

    i just found that i can exit the emu if i do not load any roms. if i load something and then try to exit (in-game or via triangle), it crashes.

    what makes absolutely no sense to me is that the files work just fine on another psp. where there any significant differences between 6.20 and 6.60 pro b10 that would explain this?

    edit:
    i just tried the unofficial mod r4, it also crashes.

    edit 2:
    it seems that i can play some games and exit, everytime. but with others it crashes. again, these same files work just fine on another psp. the only differences between the systems is which version of pro b10 was installed (6.20 permanent vs 6.60 temp)

    1944.zip 1944: The Loop Master (USA 000620) - crashes on exit
    gigawing.zip Giga Wing (USA 990222) - works perfectly fine

    -another world
     
  4. xist

    Member xist ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ

    Joined:
    Jul 14, 2008
    Messages:
    5,861
    Country:
    United Kingdom
    You may also need to consider that the 3000's don't share the same motherboard which could possibly cause some differences. If you run PSPIdent you'll be able to ascertain if there are hardware differences to consider too.
     
  5. Another World
    OP

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    [​IMG]
    *everything works

    [​IMG]
    *crashes

    is it a common issue that homebrew does not run the same across different mobo revisions? it seems if that is the case that i would have come across a cps2 report of the emu crashing upon exit.

    -another world
     
  6. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Do remember that a lot of these emulators were made before CFWs (or even homebrew) on later models (like the 3000 and Go) was even possible, so a lot of bugs with the varying motherboards and such wouldn't be found during the lifetime.

    No suggestions on a home-made fix though, other than perhaps running an alternate shell that would be returned to and seeing if that works?
     
  7. Another World
    OP

    Former Staff Another World Emulate the Planet!

    Joined:
    Jan 3, 2008
    Messages:
    10,476
    Location:
    From Where???
    Country:
    Colombia
    i reformatted the pro duo then copied back some stuff, it still crashes.

    i tried 3 unofficial builds: cps2psp_2.3.2uo, EmuCR-Uo_CPS2PSP_2.3.2, and uo_cps2psp_2.3.1_for_2k-3k-go-street_mod_r4. they all have the same problem.

    unless someone can confirm this behavior on a maching psp (same mobo, same cfw, same emu files), then i have to assume there is something i can do to fix this.

    -another world
     

Share This Page