cIOSCORP v3.3 release!

Discussion in 'Wii - Hacking' started by damysteryman, Aug 12, 2009.

Aug 12, 2009

cIOSCORP v3.3 release! by damysteryman at 2:15 AM (41,000 Views / 0 Likes) 169 replies

  1. damysteryman
    OP

    Member damysteryman I am too busy IRL these days...

    Joined:
    Oct 4, 2007
    Messages:
    1,182
    Country:
    Antarctica
    Hi everyone!

    I've been reading the posts in the previous thread, and now there's another update with more fixes:

    cIOSCORP v3.3!

    EDIT: Here is an updated README addressing 2 issues, and how to workaround them: (Animal Crossing Wii blackscreen & Mario Kart Wii #001 error)
    <!--c1--><div class='codetop'>CODE</div><div class='codemain'><!--ec1-->It finally exists!

    We, da_letter_a & damysteryman, now present to you all:

    cIOSCORP v3.3!

    What is it?
    It's a software modification for your Nintendo Wii to allow you to
    play almost all of your backup burnt Wii and GameCube games via the
    disc channel without opening your console or having to use a loader
    application.

    What's in it:
    Main Installer:
    IOS09ÂÂÂÂÂÂÂÂ= IOS33 v2834 with rev14 DIP
    IOS11 -> IOS15ÂÂÂÂ= IOS33 v2834 with rev14 DIP
    IOS17ÂÂÂÂÂÂÂÂ= IOS33 v2834 with rev14 DIP
    IOS20 -> IOS22ÂÂÂÂ= IOS33 v2834 with rev14 DIP
    IOS28ÂÂÂÂÂÂÂÂ= IOS28 v1293 with rev14 DIP
    IOS30ÂÂÂÂÂÂÂÂ= IOS33 v2834 with rev14 DIP + ES_Identify Patch
    IOS31ÂÂÂÂÂÂÂÂ= IOS31 v3092 with rev14 DIP
    IOS33ÂÂÂÂÂÂÂÂ= IOS33 v2834 with rev14 DIP
    IOS34ÂÂÂÂÂÂÂÂ= IOS34 v3091 with rev14 DIP
    IOS35ÂÂÂÂÂÂÂÂ= IOS35 v3092 with rev14 DIP + ES_Identify Patch
    IOS36ÂÂÂÂÂÂÂÂ= IOS36 v3094 with rev13b DIP + ES_Identify Patch + NAND Permissions Patch
    IOS37ÂÂÂÂÂÂÂÂ= IOS37 v3612 with rev14 DIP
    IOS38ÂÂÂÂÂÂÂÂ= cIOS249 rev13b with rev14 DIP
    IOS50ÂÂÂÂÂÂÂÂ= IOS50 v4889 with rev14 DIP + ES_Identify Patch
    IOS53ÂÂÂÂÂÂÂÂ= IOS53 v5149 with rev14 DIP
    IOS55ÂÂÂÂÂÂÂÂ= IOS55 v5149 with rev14 DIP
    IOS60ÂÂÂÂÂÂÂÂ= IOS60 v6174 with rev14 DIP + ES_Identify Patch
    All IOS have the Trucha Bug restored.
    cmios Installer (GC Mode):
    bcÂÂÂÂÂÂÂÂ= bc v5 + Trucha Bug Restored
    cmiosÂÂÂÂÂÂÂÂ= mios v4 with GC Backup Launcher embedded but
    ÂÂÂÂÂÂÂÂÂÂwith mios v9's tmd, ticket, and banner info.
    DVDX Fix Installer:
    IOS201ÂÂÂÂÂÂÂÂ= IOS36 v3094 + Trucha Bug Restored + ES_Identify Patch + NAND Permissions

    Patch
    DVDXÂÂÂÂÂÂÂÂ= DVDX, but runs under IOS201 instead of IOS36

    How to install it:
    Unpack the contents of this .zip file to your SD card and run the
    "cIOSCORP v3.3 Installer" application via the Homebrew Channel,
    sit back, and wait a few minutes. That's it!

    If you want to load backup GameCube games aswell, then run the
    "cmios Installer" application via the Homebrew Channel, after
    installing cIOSCORP v3.3. If you already have a cmios and don't
    want to change it, then don't run "cmios Installer".

    IOSes 30, 35, 36, 50, and 60 now all have the ES_Identify Patch
    in them. This fixes preloader compatibility, and should allow the
    majority of homebrew applications to identify as SU (SuperUser).
    This patch will only allow identification as SU, but not others
    like SystemMenu, so programs like AnyTitle Deleter won't be able
    to identify as SystemMenu.

    The custom DIP Modules used in cIOSCORP v3.3 do not support DVDX,
    as AFAIK the DIP Module uses a modified DVDX inside it to read
    the backup DVD-R discs, so cIOSCORP v3.3 now includes a workaround
    to this. Just run the "DVDX Fix Installer" application via the
    Homebrew Channel. This will install an unmodified IOS36 as IOS201
    and a DVDX channel that runs under said IOS201. Be aware that this
    WILL OVERRIDE ANY PREVIOUS DVDX INSTALLATION!!!

    Comment from dmm:
    "We tried to make it as noob friendly as possible. Read README,
    copy it over, run it, done! Now just pop in a disc and play!"

    FAQ:
    Does it work with LU64+ or equivalent Wiis?
    -> YES! It is the ONLY full-on disc channel loading solution for
    LU64+ and equivalent Wiis!
    cIOSCORP v1 and v2 will BRICK LU64+ (or equivalent) WIIS!

    Do I have to uninstall anything before installing this?
    -> NO!!!
    NEVER UNINSTALL OR DELETE ANY SORT OF SYSTEM FILES!
    DO NOT UNINSTALL THE SYSTEMMENU!
    DO NOT UNINSTALL ANY IOS!
    DO NOT UNINSTALL THE BC!
    DO NOT UNINSTALL THE MIOS!
    DON'T EVEN TOUCH BOOT2! (let bootmii do that, if it can)
    OR ELSE YOU WILL KILL YOUR WII!
    Just make a NAND backup if you can, then run the installer.
    THAT'S IT!

    Can I switch off or unplug the Wii during installation?
    Is there any way to cancel the installation during the install
    process?
    -> NO!!!
    DOING SO WILL KILL YOUR WII!
    Once you press "Load" in the Homebrew Channel, or load the
    "cIOSCORP v3.3 Installer" application, you can't stop the
    installation.

    Does preloader and the System Menu spaz out with a
    "System Files are corrupted" message when installed on a 3.xx Wii?
    -> Not anymore!

    My discs don't show up in the System Menu! What do I do?
    -> Try to experiment with enabling and disabling preloader hacks,
    especially if the hack's name has the words "region", "game"
    and/or "disc" in it, or maybe change your Wii's region setting.

    Does the Hackmii Installer work?
    -> It should do, now that IOS36 has the NAND Permissions Patch.
    I can't test it as it freezes on my console, unless I have the
    OLD NON-LU64+ IOS36 v1042 installed, which I refuse to use as
    using this in cIOSCORP v3.3 will break LU64+ console support.

    DVDs won't read properly in MPlayer! What do I do?
    -> The following answer is based on MPlayer_CE: try going to "Open,
    File, Wii DVD", this should mount the DVD, which you can then go
    back and select "Open, DVD Video, Play DVD", or maybe select
    "Play Title #x" instead, or you could try going to
    "Open, File, Wii DVD" and load the .VOB file you want to play.
    Or you could just select "Play DVD" and wait several minutes.

    Animal Crossing Wii blackscreens! What do I do?
    -> After hitting "Start", wait till the disc drive makes a
    second "boorp" sound, then eject the disc, then put it back in. It
    should load fine from then.

    AHHH! Mario Kart Wii gives #001 error! What do I do?
    -> You'll either have to burn the ISO onti a DVD+R and booktype
    it to DVD-ROM (DVD-R won't work). Or just load via Gecko OS.

    Does Ghostbusters work?
    -> Yes!

    Ghostbusters gives a black screen! What do I do?
    -> This should be fixed, but if not:
    Try to experiment with enabling and disabling preloader hacks,
    especially if the hack's name has the words "region", "game"
    and/or "disc". Maybe even try changing your Wii's video mode from
    NTSC to PAL, and vice versa. Make sure the iso you're using hasn't
    had a patch video mode, or been patched to use an IOS other than
    IOS53, or been patched at all. Make sure it's not a bad dump, etc.
    If I still gives a black screen, then I don't know what to do.
    Maybe there's a setting you mised and didn't change.

    Ghostbusters freezes at the Wrist Strap Health & Safety Screen!
    What do I do?
    -> According to WiiPower, this seems to be a problem with the Scene
    Release, which could be a bad dump. There is a "disc eject trick"
    that I found on gbatemp (can't remember who posted it, though.
    @Whoever discovered this, credits to you.) I have reworded it into
    steps:

    Start at the wii menu

    1. Make sure the nunchuk is connected before starting
    2. Insert disc
    3. Banner should load up in disc channel
    4. Hit Start (but be ready to hit eject)
    5. You should see the screen flicker for a second, when this
    ÂÂ happens, HIT EJECT IMMEDIATELY!
    6. It should say "Please Insert Disc blah blah blah", just wait a
    ÂÂ few seconds, then insert the disc.
    7. The game should load fine from that point.

    This might have to be tried a few times, and will need practice
    to master.

    Here's a quote from WiiPower from this thread:
    http://gbatemp.net/index.php?showtopic=123307
    "Problem category 3(heath screen freeze games)

    These games freeze at the heath screen for some users, mostly for
    people using discs and that only get 3x reading speed. There's no
    real solution for this problem yet. Some people get it to work by
    pressing certain buttons with the correct timing. And many people
    report that they get the game to load by pressing eject with the
    correct timing, and reinserting the disc when they are asked for.
    The correct timing seems to be as soon as the screen flashes white
    for the health screen. And a 3rd solution that is reported to work
    is to remove the sd card. It seems these problems are caused by
    faulty piracy releases, many people reported that a self created
    backup works flawlessly, while the 3 burns before have this issue.
    Maybe this problem is caused by scrubbing the game."

    Comment from dmm:
    "Fixing Ghostbusters compatibility really pissed us off.
    I mean REALLY. I'm assuming it pissed off the testers aswell.
    It took 5 fixes to make it work. Animal Crossing Wii worked with
    the first fix we made for it.

    If I ever see a ghost, I am going to personally bust the
    damn thing myself!"

    My Wii Speak channel doesn't work! What do I do?
    You must have installed cIOSCORP v3.1, which had a modified IOS56,
    which didn't work. Use the application "DOP-IOS" to download and
    reinstall IOS56, or you could acquire a copy of the file
    "IOS56-64-v4890.wad", and install using Wad Manager.

    This this related to the original cIOSCORP?
    No.

    Are you affiliated with any of the creators of the original
    cIOSCORP?
    No.

    Credits:
    waninkokoÂÂÂÂ- made the cIOS249 we all know and love, I used DIP
    ÂÂÂÂÂÂÂÂÂÂmodules from that to make cIOSCORP v3.3
    WiigatorÂÂÂÂ- made the cmios which is used in cIOSCORP v3.3
    WiiPowerÂÂÂÂ- for telling me about rev14's DIP Module breaking
    ÂÂÂÂÂÂÂÂÂÂDual Layer Support
    ÂÂÂÂÂÂÂÂ- for explaining the "Problem category 3
    ÂÂÂÂÂÂÂÂÂÂ(health screen freeze games)"
    icefireicefireÂÂÂÂ- made the original cIOSCORP installer, I modified
    ÂÂÂÂÂÂÂÂÂÂthat to install cIOSCORP v3.3
    WiiBlasterÂÂÂÂ- the creator of the original cIOSCORP, he let me
    ÂÂÂÂÂÂÂÂÂÂuse the name "cIOSCORP" as no other name seemed
    ÂÂÂÂÂÂÂÂÂÂto fit what this modification does
    ChokeDÂÂÂÂÂÂÂÂ- for hosting cIOSCORP v3.3

    And of course...
    All of my testers (too many to name, you all did an
    ÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂÂABSOLUTELY SUPERB JOB! Without you guys, this
    ÂÂÂÂÂÂÂÂÂÂwould never be as refined as it is now!)

    Changelog:
    v3.3ÂÂÂÂÂÂÂÂ- changed DIP Module in IOSes 30, 50, and 60 to
    ÂÂÂÂÂÂÂÂÂÂuse rev14, i.e. the true #002b error fix
    ÂÂÂÂÂÂÂÂÂÂ(Ghostbusters, etc. SSBB is unaffected)
    ÂÂÂÂÂÂÂÂ- added DVDX Fix workaround
    ÂÂÂÂÂÂÂÂ- added NAND Permissions Patch to IOS36
    ÂÂÂÂÂÂÂÂ- changed the ES_Identify patch (results didn't
    ÂÂÂÂÂÂÂÂÂÂchange, though)
    ÂÂÂÂÂÂÂÂ- removed IOS10 from the package as it is
    ÂÂÂÂÂÂÂÂÂÂunnecessary
    ÂÂÂÂÂÂÂÂ- updated the README

    v3.2ÂÂÂÂÂÂÂÂ- added the ES_Identify Patch to IOSes 30, 35,
    ÂÂÂÂÂÂÂÂÂÂand 50 (preloader fix)
    ÂÂÂÂÂÂÂÂ- fixed Animal Crossing Wii compatibility
    ÂÂÂÂÂÂÂÂ- fixed Ghostbusters compatibility as much as
    ÂÂÂÂÂÂÂÂÂÂpossible
    ÂÂÂÂÂÂÂÂ- moved cmios to use an installer separate to the
    ÂÂÂÂÂÂÂÂÂÂmain installer, for people who don't want to
    ÂÂÂÂÂÂÂÂÂÂinstall the included cmios
    ÂÂÂÂÂÂÂÂ- removed IOSes 51, 56, 57, and 61 as they are
    ÂÂÂÂÂÂÂÂÂÂunnecessary
    ÂÂÂÂÂÂÂÂ- completely overhauled the README

    v3.1ÂÂÂÂÂÂÂÂ- fixed the #001 errors many games were giving.

    v3.0ÂÂÂÂÂÂÂÂ- Unreleased, due to the amount of #001 errors.<!--c2--></div><!--ec2-->

    #002b error games should be working now!

    dmm has made a little parody jingle about fixing Ghostbusters:
    "If something's f***ed-up,
    and it aint work-ing,
    who ya gonna call?
    d-m-m!"

    Apparently I'm not allowed to post my .dol file, so you could just email this address: cioscorp@thewebpost.net . This address isnt the link, but it will send people in the right direction, so it should be legal. It hasn't been updated with v3.3 yet, so you might want to wait a while. You could try googling it, but you might not find it quickly, as it's only just been uploaded.

    Or you could just pm either me or ChokeD for the link. I've just emptied my pm inbox, so I will happily provide the link via pm (as long as I'm logged on of course!). If you know someone else who has obtained the link to cIOSCORP v3.3, try pm'ing them.

    Thanks for all the feedback on the previous versions, and aside from the "download link not allowed" problem,

    EDIT: here is a compatibility list in Excel spreadsheet form of all the games I have tested (It's not filled up yet though):
    <a href="http://www.freewebs.com/dmanspokehackland/cIOSCORP/cIOSCORP%20v3.3%20compatibility.xls" target="_blank">cIOSCORP v3.3 compatibility list</a>

    If someone could set up a compatibility list page on the gbatemp wiki, that would be great! (I'll be able to update it then)

    Anyways...
    Enjoy! *da_letter_a runs straight to inbox awaiting flood of pms*
     


  2. wiistarter

    Member wiistarter GBAtemp Fan

    Joined:
    Apr 11, 2009
    Messages:
    385
    Country:
    United Kingdom
    Excellent stuff..

    Downloading now then it will be straight onto the wii..

    Thanks again
     
  3. jjahuja

    Newcomer jjahuja Advanced Member

    Joined:
    Aug 28, 2008
    Messages:
    52
    Location:
    In your wii bricking it
    Country:
    United States
    I might update but i dont like ghostbusters... Can it shoot lasr bwams from the disk drive?


    nice song btw.
     
  4. TrickyTony

    Member TrickyTony GBAtemp Fan

    Joined:
    Oct 8, 2008
    Messages:
    372
    Country:
    United States
    Sorry if I missed this in the ReadMe... I know normally the answer is yes but I just want to double check. I just did 3.2 last night, if I want to upgrade to 3.3 all I have to do is just run this, no "undoing" from the last version required?
     
  5. Gino_Drago

    Newcomer Gino_Drago Member

    Joined:
    Mar 11, 2009
    Messages:
    26
    Country:
    United States
    Uhmmm, the mail address is still providing the link for CIOScorp V3.2.
     
  6. Nikj14

    Member Nikj14 GBAtemp Regular

    Joined:
    Jun 7, 2009
    Messages:
    100
    Country:
    Canada
    sorry for the n00b question but will there EVER be 6X loading speed supported in CIOSCORP? im guessing thats waninkokos job in the CIOSes isnt it? if so ignore that question.

    thx for the update though.
     
  7. foxgrey

    Member foxgrey GBAtemp Regular

    Joined:
    Nov 15, 2008
    Messages:
    104
    Country:
    United States
    Sweet going to upgrade my wii as soon as I get it downloaded! Thanks again
     
  8. damysteryman
    OP

    Member damysteryman I am too busy IRL these days...

    Joined:
    Oct 4, 2007
    Messages:
    1,182
    Country:
    Antarctica
    Read the rest of the post. The email link is not updated just yet, so try pm'ing someone who has it, or google it, or look in people's sigs (I know some sigs can point in the right direction)

    @TrickyTony
    Just run the new installer. Don't try undoing anything.

    And no, it's currently impossible to run discs at 6x speed with a softmod. The softmod doesn't trick the disc drive, but it just tells the wii how to handle DVD-R games (which run at 3x). The only way to run DVD-R discs at 6x is to physically modify the disc drive (this is what all of the older, non-ribbon-cable chips do)

    EDIT: I'm logging off now, so I won't be able to answer any pms until this time tomorrow. If you have already acquired a link, and somebody asks for the link, could you please provide the link to them? Thanks in advance.

    If you still can't get it though, just look down.

    |
    V
     
  9. lithium210

    Member lithium210 GBAtemp Fan

    Joined:
    Oct 16, 2003
    Messages:
    414
    Country:
    United States
    awesome, i hope this fixes any errors found in ssbb loading from disc channel.
     
  10. Shadow#1

    Member Shadow#1 Wii & 3DS Softmod Expert

    Joined:
    Nov 21, 2005
    Messages:
    3,107
    Country:
    United States
  11. LexLuthor

    Member LexLuthor GBAtemp Regular

    Joined:
    Oct 8, 2007
    Messages:
    161
    Location:
    Southampton, UK
    Country:
    United Kingdom
    Good work.
    I cant keep up with all these updates.
     
  12. nknave

    Member nknave GBAtemp Regular

    Joined:
    Jun 23, 2009
    Messages:
    154
    Country:
    Mexico
    Sweeeeeeeeeeeettt!!!!


    Ever thought of using another distribution file hosting service other than rapidshare?


    I mean, it's the most peeky service ever. MediaFire, MegaUpload rule over rapidshare.


    just my two cents.


    Thanks for the update.
    *Great Minds think alike*

    QUICK EDIT: Any way of implementing a system call directly from IOS to double the read speed on DVDRom, not necessary tricking the drive into thinking it's a Wii game, but making a system call to force the read speed at 6x without specification other than the read speed?

    Maybe I'm just halousinating(mispelled), but it's worth a thought.
     
  13. JumpMan3

    Member JumpMan3 GBAtemp Regular

    Joined:
    Aug 13, 2008
    Messages:
    114
    Country:
    United States
    I found that after taking off the start patch 4.1 wii "region free wii Discs" hack that gamecube games will load up in the disk channel like normal on CIOScorp 3.1 and 3.2.

    But after installing cIOScorp 3.3 I keep on getting a "Eject the Game Disc" error message every time I try to load up a gamecube game, even when I remove all of the start patch hacks.

    Any ideas as of why??
     
  14. thc42O

    Banned thc42O Banned

    Joined:
    Jan 3, 2009
    Messages:
    470
    Country:
    Canada
    Thanks
     
  15. jazvdb

    Member jazvdb GBAtemp Advanced Fan

    Joined:
    Jul 22, 2009
    Messages:
    835
    Location:
    In front of computer...
    Country:
    United States
    cant wait to try
     
  16. cactusjack901

    Newcomer cactusjack901 Advanced Member

    Joined:
    Feb 3, 2009
    Messages:
    83
    Country:
    United States
    I have BootMii installed as boot2 right now, would this affect my potential installation of cIOSCORP?
     
  17. L_o_N_e_R

    Member L_o_N_e_R GBAtemp Fan

    Joined:
    Jun 2, 2007
    Messages:
    413
    Country:
    United States

    it shouldnt

    thats actually a good thing
    just make a nand backup first before trying anything
     
  18. lithium210

    Member lithium210 GBAtemp Fan

    Joined:
    Oct 16, 2003
    Messages:
    414
    Country:
    United States

    well i didnt use the wiigator installer for cmios because i didnt like the launcher showing up when running a gamecube game but i instead reinstalled waninkoko's cmios 0.3 which allows my games to boot directly from the channel.
     
  19. riddle43

    Member riddle43 GBAtemp Fan

    Joined:
    Nov 21, 2008
    Messages:
    374
    Location:
    Mich USA
    Country:
    United States
    im still haveing trouble with ghost busters any help would be grate

    im on 4.1u the wan way

    preloader 29

    bootmii as ios

    and all before rev of cioscorps

    the eorror is 002 An error has occurred. Press eject button and remove the disc..

    i find it a bit odd maby my preloader is getting in the way like last time but i cant seem to fig it out
    so if it works for you and your set up is close or the same let me know what your preloader hacks are set to
    it might help so thanks heres hopeing. [​IMG] [​IMG] [​IMG] [​IMG] [​IMG] [​IMG]
     
  20. lithium210

    Member lithium210 GBAtemp Fan

    Joined:
    Oct 16, 2003
    Messages:
    414
    Country:
    United States
    another thing.. about ghostbusters i could only get it to boot with the eject trick so it must be my backup. For smash bros, it seems to be working pretty good so far, i havent encountered any crashes at the intro or during subspace emissary.

    Posts merged


    weird.. i dont get the 002 error just stuck at the nunchuk screen unless i do the eject trick itll work fine. I have the following on the wii:

    Wii 4.1U
    Cioscorp 3.3
    Preloader 0.29 (no health warning and disc updates, everything else is default)
    bootmii is on boot2

    also incase anyone is having trouble with brawl, i had a backup burned on verbatim dvd+r dl (india) burned 2.4x w/ imgburn 2.4.4.0 (pioneer 117) and it wouldnt crash constantly. So i burned it on the same media but the singapore discs and its working great so far.
     

Share This Page