Question cart reader not working post update 9.0

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by Fredfrog6, Sep 23, 2019.

  1. Fredfrog6
    OP

    Fredfrog6 Member

    Newcomer
    1
    Apr 19, 2019
    United States
    I'm trying to play some cart games, but I keep getting an error and it won't read them. I saw somewhere that changing the NoGC value to 0 could fix it, but I can't find any information on how to do that once in the BCT.ini file, and I can't seem to get it to work.
     
  2. 8BitWonder

    8BitWonder Small Homebrew Dev

    Member
    11
    Jan 23, 2016
    United States
    47 4F 54 20 45 45 4D
    In your BCT.ini:
    Under [stratosphere] add nogc = 0 to force disable nogc and update your cart-reader firmware.
     
    KlariNoX likes this.
  3. JohnathanMonkey

    JohnathanMonkey GBAtemp Advanced Fan

    Member
    4
    Apr 26, 2013
    United States
    Same issue, but it only boots to a black screen for me.

    — Posts automatically merged - Please don't double post! —

    BCT0
    [stage1]
    stage2_path = atmosphere/fusee-secondary.bin
    stage2_mtc_path = atmosphere/fusee-mtc.bin
    stage2_addr = 0xF0000000
    stage2_entrypoint = 0xF0000000

    [exosphere]
    ; Note: Disabling debugmode will cause parts of ams.tma to not work, in the future.
    debugmode = 1
    debugmode_user = 0
    ; Note: Disabling usermode exception handlers will cause atmosphere to not fail gracefully under error conditions.
    ; Support will not be provided to users who disable these. If you do not know what you are doing, leave them on.
    disable_user_exception_handlers = 0

    [stratosphere]
    ; To force-enable nogc, add nogc = 1
    nogc = 0
    Is this correct?
     
  4. TheCyberQuake

    TheCyberQuake Certified Geek

    Member
    14
    Dec 2, 2014
    United States
    Las Vegas, Nevada
    If you are using hekate, just disable auto nogc
    disabling nogc is different if you use hekate or fusee-primary, so we'll need to know which one you are using.
     
  5. laz305

    laz305 GBAtemp Regular

    Member
    3
    Jul 31, 2008
    United States
    I'm using hekate or fusee-primary so what can I do to get my cart reader to work again? here's what my BCT.ini looks like
    BCT0
    [stage1]
    stage2_path = atmosphere/fusee-secondary.bin
    stage2_addr = 0xF0000000
    stage2_entrypoint = 0xF0000000
    [exosphere]
    ; Note: Disabling debugmode will cause parts of ams.tma to not work, in the future.
    debugmode = 1
    debugmode_user = 0
    ; Note: Disabling usermode exception handlers will cause atmosphere to not fail gracefully under error conditions.
    ; Support will not be provided to users who disable these. If you do not know what you are doing, leave them on.
    disable_user_exception_handlers = 0
    [stratosphere]
    ; To force-enable nogc, add nogc = 1
    ; To force-disable nogc, add nogc = 0
     
  6. pLaYeR^^

    pLaYeR^^ Doctor Switch

    Member
    9
    GBAtemp Patron
    pLaYeR^^ is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Sep 18, 2014
    Austria
    Austria
    For fusee primary add:
    [stratosphere]
    nogc = 0

    For hekate simply enter the hekate menu and disable autonogc.
     
    KlariNoX likes this.
  7. tronlink

    tronlink Newbie

    Newcomer
    1
    Sep 26, 2019
    Mexico
    Hi, I have the same problem of not being able to read the games, I already put Off the Autonogc, and still do not want to run the games
     
  8. Depechem70

    Depechem70 Newbie

    Newcomer
    1
    Aug 11, 2018
    Germany
    Does not work for me:
    [stratosphere]
    nogc = 0

    Gamecards are not readable under 9.01.
     
Quick Reply
Draft saved Draft deleted
Loading...