Can't update R4i-SDHC 3DS RTS

Discussion in 'NDS - Flashcarts and Accessories' started by plastklær, Sep 1, 2014.

  1. plastklær
    OP

    plastklær Newbie

    Newcomer
    2
    0
    Sep 1, 2014
    I have an old R4i-SDHC 3DS RTS flashcard and i can't update it to work on my 3DS v8.0.1-19E. If I try to upgrade to a kernel higher than 1.69b (on my DSi) the option to upgrade won't appear.

    Does this mean my RTS card has the same limitations as the v4.5 card, and therefore won't work on my 3DS?

    Should I buy a new one?
     
  2. codymalach

    codymalach Newbie

    Newcomer
    6
    0
    Aug 30, 2014
    Canada
    You can try to upgrade your r4isdhc rts card on a ds lite console
     
  3. plastklær
    OP

    plastklær Newbie

    Newcomer
    2
    0
    Sep 1, 2014
    I don't have a DS lite but i tried to upgrade it on a DSi and DS phat and it didn't work
     
  4. Rezatron

    Rezatron Advanced Member

    Newcomer
    81
    8
    Oct 12, 2012
    Canada
    www.r4i-sdhc.com has a lot of similar looking cards (RTS versions included) but there are many different hardware revisions of the cards and you unfortunately have an older RTS which can't be upgraded to support newer 3DS firmwares. You need to get a new card. Fortunately Nintendo seems to have stopped blocking R4i cards this year so you probably won't have to buy another card ever after you get a new one.