Can't update from 11 to 11.1

Discussion in '3DS - Flashcards & Custom Firmwares' started by Bjnido35, Sep 20, 2016.

  1. Bjnido35
    OP

    Bjnido35 GBAtemp Regular

    Member
    146
    16
    Jan 10, 2016
    United States
    Sorry, I know there have been a couple of other threads like this, but I just don't really know where to begin with them. :/

    I have been out of the 3ds scene for a few months. Haven't done anything with my 3ds since then, been busy with other things. I am running N3DSXL with A9LH.

    Any help?

    EDIT: Try to update normally, says An error has occurred. Unable to update. The system will now be restarted.
     
    Last edited by Bjnido35, Sep 20, 2016 - Reason: Added detail about message
  2. OrGoN3

    OrGoN3 GBAtemp Addict

    Member
    2,042
    459
    Apr 23, 2007
    United States
    Then simply update your 3DS via system settings.

    Did you try updating? What is the error you receive? And no, you shouldn't have made a new thread for this.
     
  3. Bjnido35
    OP

    Bjnido35 GBAtemp Regular

    Member
    146
    16
    Jan 10, 2016
    United States
    Sorry, I should have been more clear.

    It says Updating....

    Then it says: An error has occurred. Unable to update. The system will now be restarted.
     
  4. OrGoN3

    OrGoN3 GBAtemp Addict

    Member
    2,042
    459
    Apr 23, 2007
    United States
    So many possibilities. Are you using Luma3DS? First update that to the latest and make sure to get rid of any firmware.bin files in the luma folder. Then try again. Did you make any custom mods to your home menu?
     
  5. Bjnido35
    OP

    Bjnido35 GBAtemp Regular

    Member
    146
    16
    Jan 10, 2016
    United States
    Yes to Luma, just updated that to latest (I think I did it correctly, not doing this stuff for few months makes things a little fuzzy). No firmware.bin in my luma folder. No custom mods to home menu.
     
  6. OrGoN3

    OrGoN3 GBAtemp Addict

    Member
    2,042
    459
    Apr 23, 2007
    United States
    Updating Luma3DS for A9LH is done by replacing the arm9loaderhax.bin file on your SD card with the new one.

    You aren't doing this through NTR, right? Can you go into the eShop?
     
  7. Bjnido35
    OP

    Bjnido35 GBAtemp Regular

    Member
    146
    16
    Jan 10, 2016
    United States
    Ok, did it correctly then.

    Not quite sure what you mean by NTR, but going to eShop give the message saying that an update is available and to come back after doing so.
     
  8. OrGoN3

    OrGoN3 GBAtemp Addict

    Member
    2,042
    459
    Apr 23, 2007
    United States
    And you're not using any custom DNS to block/bypass updates, right? Can you access the web browser? Basically, we want to make sure it isn't your router/firewall. DNS is typically the problem for this issue.

    Also, which version of A9LH? You could always try using recovery mode. I think the latest version of A9LH (aurora's) supports recovery mode.

    Edit: As long as you're on the latest Luma you should be able to update through recovery without losing A9LH. First check the other steps I mentioned above. Then, hold L+R+Up(Dpad)+A when booting your system. Follow prompts to update.
     
    Last edited by OrGoN3, Sep 20, 2016 - Reason: added info about recovery mode
  9. Barawer

    Barawer GBAtemp Regular

    Member
    192
    65
    Jan 3, 2016
    Iceland
    there were some reports that having modifications to the home menu causes the update to fail. do you have any?
     
    TheCyberQuake likes this.
  10. OrGoN3

    OrGoN3 GBAtemp Addict

    Member
    2,042
    459
    Apr 23, 2007
    United States
    I already asked him this and he said he didn't have any.
     
  11. Bjnido35
    OP

    Bjnido35 GBAtemp Regular

    Member
    146
    16
    Jan 10, 2016
    United States
    I never was fond of the blocking updates thing, so I don't think I ever did that. Going to web browser also asks me to update.

    How do I know what version of A9LH?
     
  12. Barawer

    Barawer GBAtemp Regular

    Member
    192
    65
    Jan 3, 2016
    Iceland
    oh lol i'm blind. sorry for that :)
     
    OrGoN3 likes this.
  13. OrGoN3

    OrGoN3 GBAtemp Addict

    Member
    2,042
    459
    Apr 23, 2007
    United States
    I edited my statement. You should be fine as Luma3DS is what makes sure A9LH doesn't get overwritten. You should try recovery mode.

    https://github.com/AuroraWright/Luma3DS/releases/tag/v5.5

    [Disclaimer: I'm not responsible if your 3DS becomes un-modded. It's just advice.]

    — Posts automatically merged - Please don't double post! —

    No worries. You're only trying to help. ^_^
     
    Last edited by OrGoN3, Sep 20, 2016
  14. Akira

    Akira I'm not a SHRIMP!!!!

    Member
    988
    330
    Apr 28, 2013
    Keep updating it, it downloads the files and continued on where the error occured. It happens to me everytime i'm doing/updating a system to the latest firmware.
     
    OrGoN3 likes this.
  15. OrGoN3

    OrGoN3 GBAtemp Addict

    Member
    2,042
    459
    Apr 23, 2007
    United States
    Then something is quite wrong with your setup. Perhaps even just the SD card. But that is not how the updates should be downloading.
     
  16. Bjnido35
    OP

    Bjnido35 GBAtemp Regular

    Member
    146
    16
    Jan 10, 2016
    United States
    Gives me message right away after trying to update via recovery.
     
  17. Akira

    Akira I'm not a SHRIMP!!!!

    Member
    988
    330
    Apr 28, 2013
    Not really, I believe this is a wifi issue or something. Most of the time I always set up a brand new device and I follow the guide to the letter. And i've done a lot of devices so I know it's not my setup
     
  18. OrGoN3

    OrGoN3 GBAtemp Addict

    Member
    2,042
    459
    Apr 23, 2007
    United States
    Just for shits and giggles, go to your system settings and then your active WiFi connection. Edit your active connection settings DNS. Primary: 8.8.8.8, secondary: 8.8.4.4 and then retry.

    — Posts automatically merged - Please don't double post! —

    It seems like it is your wireless setup that is causing issues. Do you use a custom DNS service?
     
  19. Akira

    Akira I'm not a SHRIMP!!!!

    Member
    988
    330
    Apr 28, 2013
    That I believe is the problem too, but It only happens when I'm updating from 9.2 to latest. Because I just did an update from 11.0 to 11.1 and it went smoothly. I don't know about custom DNS service, but I never touched anything on my IPS/WiFi Router since it was installed.
     
  20. Bjnido35
    OP

    Bjnido35 GBAtemp Regular

    Member
    146
    16
    Jan 10, 2016
    United States
    Same thing.