Can I make this work?

Discussion in '3DS - Flashcards & Custom Firmwares' started by kazuto, Dec 18, 2015.

  1. kazuto
    OP

    kazuto Member

    Newcomer
    13
    0
    Aug 9, 2013
    So I've been using the DSTWO for a while to play DS games and such and recently found out there is one that can play 3DS games as well, so I bought the DSTWO+. It was only once I had bought it and it was on it's way that I realised I can't play 3DS games with my 3DS being at the latest firmware. I have looked into other options and I think that the Sky3ds seems to be the best option but I'd like to know id I could still get it to work with the DSTWO+

    I'm adept with all this stuff but I know that before when I updated, I used an old DS to make my DSTWO work with the latest 3DS firmware. Is there an option like that now or is my only option to buy the Sky3ds?
     
  2. qproject

    qproject GBAtemp Regular

    Member
    239
    76
    Mar 12, 2015
    Canada
    DSTWO+ for 3ds firmware need to be 9.2 or lower. If you are going to get a sky3ds get the orange edition.
     
  3. kennyhi123

    kennyhi123 GBAtemp Regular

    Member
    183
    34
    Oct 15, 2015
    United States
    only option is sky3ds
     
  4. squee666

    squee666 Advanced Tech Pleb

    Member
    1,591
    895
    Sep 17, 2010
    Belfast
    3rd option sell the dstwo+ and your 3ds, use the money to buy a 9.2 or lower 3ds will probably work out cheaper than buying another flashcart
     
    Quantumcat likes this.
  5. subcon959

    subcon959 teh retro

    Member
    762
    457
    Dec 24, 2008
    A month ago you could've got a brand new 2.1FW O3DS from Argos for £69.99.

    I would also sell up and get a lower firmware system. At least then you have more options instead of the Sky, which for all we know will need replacing yet again down the line.
     
  6. Quantumcat

    Quantumcat Dead and alive

    Member
    11,006
    5,899
    Nov 23, 2014
    Australia
    Canberra, Australia
    If you buy a brand new sealed o3ds, o3ds xl, or 2ds (but not the Yokai watch bundle) you are guaranteed an exploitable console.