[Browserhax Error] The Internet browser cannot be used at this time...

Discussion in '3DS - Homebrew Development and Emulators' started by Ryuka, Nov 19, 2015.

  1. Ryuka
    OP

    Ryuka Member

    Newcomer
    18
    6
    Sep 11, 2015
    Mexico
    The Internet browser cannot be used at this time. Please check your network environment or try again later.

    Basically, I can't use Browserhax because a window saying that won't let me load the page for the browserhax.

    Any solutions to this or am I screwed? I'm using the DNS to block the "please update to use this" message, 9.9 O3DS.

    Thanks in advance.
     
  2. Pikasack

    Pikasack What is a title

    Member
    634
    203
    Apr 27, 2015
    Canada
    You would have to use the DNS before you even saw the update message, now you're locked out forever! Unless you got Cubic Ninja or OoT3D with Powersaves just lying around...
     
  3. Ryuka
    OP

    Ryuka Member

    Newcomer
    18
    6
    Sep 11, 2015
    Mexico
    That's not the update message, though?

    I used before going into the browser.
     
    Ammako likes this.
  4. Pikasack

    Pikasack What is a title

    Member
    634
    203
    Apr 27, 2015
    Canada
    Oops, silly me, for that I'm pretty sure it's the update message in disguise.
    But I'm not sure.
    You want to go to someone else for this error then, i wouldn't know what this would mean, what is the actual number code if i may ask?
     
    Last edited by Pikasack, Nov 19, 2015
  5. SomeGamer

    SomeGamer GBAtemp Guru

    Member
    5,793
    2,747
    Dec 19, 2014
    Hungary
    This IS the update message, sorry.
     
  6. Ryuka
    OP

    Ryuka Member

    Newcomer
    18
    6
    Sep 11, 2015
    Mexico
    No number, it just displays the message.

    @SomeGamer
    Really? Oh well, I think one of my friends have OoT anyways. Thanks.
     
    Last edited by Ryuka, Nov 19, 2015
  7. Roxie Mika

    Roxie Mika YOU'LL NEVER SEE IT COMIIIIIN'

    Member
    142
    106
    Mar 14, 2015
    United States
    Bronx, NY
    Try opening a page that doesn't load as HTTPS, like GBATemp. I would get that error when I tried to connect to Starbucks' Wi-Fi, but it was caused by trying to use sites that used HTTPS like Google.
     
  8. Ammako

    Ammako GBAtemp Guru

    Member
    6,424
    3,547
    Dec 22, 2009
    Canada
    The update message clearly mentions needing to update the system to use the browser. This is a different one.
     
    josh87402, Pacheko17 and peteruk like this.
  9. robot56

    robot56 Advanced Member

    Newcomer
    94
    31
    Sep 13, 2015
    United States
    The first time that you use the browser a connection to the update server is required - if this fails you get that error. Once you pass that check (or are caught outdated), it's cached into the browser that your clear/not clear to use the browser. Everytime you open the browser thereafter it checks to see if there's an update from the server - if there is, it prompts you to update. If it can't connect to the server, it ignores and uses the cache to check that you're clear.
     
    SomeGamer likes this.
  10. ChaosRipple

    ChaosRipple GBAtemp Regular

    Member
    260
    66
    Oct 1, 2015
    United States
    There's two messages, one that tells you that you need to update, and the other that says you can't use the browser at this time (your message). The first message occurs when your 3DS is notified by nintendo to block out your browser until you update and the second message (your message) occurs when you attempt to block the update check (using a DNS or some form of website blocking) after the 3DS already have been notified to block the browser until you update.

    So yes, this is pretty much requiring you to update and you're screwed unless you have access to another entrypoint, which you do.
     
    Last edited by ChaosRipple, Nov 19, 2015
    SomeGamer and peteruk like this.
  11. LinkSoraZelda

    LinkSoraZelda GBAtemp Advanced Maniac

    Member
    1,980
    627
    Aug 12, 2015
    United States
    Land of the Rising Orange
    This is NOT the update message. This existed long before Browserhax existed. Use another Internet connection.

    — Posts automatically merged - Please don't double post! —

    I just got it today at school, using my school's connection. I don't ever get it at home. The browser's working fine for me.
     
  12. robot56

    robot56 Advanced Member

    Newcomer
    94
    31
    Sep 13, 2015
    United States
    Not correct:

    You can replicate this by selecting "Initialize Save Data" (deletes the browser data and browser cache) on the browser with the update server blocked. The browser doesn't care if it's out of date or not as it never knows.
     
  13. ChaosRipple

    ChaosRipple GBAtemp Regular

    Member
    260
    66
    Oct 1, 2015
    United States
    That doesn't remove the data the browser stored when it was notified that an update was required. Once you get the first message, there's no way to remove it without kernel.
     
  14. robot56

    robot56 Advanced Member

    Newcomer
    94
    31
    Sep 13, 2015
    United States
    It should be stored in the browser savedata, no? See http://3dbrew.org/wiki/Internet_Browser#Forced_system-update

    It wouldn't make much sense storing it elsewhere.
     
  15. ChaosRipple

    ChaosRipple GBAtemp Regular

    Member
    260
    66
    Oct 1, 2015
    United States
    Honestly, I'm not 100% sure how everything works in the 3DS. But I can gaurantee that doing what you said doesn't remove the data. Nintendo wouldn't be that dumb enough to allow you to remove data that's meant to prevent you from hacking the 3DS. There's a whole thread on this. If we could remove that data, then browserhax would still be working. :/
     
  16. robot56

    robot56 Advanced Member

    Newcomer
    94
    31
    Sep 13, 2015
    United States
    I think you read what I said wrong, then.

    You can replicate this error on a brand new system on FW9.9+ with the update server blocked. It also wouldn't make sense to store browser save/state information in random places, that's what its savedata is for.
     
  17. ChaosRipple

    ChaosRipple GBAtemp Regular

    Member
    260
    66
    Oct 1, 2015
    United States
    I don't have a brand new system on 9.9+ so I can't replicate that. Also, this is the first time this case has been mentioned (to me at least). Your link clearly states "It is still possible to guard against this update by blocking the previous URLs using a proxy." So if you are blocking the link before you get the message, then the browser will still work for you. FYI, TubeHax DNS does not block the link in case that's what you are referring to when you mean block. And that link is talking about the Nand SaveData, we can't touch that.
     
    Last edited by ChaosRipple, Nov 19, 2015
  18. robot56

    robot56 Advanced Member

    Newcomer
    94
    31
    Sep 13, 2015
    United States
    The browser allows you to delete its savedata via "Initialize Save Data" button as I said before. You're trying to say that its stored elsewhere in NAND (or at least I was assuming) which is why I pointed out the 3Dbrew page.

    http://www.3dbrew.org/wiki/Internet_Browser#0x000200BB_savedata : see the description for 0xD8.

    So to clarify, the proxy would work *after* the cache is set and the savedata has a cached positive timestamp.
     
  19. ChaosRipple

    ChaosRipple GBAtemp Regular

    Member
    260
    66
    Oct 1, 2015
    United States
    Honestly, this whole thing is confusing me. There's a whole thread on this. What are we even disagreeing and agreeing on from the beginning? We're gonna need someone who has more of an expertise in this subject to come in.
     
  20. Stecker8

    Stecker8 Plug

    Member
    461
    120
    Oct 9, 2015
    Here
    The Internet browser cannot be used at this time. Please check your network environment or try again later. I have this problem in 10.1 O3DS. I'm using tubehax dns since tubehax works. Two weeks ago i connect to a free wifi without tubehax dns. Since this day I can 't use the browser.