Hacking Black screen when booting GameCube games from usbloaderGX

Bootkap

Member
OP
Newcomer
Joined
Aug 14, 2016
Messages
9
Trophies
0
Age
33
XP
31
Country
United States
When I use usbloadergx to boot GameCube games with nintendont I get a black screen after the nintendont loading screen. But if i use just nintendont (forcing ntsc cause of pal wii and NTSC games)then games load fine .
I've tried forcing ntsc in usbloadergx in the DM(l) + nintendont settings but when I try to boot GC games with that I get no video signal,
 

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,651
Trophies
2
Age
44
Location
Engine room, learning
XP
15,213
Country
France
USBLoaderGX only send settings to nintendont.
nintendont is the one responsible for applying them and loading the game.

if it works from HBC and not USBGX, it means one of the setting sent by the loader is different than the default setting used by nintendont from HBC.
maybe you edited some and don't remember which one.
You could look at nintendont settings (in nintendont) and see how the settings are set by default, and set the same in USBGX.


also be sure you are using USBLoaderGX r1260 (or 1261mod if you use GPT/Logical partition)
 

Bootkap

Member
OP
Newcomer
Joined
Aug 14, 2016
Messages
9
Trophies
0
Age
33
XP
31
Country
United States
USBLoaderGX only send settings to nintendont.
nintendont is the one responsible for applying them and loading the game.

if it works from HBC and not USBGX, it means one of the setting sent by the loader is different than the default setting used by nintendont from HBC.
maybe you edited some and don't remember which one.
You could look at nintendont settings (in nintendont) and see how the settings are set by default, and set the same in USBGX.


also be sure you are using USBLoaderGX r1260 (or 1261mod if you use GPT/Logical partition)
I'm using r1260 and I've got exactly the same settings in usbloadergx as I do in nintendont and still get a black screen any other ideas?
 
Last edited by Bootkap,

Cyan

GBATemp's lurking knight
Former Staff
Joined
Oct 27, 2002
Messages
23,651
Trophies
2
Age
44
Location
Engine room, learning
XP
15,213
Country
France
try an older version of nintendont (1420 was reported working) with USBLoaderGX 1260 to so see if it's a nintendont recent issue.
if older version work, then something is new in nintendont want could need a fix (in usbgx or nintendont, based on where the issue is located).

if older version doesn't work either, it's probably something from your side (even if I don't know why). without seeing or comparing nincfg.bin generated by USBLoaderGX and the one generated by nintendont, I can't tell if it's really an issues with USBLoaderGX or nintendont issue.

to generate a nincfg.bin file, you need to set the option in USBLoaderGX>loader settings>Nintendont settings : create
then run a game, exit and keep a backup of that file located in nintendont folder.
delete it from the folder, launch the same game with the same settings from [email protected] it will generate the same file (don't forget to enable autoboot to be the same setting than USBGX). now you can hexedit the two files to compare the settings.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    Sonic Angel Knight @ Sonic Angel Knight: Veho should eat a cookie :P