Homebrew Black screen running Mario Kart on USB Loader


New Member
May 20, 2021
United Kingdom
Hi, I hope someone can help!

I have set up Homebrew on my (PAL - UK) Wii. Primarily with the goal of running mario kart because the old disk has got scratched and doesn't work any more. I have ripped two disks (Wii sports and Toy Story 3) using USB Loader gx which work perfectly. However, I have failed to get mario kart to work with it always displaying a black screen and either returning me to the homebrew menu or just crashing completely.

I have tried ripping the scratched disk, this ripped very slowly but I left it overnight and it said it completed successfully. However the wbfs file black screened and when I try it on my pc with dolphin emulator it also black screened so I am working on the basis the rip was corrupt. So I also tried an NTSC downloaded wbfs (I could not find Pal wbfs for mario kart) and that does work fine on dolphin BUT black screens under usb loader gx on the wii.

I have BootMii and Priiloader set up and have tried changing settings in Priiloader (particularly region settings in case it is the NTSC file that is the issue) and I have tried changing game setting (force pal 50, set language to English and a number of other) under usb loader gx but every time it black screens.

I have tried two different usb stick and an external spinning rust HDD.

I have used D2x-cios-installer to install to slots 249, 250 and 251 and have done a SysCheck scan to check (result below) that they are set. Oddly when I first scan this they were set to v8 (despite many previous application of D2x-cios-installer to change it to v10beta52), however, I ran D2x-cios-installer once more and now have this result but still a black screen.

I have tried wiiflow (just once) and also get a black screen, just like when using usb loader gx.

I have used Wad manager to install that Wii IOS WAD Pack as per the "Fix Problems/Errors On USBLoaderGX & WiiFlow (Installing IOS WAD's)" video on youtube by "Tech James". Although, come to think about it that was before I did the SysCheck scan and found slots 249 etc all still set to v8.

I think I have tried just about everything that the internet guides etc have suggested. What have I missed? I have clearly failed in someway as if running NTSC mario kart wbfs on pal wii wasn't possible I would have found many people saying this by now!

Whatever changes I have made wii sports and toy story 3 have always worked perfectly and mario kart has never worked!

Does anyone have any reliable systematic way to get this working?

Thanks in advance!

SysCheck HDE v2.4.0 HacksDen Edition by JoostinOnline, Double_A, R2-D2199, and Nano
...runs on IOS58 (rev 6176).

Region: PAL
System Menu 4.3E (v514)
Priiloader installed
Drive date: 02.13.2007
Homebrew Channel 1.1.2 running on IOS58

Hollywood v0x11
Console ID: 57948619
Console Type: Wii
Shop Channel Country: United Kingdom (110)
Boot2 v4
Found 100 titles.
Found 55 IOS on this console. 5 of them are stubs.

IOS4 (rev 65280): Stub
IOS9 (rev 54321): Trucha Bug
IOS10 (rev 768): Stub
IOS11 (rev 54321): Trucha Bug
IOS12 (rev 526): No Patches
IOS13 (rev 1032): No Patches
IOS14 (rev 1032): No Patches
IOS15 (rev 1032): No Patches
IOS16 (rev 54321): Trucha Bug, ES Identify, Flash Access, NAND Access
IOS17 (rev 1032): No Patches
IOS20 (rev 54321): Trucha Bug
IOS21 (rev 1039): No Patches
IOS22 (rev 1294): No Patches
IOS28 (rev 1807): No Patches
IOS30 (rev 54321): Trucha Bug
IOS31 (rev 3608): No Patches
IOS33 (rev 3608): No Patches
IOS34 (rev 3608): No Patches
IOS35 (rev 3608): No Patches
IOS36 (rev 54321): Trucha Bug, ES Identify, NAND Access
IOS37 (rev 5663): No Patches
IOS38 (rev 4124): No Patches
IOS40 (rev 3072): Stub
IOS41 (rev 3607): No Patches
IOS43 (rev 3607): No Patches
IOS45 (rev 3607): No Patches
IOS46 (rev 3607): No Patches
IOS48 (rev 4124): No Patches
IOS50 (rev 54321): Trucha Bug
IOS51 (rev 4864): Stub
IOS52 (rev 5888): Stub
IOS53 (rev 5663): No Patches
IOS55 (rev 5663): No Patches
IOS56 (rev 5662): No Patches
IOS57 (rev 5919): No Patches
IOS58 (rev 6176): USB 2.0
IOS60 (rev 54321): Trucha Bug
IOS61 (rev 5662): No Patches
IOS62 (rev 6430): No Patches
IOS70 (rev 54321): Trucha Bug
IOS80 (rev 54321): Trucha Bug
IOS90 (rev 54321): Trucha Bug
IOS202[60] (rev 65535, Info: hermesrodries-v6): Trucha Bug, NAND Access, USB 2.0
IOS222[38] (rev 4, Info: hermes-v4): Trucha Bug, ES Identify, NAND Access, USB 2.0
IOS223[38+37] (rev 4, Info: hermes-v4): Trucha Bug, ES Identify, NAND Access, USB 2.0
IOS224[57] (rev 65535, Info: hermesrodries-v6): Trucha Bug, NAND Access, USB 2.0
IOS236 (rev 54321): Trucha Bug, ES Identify, NAND Access, Beer Ticket
IOS245[37] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
IOS246[38] (rev 21008, Info: d2x-v8final): Trucha Bug, ES Identify, NAND Access
IOS247[53] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
IOS248[55] (rev 21008, Info: d2x-v8final): Trucha Bug, NAND Access, USB 2.0
IOS249[57] (rev 65535, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
IOS250[56] (rev 65535, Info: d2x-v10beta52): Trucha Bug, NAND Access, USB 2.0
IOS251[38] (rev 65535, Info: d2x-v10beta52): Trucha Bug, ES Identify, NAND Access
IOS254 (rev 65281): BootMii
BC v6
MIOS v10
Report generated on 05/19/2021.


New Member
Nov 12, 2021
United States
I had this issue with my USA wii with Mario kart wii. I tried many things including changing the cIOS, but what worked was simply changing the name of my wbfs file. You are likely aware the usbloader needs files to be in a specific format and include wbfs id numbers. The wbfs id for Mario kart wii varies between RMCE01 for NTSC-u or RMCP01 for PAL. I changed that and it worked. That wbfs was from Vimm's Lair

Popular threads in this forum

General chit-chat
Help Users
  • No one is chatting at the moment.
    K3N1 @ K3N1: https://youtube.com/shorts/tvurxLB3fOw?si=4ksAQAeBZ_Ji4ceZ