Basehaxx not installing correctly

Discussion in '3DS - Homebrew Development and Emulators' started by Aidanbutt72, Jul 26, 2017.

  1. Aidanbutt72
    OP

    Aidanbutt72 Member

    Newcomer
    10
    0
    Jul 26, 2017
    United States
    I have an old 3ds running LumaCFW on 11.2. The download link on the official basehaxx site is broken, so I downloaded it from a (trusted) german site (Not sure if I can link it, please tell me if I can).

    I tried to install it for my New 3ds which I bought running stock 11.4 (rip). When I open basehaxx, it says Pokemon AS 1.0 detected, even though I have the update version 1.4 installed.
    I chose New3DS-11.4-0-37U
    It proceeded to download, then install, to be brought to an error screen that says "Failed to embed payload" (I assume because it thinks its a 1.0 game).

    Then, I tried adding an XML with this in it:
    Code:
    <targets selectable="true">
    </targets>
    Now when I try to run it, it pops up with a message saying "This homebrew exploit does not have support for launching applications under target titles. Please use a different exploit."

    What should I do?
     
    Last edited by Aidanbutt72, Jul 26, 2017
  2. Dracari

    Dracari GBAtemp Maniac

    Member
    1,401
    386
    Apr 5, 2009
    United States
    -Snip-
     
    Last edited by Dracari, Jul 26, 2017
  3. Aidanbutt72
    OP

    Aidanbutt72 Member

    Newcomer
    10
    0
    Jul 26, 2017
    United States
  4. Dracari

    Dracari GBAtemp Maniac

    Member
    1,401
    386
    Apr 5, 2009
    United States
    when i read it over i didnt see the O3DS was allready set up w/ CFW. i suppose if the O3DS has a compatable Legit copy of any of teh usable DSiware titles you can do the dsiware method. otherwise i think only hardmods work for now. atleast untill ntrboothax is released/
     
  5. Aidanbutt72
    OP

    Aidanbutt72 Member

    Newcomer
    10
    0
    Jul 26, 2017
    United States
    I'm not trying to get CFW on the target 3ds, just the HBLauncher. Am I mistaken that basehaxx is compatible with 11.4?
     
  6. Dracari

    Dracari GBAtemp Maniac

    Member
    1,401
    386
    Apr 5, 2009
    United States
    nope according to https://3ds.guide/homebrew-launcher-(alternatives) anyways. looks like only oot3d and ninjhax are the only 2 compatabile w/ 11.4
     
  7. Aidanbutt72
    OP

    Aidanbutt72 Member

    Newcomer
    10
    0
    Jul 26, 2017
    United States
  8. Dracari

    Dracari GBAtemp Maniac

    Member
    1,401
    386
    Apr 5, 2009
    United States
    not on a vanilla system i think they do work on a Alrready CFW'd system as luma at the updates for 11.4 Restored some exploit entrypoints.
     
  9. Aidanbutt72
    OP

    Aidanbutt72 Member

    Newcomer
    10
    0
    Jul 26, 2017
    United States
    Just tested, it also didnt work when trying to install it for Old3DS-11.2-0-35U. I think something else is wrong.
     
  10. Dracari

    Dracari GBAtemp Maniac

    Member
    1,401
    386
    Apr 5, 2009
    United States
    i've sene more or less renaming the payload. hmmm have you made sure to delete the Update data? as for ideas elsewise to make this work for you i'm out of reach from just quick googlin. (i'm currently playing FFXIV atm, outside suggesting getting a copy of Cubic Ninja or a cart of OOT3D, not sure what to tell ya,) Maybe someone else who is more knowledgeable can help you.
     
  11. Aidanbutt72
    OP

    Aidanbutt72 Member

    Newcomer
    10
    0
    Jul 26, 2017
    United States
    Hmm, deleting update data also didnt help me.

    Hopefully someone else can help me.
     
  12. Aidanbutt72
    OP

    Aidanbutt72 Member

    Newcomer
    10
    0
    Jul 26, 2017
    United States
    *bump*
     
  13. Aidanbutt72
    OP

    Aidanbutt72 Member

    Newcomer
    10
    0
    Jul 26, 2017
    United States
    It worked after downgrading my 3ds to 11.0.
    Apparently its not compatible with a source 3ds running 11.2
     
  14. Zidapi

    Zidapi GBAtemp Psycho!

    Member
    3,024
    1,805
    Dec 1, 2002
    According to 3DS.guide it works up to, and including 11.3. Yet the basehax page itself says it only works up to, and including 11.1.

    I think some entry points haven't officially been updated, but can be used on later firmwares by simply renaming the payloads.

    @Plailect is this the case with basehax?
     
  15. Aidanbutt72
    OP

    Aidanbutt72 Member

    Newcomer
    10
    0
    Jul 26, 2017
    United States
    I think the installer is the one with compatibility issues, and some sites only show the post-installed exploit
    Edit:
    I also heard something about PokeBank needed for newer versions. Can someone confirm this?
     
  16. Majickhat55

    Majickhat55 The Red Woman

    Member
    3,324
    1,587
    Mar 28, 2016
    United States
    Asshai
    No you don't need PokeBank for any versions of Basehax, just a base with a team name. You're correct in assuming it's the installer that doesn't work above 11.1. That's true for a number of game exploits, especially OOT3DHax. Anyway, it might work on 11.4 if it has an updated firmware option in the installer itself. Only thing is there are no robpin payloads past 11.3 for O3DS models.
     
  17. Aidanbutt72
    OP

    Aidanbutt72 Member

    Newcomer
    10
    0
    Jul 26, 2017
    United States
    Is this also why oot3dhax failed to install?
     
  18. Majickhat55

    Majickhat55 The Red Woman

    Member
    3,324
    1,587
    Mar 28, 2016
    United States
    Asshai
    Yerp