BAD_POOL_HEADER BSOD Problem in Windows XP

Discussion in 'Computer Software and Operating Systems' started by AlanJohn, Mar 1, 2014.

  1. AlanJohn
    OP

    AlanJohn くたばれ

    Member
    3,457
    2,930
    Jan 6, 2011
    Canada,New Jersey
    So I have an old Toshiba laptop with a home version of windows xp with sp3. I got a BSOD that refers to itself as "BAD_POOL_HEADER". Now I would have just simply googled for this problem, and I did, but it didn't help me. GBAtemp is my only hope left!
    What I've tried:
    • Going into safemode and doing a sfc /scannow (I get a bsod when entering safe mode)
    • Using a live Windows XP boot cd (It just goes right into installing windows, no options for recovery and such)
    • Cleaning my registry with CCLeaner (it didn't help, not to mention I have about 30 seconds until my pc goes BSOD)
    • Googling the problem (the results are either commercials for spamware or forum threads that have similar problems, but the solution to them was entering safe mode or using a bootdisk, which didn't work for me)
    NEW:
    • Tried memtest + a check with gparted by using a debian live disk, there are no problems with my hdd
    • Tried booting through a usb stick with ubuntu on it (so I can copy windows files from a disk onto my pc), didn't work. PC doesnt show any options for booting from USB, only from HDD, Floppy, CD Rom and lan.
     
  2. Arras

    Arras GBAtemp Guru

    Member
    5,862
    2,676
    Sep 14, 2010
    Netherlands
  3. Originality

    Originality Chibi-neko

    Member
    5,345
    781
    Apr 21, 2008
    London, UK
    RAM issues, or IO misreads sending corrupt data to the memory pool. Sometimes caused by driver issues. This usually occurs in conjunction to other BSOD messages such as IRQL_NOT_LESS_OR_EQUAL.

    Top google result suggests trying to unplug all external devices (aside from monitor) to see if any peripheral drivers are causing it.
    You can also run a memtest and a chkdsk to test the RAM and primary HDD for issues.
    For more detailed checks, you can try getting a diagnostic tool for your specific HDD (e.g. Seatools for Seagate HDDs).
     
  4. AlanJohn
    OP

    AlanJohn くたばれ

    Member
    3,457
    2,930
    Jan 6, 2011
    Canada,New Jersey
    Updated OP with 2 more things I've tried.
     
  5. FireEmblemGuy

    FireEmblemGuy Celebrating a decade of shitposting

    Member
    2,440
    440
    Jul 6, 2007
    United States
    Michigan, USA
    Sounds like a RAM issue to me. Download something like Memtest86+, get it running, and leave it testing overnight. If it pops up any errors, you probably need to replace the RAM.
     
  6. Plainscript

    Plainscript GBAtemp Regular

    Member
    110
    13
    Nov 18, 2012
    Netherlands
    Feel free to try this (just to be sure there isn't some dodgy driver issue)

    Try Safe Mode with Command Prompt, if possible.

    Print/copy/whatever the following page and scroll down to Command Line Interface: http://support.microsoft.com/kb/244617

    Try: verifier.exe /standard & more importantly

    verifier.exe /all

    Might do a couple of reboots.
     
  7. Taleweaver

    Taleweaver Storywriter

    Member
    5,601
    1,643
    Dec 23, 2009
    Belgium
    Belgium
    I had this error on a couple of my users...in the end, we had to replace the memory (memtest86+ showed errors). If it's too hard to create a bootCD containing memtest86+, at least try removing some of the memory bars (assuming you've got more than 1) to see if that changes things.

    While the "Chkdsk /f" command does some fixing, it doesn't make for a permanent solution (at least not in the cases I've found). To be honest, I think it just clears out the garbage from the last crashes without taking care of the real problem.