Bad video on some games & emulators (softmod unleashedx)

Discussion in 'Microsoft Xbox' started by |<roni&g, Feb 13, 2018.

  1. |<roni&g
    OP

    |<roni&g GBAtemp Regular

    Member
    3
    Nov 18, 2010
    United States
    UK
    IMG_4923.JPG Hello, just recently got a crystal xbox (pal) & softmodded it with a bunch of games and emulators, but the problem is that 3 of them result in this kind of picture.
    The 3 games so far that have resulted In this are final burn legends 2.3, vbag gba emu and arctic thunder game.
    Any ideas what could be causing this?
    I am using component cables and selected the hd option when installing the softmod
     
  2. DinohScene

    DinohScene Feed Dino to the Sharks

    Moderator
    21
    GBAtemp Patron
    DinohScene is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Oct 11, 2011
    Antarctica
    Восторг
    Third party component cables are notoriously shitty.
    Other using the original MS HD AV pak or composite, you could try to reset the video settings to the original settings
     
  3. |<roni&g
    OP

    |<roni&g GBAtemp Regular

    Member
    3
    Nov 18, 2010
    United States
    UK
    I tried resetting video and even softmodded again to make sure, but no luck. I have just tested on another Xbox which had the exact same softmod, files and cables and they work perfectly on there.
    Any ideas? It's a crystal xbox and most games aren't affected but some are, which as I said they work fine on the other og black xbox
     
  4. DinohScene

    DinohScene Feed Dino to the Sharks

    Moderator
    21
    GBAtemp Patron
    DinohScene is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Oct 11, 2011
    Antarctica
    Восторг
    There's no difference on video scaler chips.
    Redumping the games/recopying them from the original source might help.
     
  5. Joyer7319

    Joyer7319 Member

    Newcomer
    1
    Jul 16, 2017
    United States
    New York
    Are you running 720p? 480p? Try disabling all in unleash x. I had similiar problem. If they run unscrabmbled, then set the individual emus to whatever you want. 720 or 480p.
    Ill bet its a 1.6 xbox. Arctic Thunder and a handful of others, csnt run 480p without a patch on a 1.6 xbox. Video chip differences. The patch is easily installed in xbmc.
     
    Last edited by Joyer7319, Feb 13, 2018
  6. |<roni&g
    OP

    |<roni&g GBAtemp Regular

    Member
    3
    Nov 18, 2010
    United States
    UK
    I tried disabling 720/1080 etc and no luck. have not got it working yet but I was thinking it has to be a newer box with video differences.
    So you think i can install a patch to final burn legends arctic & any others? And is it one patch for all or different patches for each? Thanks again
    IMG_4927.JPG
    ^system info on the offending crystal xbox, noticed the blank version info whereas the box that doesn't have the issue says version v1.1 (0b)
     
    Last edited by |<roni&g, Feb 13, 2018
  7. Joyer7319

    Joyer7319 Member

    Newcomer
    1
    Jul 16, 2017
    United States
    New York
    And you disabled 480p? If you run 480i, i honestly cant imagine why this is. The patch is only for xbox games. The emus should work.
     
  8. |<roni&g
    OP

    |<roni&g GBAtemp Regular

    Member
    3
    Nov 18, 2010
    United States
    UK
    Yes I tried disabling the 480p/720/1080
    And still the images are scrambled on boot. Tv says the signal is 480p even with everything disabled.
    I managed to start a game with final burn legends, it unscrambles it but then it's scrambles again next time I go on. Has to be a 1.6 xbox with the video issues.
     
  9. Rocky5

    Rocky5 Advanced Member

    Newcomer
    3
    Aug 12, 2007
    United States
    The softmod you’re using is forcing 480p SID usually does this by default.

    I made a script for XBMC that will scan your games and apply loaders to fix these issues.
    ( not all games can be fixed this way, some just don’t load in 480p on v1.6 Xbox )

    Though I have FBL 1.23 and have zero issues on my v1.6 Xbox so not sure why you are.

    Retroarch also needs a loader, but you can manually apply loaders to stuff that isn’t a game.
     
  10. |<roni&g
    OP

    |<roni&g GBAtemp Regular

    Member
    3
    Nov 18, 2010
    United States
    UK
    Thanks for the info.
    A 1080p dash would be nice if that's possible?
    But nothing is useful unless I can get all the games unscrambled.
    I started on FBL 1.20 & that had the same issue, and 1.23 is the same for me.
    I'm keen to try your script on XBMC, but how do I do it? and will the games load unscrambled from unleashed x after the script?
    thanks again

    Edit: just read your reply on xbmc4xbox, but the part where it says "I know its a year late, but here is fixes for all scrambled games." its blank
     
    Last edited by |<roni&g, Feb 13, 2018
  11. Rocky5

    Rocky5 Advanced Member

    Newcomer
    3
    Aug 12, 2007
    United States
    1080p is not possible.

    https://drive.google.com/open?id=0BzRN8P835YijNkVEdUlFSUFMUzQ

    The script patches the loaders so dashboards don’t know any different, so trainers eg... will work in XBMC or the other trainer ap for example.

    Gets installed to the scripts folder. Also requires XBMC 3.5.3 or later.

    Don’t run 1080i on the Xbox uses to much ram and the GPU/CPU can’t handle it, so you will get slowdown.
     
    Last edited by Rocky5, Feb 13, 2018
  12. |<roni&g
    OP

    |<roni&g GBAtemp Regular

    Member
    3
    Nov 18, 2010
    United States
    UK
    Thanks, Arctic thunder loaded but crashed before first level, but now it wont boot from xbmc or unleashedx. Tried Auto updating from the script but still no luck.
    Have you seen that before?
     
  13. Joyer7319

    Joyer7319 Member

    Newcomer
    1
    Jul 16, 2017
    United States
    New York
    Yes. Not every iso is good. I tried 2. 2nd one worked.
     
  14. |<roni&g
    OP

    |<roni&g GBAtemp Regular

    Member
    3
    Nov 18, 2010
    United States
    UK
    Ok so before I try downloading another, for you the game loaded, crashed while loading the race, then failed to load the next try? And you fixed by downloading a different version of the game?
     
  15. Joyer7319

    Joyer7319 Member

    Newcomer
    1
    Jul 16, 2017
    United States
    New York
    Correct. Different iso, different site. Run the game successfully with 480p,720p,1080i unselected in unleash x. then run Rocky5's script. Thats how i did it.