Already on 3.42. Update?

Discussion in 'PS3 - Hacking & Homebrew' started by Luriden, Sep 21, 2010.

  1. Luriden
    OP

    Luriden GBAtemp Fan

    Member
    429
    1
    Sep 23, 2008
    United States
    Topeka, KS
    I updated to 3.42 awhile back before reading into how easy it was to jailbreak, so I'm screwed on that end. From what I can tell, there will be no way to jailbreak 3.42 anytime soon. Now there's a new update that I need to install before using the store or PSN. I'm not too keen on how PS3 jailbreaking works, is there any chance of 3.42 being jailbroken soon? If not, I'm considering just updating, that way I can have access to PSN, as that's very important to me.
     
  2. assam

    assam Member

    Newcomer
    18
    0
    Sep 7, 2010
    yeh same here................. my firmware is on 3.42 as well..................... is it posible to buy a jailbreak for that version//////
     
  3. agimann

    agimann GBAtemp Regular

    Member
    104
    0
    Sep 27, 2008
    Norway
    fast reply...NO
     
  4. Tanas

    Tanas GBAtemp Addict

    Member
    2,258
    25
    Aug 19, 2006
    No its not possible to buy a jailbreak and probably never will be.
     
  5. Maz7006

    Maz7006 iSEXu

    Member
    3,635
    35
    Aug 2, 2008
    if you care so much about the online/ PSN then update

    if not, wait for a solution

    ... doesn't look like they'll be one anytime soon
     
  6. Livin in a box

    Livin in a box Livin' in a cardboard box

    Member
    1,794
    86
    Jul 18, 2008
    Purgatory
    There will be a solution soon enough. Remember, the folks who didn't update have got full control over the PS3 at all levels and decoding a FW update on there shouldn't take too long, after all CFW has already been 'confirmed' by a hacker team.
     
  7. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    Woah, no. They only have level-2 (GameOS). The hypervisor is still a barrier.
     
  8. EpicJungle

    EpicJungle stop browbeating me can't you see i'm sexy

    Member
    1,002
    3
    Aug 28, 2009
    Canada
    Im on 3.42 also..
    But it doesn't matter for me, I need my online play; Sony can detect if you're using jailbreak [​IMG]
     
  9. foxgrey

    foxgrey GBAtemp Regular

    Member
    104
    0
    Nov 15, 2008
    United States
    Just my opinion, if you look at other hacking scenes. Anytime a company has made public about future firmware releases, its just not practical to hack every incremental release. 3.42 was a band-aid and rushed out, but 3.50 has been on the radar. 3.50 actaully adds features, whereas 3.42 just blocks jailbreak. I would expect to see a 3.50 jailbreak workaround, before we'd see a 3.42 jailbreak.

    I'm not recomending anyone to update, but that seems the most logical to me. Why bother spending the time on 3.42 when 3.50 actaully adds features to the system. Other than that, its just a matter of time before CFW or other great things are possible!

    Personally, I'd love to see a CFW for 3.50 that would let me play my legit games on PSN, and still install the homebrew emu's and programs!
     
  10. Yuan

    Yuan GBAtemp Maniac

    Member
    1,290
    14
    Oct 1, 2007
    Brazil
    If you really need online play. You need to switch to 3.50 lol
     
  11. Livin in a box

    Livin in a box Livin' in a cardboard box

    Member
    1,794
    86
    Jul 18, 2008
    Purgatory
    Oh yeah, but they do have all that SDK and other stuff that leaked the other week with the pin-points on the mobo so someone might be able to do something with that.
     
  12. Zetta_x

    Zetta_x The Insane Statistician

    Member
    1,844
    257
    Mar 4, 2010
    United States
    True, it may be better to update to 3.5 if you are already on 3.42. If you updated to 3.42, chances are you had to in order to do online play or PSN. May as well update to 3.5. I see updates as modules of coding, with each firmware release, they update specific modules of coding vs the whole firmware. Chances are, an exploit that works for 3.42 will also work on 3.5 unless they did addition security improvements.

    But like what has been said, it sounds completely possible for a team to come up with custom firmwares that keep the PS3 jailbreakable and all of the additional resources that Sony releases.
     
  13. Servdogg

    Servdogg GBAtemp Regular

    Member
    201
    0
    Apr 13, 2009
    United States
    Stating the obvious, but if online play is really important to you and you still want to jailbreak you ps3, buy a second ps3 and keep one for online and one for "backups". Seems rather unlikely that jailbreak will work on 3.42 anytime soon. And when and if custom firmware is released, you will most likely still need to have a Ps3 on 3.41 to install the CFW. The custom firmware would hopefully allow games that require 3.42 or above to be played without the jailbreak blocking stuff and potentially allow for jailbroken ps3s to be used online, however its doubtful the release of CFW would somehow allow the jailbreak exploit to work firmwares above 3.41
     
  14. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    To clarify, currently you can't play online with the jailbreak.