Acekard Micro SD chip not going in

Discussion in 'Acekard' started by liamash3, Jan 8, 2010.

Jan 8, 2010
  1. liamash3
    OP

    Newcomer liamash3 Advanced Member

    Joined:
    Jul 6, 2008
    Messages:
    88
    Location:
    Frankston
    Country:
    Australia
    I got an Acekard 2i as a late x-mas present, and after a few hours of playing it and switching to the R4DS i also had (the other present i got, an ezflash V 3in1 Plus, worked better with the R4DS) i tried to put the Micro Sd card i got with the Acekard into the Acekard from the SD card Memory Stick( it was in my PC, i was putting GBA games on it...i think) it refused to go in. It slides in about halfway, and i can push it in fully, but it springs back out after i push it in. Before, it made a *click* sound and stopped the SD card from springing back out, so i think it might be something wrong with the Acekard itself, not me, but i would still like some help in knowing how to fix this. Thanks for reading.
     
  2. hammer35

    Newcomer hammer35 Advanced Member

    Joined:
    Dec 14, 2009
    Messages:
    53
    Country:
    United States
    My spring also got stuck in the out position after only a week, I had to put a piece of scotch tape on the microsd card to and tape it to the Acehard2i to hold it in the down position to work.
     

Share This Page