Acekard 2i Not working for DSi

Discussion in 'NDS - Flashcarts and Accessories' started by MCPwns, Apr 3, 2011.

  1. MCPwns
    OP

    MCPwns Member

    Newcomer
    11
    0
    Apr 3, 2011
    Canada
    Ok so i got an acekard 2i and i've downloaded the most recent firmware w/e thing AKAIO 1.8.6a and I've imported both the _aio folder and akmenu4.nds to my microSD and whenever I put it in my DSi it gets the error message "An error has occurred. Press and hold hte Power Button to turn the system off. Please see the Nintendo DSi Operations Manual for help troubleshooting." and i went to my System Settings for my DSi it's ver 1.3U. I've tried formatting it to FAT32 and it doesnt work still. I've even tried switching microSD's and it still doesnt work...
     
  2. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ Cuddle lesbian derp

    Member
    20,070
    21,180
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    AkAIO won't do anything for that, download the latest flash firmware: here.
    You need another DS or another flashcard that already works on the DSi to run the flashing tool
     
  3. MCPwns
    OP

    MCPwns Member

    Newcomer
    11
    0
    Apr 3, 2011
    Canada
    wait what? i dont understand that stufff... whats a flash firmware? and another ds or flashcard??
     
  4. jurassicplayer

    jurassicplayer Completionist Themer

    Member
    4,355
    505
    Mar 7, 2009
    United States
    Pantsuland
    ...It's exactly like it sounds...
    The firmware is the sort of stuff on the actual flashcart that allows it to run on a DSPhat/DSLite/DSi/etc. (Firmware that gets flashed onto the flashcart)
    The kernel is the sort of stuff you put on the microSD that allows you to run games, homebrew, etc. (AKAIO)
    You need a second DSPhat or DSLite in order to get your flashcart working on the DSi because you will need to update the firmware in order to have it work on the DSi.
     
  5. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ Cuddle lesbian derp

    Member
    20,070
    21,180
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    The Acekard 2i has an internal bootstrap (pretty much internal operating system) that needs to flashed (updated pretty much) to work properly on any system. So what you need to do is download that file I provided.
    In there it holds 2 .nds files one of DS Lite and one for DSi, what you need to do is, pick one of those files then place the file in your microSD card, you need either a DS Lite to run the file or another Flashcard to run it on the DSi, so you can flash (update the internal operating system) So it can work on the DSi.
    I am not sure if I can boil that down anymore to be honest with you.
    This video should help though
    [youtube]DNiNus3a-TU[/youtube]
    It doesn't include the latest, but nothing has changed other than the file needed
     
  6. MCPwns
    OP

    MCPwns Member

    Newcomer
    11
    0
    Apr 3, 2011
    Canada
    how do you update the firmware on the flashcart using another DS? sorry i dont really understand any of this stuff
     
  7. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ Cuddle lesbian derp

    Member
    20,070
    21,180
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    You run the .nds file through the Acekard (if it does load on the DS) and then just follow the on screen instructions. If the Acekard 2i doesn't already have some boot file installed (which is very unlikely) you need to run the same file through another flashcard and just remove the card and insert your acekard 2i when it tells you to.
     
  8. MCPwns
    OP

    MCPwns Member

    Newcomer
    11
    0
    Apr 3, 2011
    Canada
    OK now it runs on my DSi thank you!!... but now whenever i try to play a game.. lets say pokemon white then it gives me a "system file is missing" error
     
  9. pmk010

    pmk010 GBAtemp Regular

    Member
    211
    4
    Jul 27, 2010
    To your right ->

    I have the same problem