1. Scarecrowonastick

    OP Scarecrowonastick Newbie
    Newcomer

    Joined:
    Jan 11, 2021
    Messages:
    1
    Country:
    Ireland
    Hi Folks,

    Brand new user here.
    I've been usin my switch with a certain... system for a while and i love it, i paid for the combo.
    I'm runnin into an issue lately more and more where when i try to run a game it says "A system update is required to use this software".
    And what this means is for most games i have to keep them at v1.0 as if i install an update or DLC i get this message, and for games like Pokemon Shield
    i and play the game at all. I'm wondering if there's any way i can overcome this issue? sx os
     
  2. kerelenko

    kerelenko GBAtemp Regular
    Member

    Joined:
    Jun 25, 2018
    Messages:
    234
    Country:
    United States
    Some game update and dlc require a higher firmware than the original version the game in. Update your firmware and cfw.
     
  3. Lacius

    Lacius GBAtemp Legend
    Member

    Joined:
    May 11, 2008
    Messages:
    15,303
    Country:
    United States
    You can use something like Tinfoil to remove soft version requirements, but newer games, updates, and DLC will eventually require newer system versions. If you are using SX OS, it is safe to update as high as 11.0.0 (not 11.0.1) as long as you update SX OS to the latest version.

    TX's future is uncertain at best, and upgrading to Atmosphere is recommended.
     
  4. Draxzelex

    Draxzelex GBAtemp Legend
    Member

    Joined:
    Aug 6, 2017
    Messages:
    14,009
    Country:
    United States
    What firmware are you even on currently?
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - required, system, update