6.0 Master Keys?

Discussion in 'Switch - Backup Loaders & Modchips' started by man_of_power05, Sep 25, 2018.

  1. man_of_power05
    OP

    man_of_power05 Member

    Newcomer
    3
    Feb 11, 2012
    United States
    Does OFW 6.0 have different master keys that require you to be on that fw to play games that require it or would tinfoil still work with those games on fw 5.2? that is what i have an i don't want to update if i don't need to. for now it seems all games work but Smash Ultimate is sure to require 6.0 so i really want to know before its released.
     
  2. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    Yes, firmware 6.0 introduced a new set of masterkeys (revision 5) however currently no game, update, or DLC is encrypted using this revision. There is no telling what future games will require until they're released so just wait until after they come out in order to verify the encryption used.
     
  3. man_of_power05
    OP

    man_of_power05 Member

    Newcomer
    3
    Feb 11, 2012
    United States
    hm...i wonder if some functionality can be added to tinfoil where you can install a certain master key if the switch is missing it without updating the ofw. then all you would need to do is just include the master key file
     
  4. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    Alternatively you can just extract the NCA files from whatever game you want to play, reencrypt them with the lowest masterkey revision, then launch the game. However when I tried doing this with the new Hacbrewpack, the ticket failed to install. Hacbrewpack may need an option to add a fake ticket for this to work properly.
     
  5. garyopa

    garyopa Admin @ MaxConsole

    Member
    16
    Apr 25, 2009
    Canada
    Tropical Island
    just search for skull & crossbones on maxconsole, and your dreams of new master keys will be fulfilled.

    But most likely until physical game cartridge ships with 6.x firmware on it, they will not be used, all bets are on Smash on Dec. 7th to have them.
     
    RayPanimals likes this.
  6. man_of_power05
    OP

    man_of_power05 Member

    Newcomer
    3
    Feb 11, 2012
    United States
    i'm confused on how to do this. i went to that skull and crossbones thing and got this keys.dat. i know now its not needed but when the time comes what would i do with it? how would i add it to a nsp? will this also work with an xci or just nsp?
     
  7. wurstpistole

    wurstpistole I got 8 warning points

    Member
    11
    Nov 19, 2015
    Gambia, The
    You will not successfully install and run a game that requires 6.0.0 on a lower firmware ever, no matter how many keys you got.
     
  8. man_of_power05
    OP

    man_of_power05 Member

    Newcomer
    3
    Feb 11, 2012
    United States
    ??? then what's with the above posts?
     
  9. Der_Blockbuster

    Der_Blockbuster GBAtemp Advanced Fan

    Member
    6
    Mar 2, 2016
    Germany
    Why that
     
  10. wurstpistole

    wurstpistole I got 8 warning points

    Member
    11
    Nov 19, 2015
    Gambia, The
    You can run games on lower firmwares that have the same master keys as higher firmwares, by modyifing the nsps. For example a 5.1.0 game on 5.0.1
    But there's no way ever that a 6.0.0 game runs on anything below 6.0.0, new keys.
    Update, or create an updated Emunand as soon as that reliably works and play on that.
     
  11. Der_Blockbuster

    Der_Blockbuster GBAtemp Advanced Fan

    Member
    6
    Mar 2, 2016
    Germany
    Okay but you didn't explain why.
     
  12. wurstpistole

    wurstpistole I got 8 warning points

    Member
    11
    Nov 19, 2015
    Gambia, The
    Don't care, really. Won't work for the same reasons higher fw 3ds games didn't work on lower fw, higher fw ps4 games won't run on lower fw exploited ps4s.
    I reckon that 5.1 simply can't decrypt 6.0 games no matter how many masterkeys you got. You having them doesn't mean you can feed them to 5.1 console. Gotta have 6.0 to run them.
     
  13. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    He's right. I managed to successfully decrypt and reencrypt Freedom Planet (a game using masterkey revision 4) and install in on my 4.1 console (masterkey revision 3) but the game would not load. Why? The .NSO file in the game is hardcoded to run on firmwares 5.0 and above meaning encryption is not the only thing stopping games from running on lower firmwares; you would have to make your own .NSO file for this game and all others to work on lower firmwares but this is virtually impossible since newer firmwares introduce key changes to Horizon which makes these games run in the first place. Firmware spoofing is likely never going to happen but this is hardly an issue as we can update without burning fuses using ChoiDujourNX.
     
    Garou and Der_Blockbuster like this.
Loading...