#001 error when loading Mario Kart through USB Loader GX

Discussion in 'Wii - Backup Loaders' started by Sajo, May 2, 2015.

  1. Sajo
    OP

    Sajo Newbie

    Newcomer
    5
    1
    May 2, 2015
    Keep getting error #001 when trying to start Mario Kart PAL version. I have alternativ d2x v 10 beta r53 installed. Where IOS 249 is installed at 56 and IOS 250 at 58 and the highest rev installed (65535).

    I can launch Wii Sports just fine, haven't tried with other Wii games though.
     
  2. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    17,650
    8,227
    Oct 27, 2002
    France
    Engine room, learning
    #001 error should be fixed by cIOS long time ago.
    I don't know why you are still having it.
    Maybe your Mario Kart iso is corrupted, or has been patched to prevent error001 long ago ? (even if it shouldn't matter)

    Try dumping your retail disc again, use a clean ISO.


    Do you really need base58 in slot250 ?
    usually, it's recommended to install base57 in slot250 for playing Call of duty. If you don't need to play that game, you don't need base57.
    base58 might be needed for musical games (sing it, guitar hero etc.)
    So, maybe installing base58 is your own choice.

    use the slot249 by default for all your games.
    no need to maxed out the revision to 65535 if you don't launch games from Disc channel, or if you have priiloader disc update patches.

    If you don't need to use both USB Port, you can install v10 (beta52 instead of beta53)
     
  3. Sajo
    OP

    Sajo Newbie

    Newcomer
    5
    1
    May 2, 2015
    Thanks for the reply Cyan. Now I'm pretty sure the IOS 250 at base 58 is a typo by me. I did install it on 57, just like the d2x wiki said.

    I'll try to install the beta52 instead and see if that works
     
  4. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    17,650
    8,227
    Oct 27, 2002
    France
    Engine room, learning
    The base you use only depend on what game you really want to play.
    I just found "not usual" to see you installed base58. but that's fine if you really installed that base, as long as you understand why.

    base56 is faster than base57 to access USB data, but has some issues with games (call of duty)
    base57 has more compatibility, but it's a little slower to access USB.
    base58 is even more slower, and needed only for games with USB accessories (microphones for example)

    Most guide will tell user to install only base56 and base57 on Wii. (base58 is present on guide for vWii WiiU)
    You can keep just 56 and 57. (even only 56 is fine! you don't need two cIOS if you don't play call of duty)


    I'm sorry I don't know why you have error001. it's a very old error and I even forgot what caused this error.
    I think it's related to GameID not copied correctly in memory. cIOS is supposed to do it automatically now.
     
  5. Sajo
    OP

    Sajo Newbie

    Newcomer
    5
    1
    May 2, 2015
    Well I got it to work! I just got my hand on another copy of the game, this new copy was maybey a gig larger then the last one I used.

    I did not install the other d2x version since I might be using a USB controller later one and I need both ports, but thanks for the explenation with the bases :yay:
     
    Cyan likes this.
  6. Sajo
    OP

    Sajo Newbie

    Newcomer
    5
    1
    May 2, 2015
    Just I quick question, can I play games such as Mario Kart and SSBB online without it messing up my softmoded wii?
     
  7. GreyWolf

    GreyWolf GBAtemp Psycho!

    Member
    3,841
    734
    Mar 2, 2015
    United States
    There is an option in USB Loader GX to use private servers. The loader will patch the games it supports when it loads them.
    As far as I know you actually *have* to have a modded Wii to play anything online now. :)
     
  8. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    17,650
    8,227
    Oct 27, 2002
    France
    Engine room, learning
    Only the games using nintendo's servers (well, more precisely the one who used gamespy servers) need a private server now.
    There are still games officially working online.


    You don't need to mess up anything if it's already softmoded.
    To connect to private servers you need to edit the server's URL in the game.
    It can be done manually (patching the ISO) or in memory (letting a loader do its magic at game launch).

    Like greywolf said, USBLoaderGX has option for private server patching.
    HTTPS only : remove the SSL certificate requirement. needed if you want to connect to altwfc server. you need to edit the DNS in your settings
    HTTPS+wimmfi : edit both SSL and the URL to connect to wimmfi.de server. No need to edit the DNS.

    in both servers, your existing profile/friendcode will not work.
    You will have to re-create a new driving license for Mario kart, etc.
     
  9. N7Kopper

    N7Kopper Proud lover of a three-inch girlfriend

    Member
    363
    133
    Aug 24, 2014
    I know that Wiimmfi supports uploading your game data for things like MKWii, Animal Crossing, and Brawl so you can retain your old save data. You do need to be patient, however. It won't update instantly, it'll take about a day. Not sure about altwfc - I don't like mucking with my DNS settings unless I have to. And for things that can use legitimate, non-DNS altered online services, it's one headache too many.