Will downgrading make homebrew better?

Discussion in '3DS - Flashcards & Custom Firmwares' started by mashers, Jan 5, 2016.

  1. mashers
    OP

    mashers Stubborn ape

    Member
    3,837
    5,154
    Jun 10, 2015
    Kongo Jungle
    I have zero interest in piracy as I like to play my games from cart. However, I'm considering downgrading my 10.2 n3DS to 9.2 and using CFW. My question really is, is it worth it considering I don't care about piracy? Will using emulators through CFW be better then through *hax? And what would I do if I bought a cart game which required fw > 9.5, since n3DS can't run emunand beyond 9.5?

    Thanks in advance guys!
     
    GotKrypto67 likes this.
  2. Filo97

    Filo97 Zelda's totally my sister! Not lying!

    Member
    3,637
    1,209
    Oct 8, 2015
    Italy
    Hyrule Castle
    yes
    you have a point.
     
  3. mashers
    OP

    mashers Stubborn ape

    Member
    3,837
    5,154
    Jun 10, 2015
    Kongo Jungle
    In what way?
     
  4. Filo97

    Filo97 Zelda's totally my sister! Not lying!

    Member
    3,637
    1,209
    Oct 8, 2015
    Italy
    Hyrule Castle
    .cia exist
     
  5. mashers
    OP

    mashers Stubborn ape

    Member
    3,837
    5,154
    Jun 10, 2015
    Kongo Jungle
    Right, but how does that improve emulators?
     
  6. Filo97

    Filo97 Zelda's totally my sister! Not lying!

    Member
    3,637
    1,209
    Oct 8, 2015
    Italy
    Hyrule Castle
    i don't know but they run faster.
     
  7. Xenon Hacks

    Xenon Hacks GBAtemp Guru

    Member
    7,050
    3,367
    Nov 13, 2014
    United States
    Kernel access
     
    Filo97 likes this.
  8. VinsCool

    VinsCool Delusional

    Member
    GBAtemp Patron
    VinsCool is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,705
    27,737
    Jan 7, 2014
    Canada
    Another World
    Kernel mode homebrews allow memory pages to be executed, so dynarec is possible.

    9.2 and lower. Although, memchunkhax2 is a kernel access exploit, so eventually, 10.3 might allow this
     
    Mrrraou likes this.
  9. Ekaitz

    Ekaitz Pokémon Master

    Member
    606
    214
    Jun 13, 2010
    France
    Lens
    Memchunkhax2 is arm11 only, I think that dynarec required ARM9 exploit?
    (There are arm9 exploits that are being worked on but I don't know if it will be released soon or even if it will be released a day lol)
     
  10. VinsCool

    VinsCool Delusional

    Member
    GBAtemp Patron
    VinsCool is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,705
    27,737
    Jan 7, 2014
    Canada
    Another World
    Arm11 userland is more than enough.

    Arm9 is good for either piracy (emunand, gateway) and high level hacking)
     
  11. mashers
    OP

    mashers Stubborn ape

    Member
    3,837
    5,154
    Jun 10, 2015
    Kongo Jungle
    Ok thanks guys. I think I'll just stick with 10.2. I can do everything I want on this FW version, and don't want to risk a brick for the sake of a slight increase in emulator performance the the possibility that a future cart purchase will fail to run on 9.5 emunand. If emunand support for >= 10.3 becomes an option on n3DS then I might reconsider.
     
  12. VinsCool

    VinsCool Delusional

    Member
    GBAtemp Patron
    VinsCool is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,705
    27,737
    Jan 7, 2014
    Canada
    Another World
    Considering that gateway officially announced 10.3 support, the wait might be worth it.
     
    Selim873 likes this.
  13. mashers
    OP

    mashers Stubborn ape

    Member
    3,837
    5,154
    Jun 10, 2015
    Kongo Jungle
    So would that mean kernel access in 10.3 using the GW card? Would it make any difference to emunand support (e.g. if there's a 10.4 update).
     
  14. VinsCool

    VinsCool Delusional

    Member
    GBAtemp Patron
    VinsCool is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,705
    27,737
    Jan 7, 2014
    Canada
    Another World
    This, is a question that only Gateway would know tha answer :D (for now)
     
  15. Viri

    Viri GBAtemp Maniac

    Member
    1,217
    1,084
    Sep 13, 2009
    United States
    So, does this mean Snes and GBA(Yes, I know about the .cias of GBA games, but I prefer using an emulator) emulators won't run like shit on o3DS XL on 9.2, if I were to install a .cia version of the emulator?