Wiishop Channel is broken ._.

Discussion in 'Wii - Hardware, Devices and Utilities' started by Pioldes, Jul 14, 2009.

  1. Pioldes
    OP

    Pioldes Member

    Newcomer
    17
    0
    Jun 30, 2009
    Canada
    Hello, I bought a wiipoint card recently for RB2 songs. The thing is, I'm still on 3.2U(IOS 249, I think. The one for the backup launcher). So when I tried to connect to the Wii Shop Channel, they asked me to update. I didn't want to, so I searched for a workaround.

    I put the Wii System Channel Updater on my SD card and I only installed the Wii Shop Channel. Everything went fine, I got no error messages.

    But now, when I try to start the Wii Shop Channel, it looks like it's starting, but it goes back to the wii menu.

    How can I solve this problem?

    Thank you.
     
  2. Dialexio

    Dialexio GBAtemp Advanced Maniac

    Member
    1,548
    26
    Mar 14, 2009
    United States
    You forgot to install IOS61 in WiiSCU. The latest Wii Shop Channel needs IOS61, or it just returns to the System Menu.

    If you want the Trucha bug in IOS61, install it via Dop-IOS or Trucha Bug Restorer (TBR) instead. If you don't know what this means, it's probably best to not bother with it at the moment.

    EDIT: As mentioned below, I forgot WiiSCU can put the Trucha bug in as well.
     
  3. Pioldes
    OP

    Pioldes Member

    Newcomer
    17
    0
    Jun 30, 2009
    Canada
    Okay, thanks a lot.

    But since I'm on IOS 249, would this be a problem?

    I mean, could it cause a conflict? And will I still be able to back up games on the backup launcher? (I don't have a modchip).

    Thanks in advance [​IMG]

    (oh, and I don't know what you're talking about for the second part, so... yeah, I probably won't bother xP)
     
  4. nicky041192

    nicky041192 GBAtemp Maniac

    Member
    1,433
    0
    Mar 9, 2008
    UK
    no conflitct at all [​IMG]
     
  5. Pioldes
    OP

    Pioldes Member

    Newcomer
    17
    0
    Jun 30, 2009
    Canada
    So that means that this IOS only ''adds up'' to the old one? I'll still be able to read burned games?

    Thanks [​IMG]
     
  6. WB3000

    WB3000 GBAtemp Advanced Fan

    Member
    668
    1
    Apr 5, 2007
    United States
    You're 'thinking wrong' about IOS. Your Wii is like a 255-door garage, and IOS modules are like cars. You can install as many as you want, none are overwritten from another one. [​IMG]
     
  7. Pioldes
    OP

    Pioldes Member

    Newcomer
    17
    0
    Jun 30, 2009
    Canada
    Okay, thanks [​IMG]

    Wow, people on this site are actually simple, kind and helpful.

    Not like on that other site where I usually get all my wii hacking stuff :x

    They told me to install some junk that would change the region of my wii, put it on 4.0 and stuff...
     
  8. SifJar

    SifJar Not a pirate

    Member
    6,022
    891
    Apr 4, 2009
    Just to mention this, WiiSCU can install IOS 61 with trucha. Just select +trucha. And you may as well do this. It may help if you update in the future and want to use certain homebrew.
     
  9. rctgamer3

    rctgamer3 GBAtemp Regular

    Member
    291
    88
    May 5, 2008
    Netherlands
  10. Pioldes
    OP

    Pioldes Member

    Newcomer
    17
    0
    Jun 30, 2009
    Canada
    But... what's trucha?
     
  11. pm_41

    pm_41 GBAtemp Regular

    Member
    204
    0
    Jul 1, 2009
    United States
    Lurking in my Wii's NAND
    Trucha Bug = fakesigning

    It's just a nickname. [​IMG]
     
  12. Pioldes
    OP

    Pioldes Member

    Newcomer
    17
    0
    Jun 30, 2009
    Canada
    I still don't get it^

    I'm really sorry, I'm basiclally noobish in hacking xP
     
  13. Pioldes
    OP

    Pioldes Member

    Newcomer
    17
    0
    Jun 30, 2009
    Canada
    Okay, I informed myself a little bit and it seems that the trucha bug is used to launch patched back-ups?

    I might install it during the installation of the IOS61, but if it adds a risk of bricking, I don't want to.

    Also, should I install BootMii to be able to repair my wii if it bricks? I already got Starfall, but some people are saying that it's outdated : I
     
  14. Dialexio

    Dialexio GBAtemp Advanced Maniac

    Member
    1,548
    26
    Mar 14, 2009
    United States
    Put simply, the fakesigning bug is a fuckup on Nintendo's/BroadOn's side. If the signature began with a null byte (00), the Wii would think Nintendo signed the code. Talk about epic fail.

    There is no risk of bricking when modifying IOS61. Worst comes to worst, IOS61 has to be removed and reinstalled.

    You should definitely get BootMii (boot2 is preferred).