WiiFlow and emulator configuring issues

Discussion in 'Wii U - Hacking & Backup Loaders' started by michelono, May 16, 2014.

  1. michelono
    OP

    michelono Member

    Newcomer
    28
    2
    May 15, 2014
    Netherlands
    With the great help of worm28 I've succeeded in creating two partitions (first FAT32, second NTFS).
    vWii is running WiiFlow with the plugin pack and when set to USB2 it plays the Wii games perfect. But now the question:

    How do I set up the plugins? I want to play NES, SNES, N64 and Gamecube roms, and I've created folders for the roms on the FAT32 partition and put the files in. What to do next?
    For example "GoldenEye 007 (E) [!].z64" is now on placed in "USB1/N64/GoldenEye 007 (E) [!].z64"
    But how do I get those roms to work? I'm a complete n00b with emulators and didn't understand anything from the article: https://sites.google.com/site/wiiflowiki4/plugins-setup

    Thanks guys for all the help I can get! :bow:
     


  2. mightymuffy

    mightymuffy fatbaldpieeater

    Member
    GBAtemp Patron
    mightymuffy is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    1,327
    522
    Nov 6, 2002
    United Kingdom
    Wigan, land of the Pies
    Using Goldeneye and your folder position as an example, first you'll need to have the Not64 plugin. If you've got Abz Masterpiece pack you're set there already. Now if you want to keep your rom in that folder you'll need to go into wiiflow/plugins and find the Not64 ini file. Open that with a text editor (Notepad will do), and find where it says 'romDir'. I suspect it'll continue to '=wii64/roms', change this part to '=N64'.

    Alternatively rename your rom folder to wii64/roms.
     
  3. michelono
    OP

    michelono Member

    Newcomer
    28
    2
    May 15, 2014
    Netherlands
    Thanks a lot mightymuffy! Going to try that first thing!
     
  4. michelono
    OP

    michelono Member

    Newcomer
    28
    2
    May 15, 2014
    Netherlands
    Thanks again mightymuffy, I just did as you discribed with all the emulators from the Abz Masterpiece pack.

    Now my second question, how do I activate a plugin? When I start WiiFlow, I see all the Wii games from my USB2 partition. When I switch to USB1 (where the roms are) I still see the covers of those same Wii games. I don't know how I can switch to one of those emulators? :ph34r:

    Cheers again for the help! :grog:
     
    mightymuffy likes this.
  5. jammybudga777

    jammybudga777 GBAtemp Advanced Maniac

    Member
    1,673
    561
    Aug 23, 2013

    go to the apps/wiiflow/settings.ini open that with notepad and turn on plugins if its not already. once thats done go to wiiflow/plugins/plugins.ini or setup.ini make sure everything is set to the correct locations also open wiiflow/source menu/source menu.ini and set out your buttons (example. button one=wii games button two=snes roms and so on) but also you need to tell it the locations of the roms and cover images.
     
  6. michelono
    OP

    michelono Member

    Newcomer
    28
    2
    May 15, 2014
    Netherlands
    Thanks jammybudga777,
    The plugins are already turned on in the wiiflow ini file.
    I can't find a plugin.ini or setup.ini though. I have all individual *.ini files in the plugin folder. Can that be the case? That I've maybe used a wrong plugin pack or something?
     
  7. jammybudga777

    jammybudga777 GBAtemp Advanced Maniac

    Member
    1,673
    561
    Aug 23, 2013

    once you download it everything should be in the correct place/folder structure. but all you need to do is open each setting.ini and make sure they all are being told where your roms folders and images exc. so from the root of your device go to wiiflow/source menu/ there will be/needs to be a setting.ini or txt file there ?
     
  8. michelono
    OP

    michelono Member

    Newcomer
    28
    2
    May 15, 2014
    Netherlands
    In the source_menu folder i only find four (Theme) folders:
    BlackWii
    Carbonik
    Orchid
    StarNight

    All folder contain png images except for BlackWii, which contains beside the png files:
    source_menu_extended.ini
    source_menu.ini
    Setup.txt

    Should I move those files to the root of the source_menu folder?
     
  9. jammybudga777

    jammybudga777 GBAtemp Advanced Maniac

    Member
    1,673
    561
    Aug 23, 2013
    move source menu.ini and source menu extended back into the source menu folder. im not sure about the setup txt open it and see what it says inside. but i dont think u need it
     
  10. michelono
    OP

    michelono Member

    Newcomer
    28
    2
    May 15, 2014
    Netherlands
    Setup.txt doesn't contain anything about configuring, just a discription like you said.
    Thanks a lot jammybudga777, will give it go and let you know!
    Cheers!
     
    jammybudga777 likes this.
  11. jammybudga777

    jammybudga777 GBAtemp Advanced Maniac

    Member
    1,673
    561
    Aug 23, 2013
    the best way i found was open plugins.ini and source menu.ini at the same time. just makes it easier to see what needs matching up. hope you get it sorted
     
  12. michelono
    OP

    michelono Member

    Newcomer
    28
    2
    May 15, 2014
    Netherlands
    Thanks jammybudga777, you helped me out a lot already by searching for the source menu.ini.
    Will give it a go tonight and let you know of the results. Cheers! :)
     
  13. michelono
    OP

    michelono Member

    Newcomer
    28
    2
    May 15, 2014
    Netherlands
    Whoehoee my roms play fine now! Most of them that is, but it is starting to look like something now.

    I still have an issue that ALL the roms (SNES, NES, N64) are displayed all at the same time, and alphabetically, not 'under the right console' so to speak.
    Another thing I haven't figured out yet, is why the covers are not displayed. I renamed the covers exactly as the roms (so including the extentions), but they won't show up.

    For example, I have placed the NES roms on the first partition (FAT32) of my HDD like: USB1/NES/roms and the covers USB1/NES/rom
    What do I have to change in the plugin.ini to get this to work:
    [PLUGIN]
    magic=46434555
    coverColor=ff0000
    coverFolder=NES
    fileTypes=.nes|.fds|.nsf|.unf|.nez|.unif|.zip|.7z
    romDir=NES/roms
    dolFile=fceugx-mod11.dol
    bannerSound=nes.ogg
    displayname=FCEUltraGX
    consoleCoverID=nintendo

    arguments={device}:/{path}/|{name}|{loader}

    Thanks again guys!
     
  14. michelono
    OP

    michelono Member

    Newcomer
    28
    2
    May 15, 2014
    Netherlands
    Thanks again for all the help you guys threw at me. Everything I wanted to get to work now works except for one thing: Gamecube games.

    I have a folder "games" on USB1 (the FAT32 partition of my harddrive). The GC games inside that folder are all named "game" and are all in seperate folders without spaces in the name. But still I can't get them to work. Somehow in the configuration of WiiFlow I can't find DIOSMIOS anywhere. Devolution and Nintendont are installed though (from Abz package). What am I doing wrong?
    I don't see a gamecube button in Wiiflow and I don't see any of the GC games aswell.
     
  15. jammybudga777

    jammybudga777 GBAtemp Advanced Maniac

    Member
    1,673
    561
    Aug 23, 2013
    first of. you need to setup the gamecube button in the source menu.ini once thats done they should show up in wiiflow. have you loaded gamecube games from that partition before?? the reason i ask is because the partition you are using needs to be formatted with a 32kluster size
     
  16. michelono
    OP

    michelono Member

    Newcomer
    28
    2
    May 15, 2014
    Netherlands
    Thanks jammybudga!
    I haven't loaded any gamecube games before from that partition yet. I did format it as FAT32 with 32k size though.
    When I press the gamecube channel from the source menu of wiiflow it says: *disabled*
    I don't understand why, because in the configuration screen it the way of handling gamecube games is set to "auto"
    Don't really know what to do next!
     
  17. markehmus

    markehmus GBAtemp Maniac

    Member
    1,073
    278
    Jul 26, 2008
    Canada
    in the GAME
    14:19 markehmus: always says disabled when i click the gamecube icon
    14:20 Abz: you need to edit your wiiflow.ini then
    14:20 Abz: [DML]
    14:20 Abz: always_show_button=yes
    14:21 Abz: source=yes
    14:21 Abz: disable=no
    14:23 Abz: open \apps\wiiflow\wiiflow.ini
    14:24 markehmus: no slot with ' disable=no '
    14:25 markehmus: do i need to add that line to the .ini if it isnt already there ?
    14:25 Abz: better add them yes
    14:26 markehmus: k
    14:26 Abz: order can be different yes
     
    jammybudga777 likes this.
  18. michelono
    OP

    michelono Member

    Newcomer
    28
    2
    May 15, 2014
    Netherlands
    This is my wiiflow.ini:
    Warning: Spoilers inside!

    I though maybe you can see anything weird in my settings?
    And maybe I should mention there are two partitions:
    First: FAT32 with 32k clusters (Gamecube games in folder "games" and then in subfolders named without spaces) All other plugins are working for the roms on this partition. (SNES, NES and N64 games)
    Second: NTFS for Wii games

    Thanks a lot for helping me out!!!
     
  19. michelono
    OP

    michelono Member

    Newcomer
    28
    2
    May 15, 2014
    Netherlands
    Thanks a lot!! Will get to that right away!
     
  20. michelono
    OP

    michelono Member

    Newcomer
    28
    2
    May 15, 2014
    Netherlands
    Whohoooooo! Everything works great now!!!! :toot:
    Thanks a lot for all the help guys! :bow:

    I have one cosmetic question remaining, how and where can I add custom Wii covers in WiiFlow? The boxcover folder is full of covers from Abz package, and the Covers folder contain some small images. But where are the normal Wii covers stored?
    For example I have a cover for "Newer Super Mario Bros. Wii", where can I store it? And does it even work that way?