Wii Firmware Version

Discussion in 'Wii - Hacking' started by jlg6184, Dec 1, 2008.

  1. jlg6184
    OP

    jlg6184 Advanced Member

    Newcomer
    57
    0
    Nov 15, 2008
    United States
    Alright, hopefully I don't get shredded by the elder members of the forums for this, but I was under the impression when I installed the TH/Homebrew Channel that I was on Firmware 3.2U. Well I finally decided to go for Starfall to prevent bricking as it was just something that I have put off mainly because I am lazy, and I don't typically install wads, so I wasn't worried about banner-bricks. Now when I went to install, I decided to check the firmware before I proceeded, and noticed it says 3.3U. Now, I may have just been not paying attention when I installed the TH/Homebrew and could have been on 3.3U the whole time, which is more likely as I haven't updated the Wii, or even let it online since I installed Homebrew. My question, after that fairly long, and probably not needed introduction is, how can I check to see if it is which version of 3.3 I have? After reading the forums it appears that there are two versions of 3.3U.

    Jason
     
  2. benwin84

    benwin84 Member

    Newcomer
    13
    0
    Sep 23, 2008
    United States
    If you didn't install the wii shop hack, try accessing the wii shop channel, if it asks for an update you have the first version of 3.3, if you can access it with out it asking for an update most likely you have version 2 of 3.3.
     
  3. jlg6184
    OP

    jlg6184 Advanced Member

    Newcomer
    57
    0
    Nov 15, 2008
    United States
    Nope, didn't install the Wii Shop Hack, and it is asking for an update to access the channel, so I guess that answers my question. Now, I know that the "best" version of Wii Firmware is 3.2, so should I just go ahead and install the Wii Shop Hack and be done with it or revert back to 3.2U via the down grader.
     
  4. EmperorOfCanada

    EmperorOfCanada GBAtemp Maniac

    Member
    1,479
    96
    Aug 4, 2008
    Canada
    Canada
    Not that I am quite an elder member yet but that hurts? We arent mean you know =/ well Noobwarrior is a little mean.. he makes me do things. No I dont

    It is up to you if you downgrade, I mostly reccomend it if you install VC/Wiiware wads often, as if you install a bad wad and brick yourself, starfall can help you.

    If you dont install wads often then you are pretty much just as safe on the version you are on so long as you dont upgrade from here on.
     
  5. benwin84

    benwin84 Member

    Newcomer
    13
    0
    Sep 23, 2008
    United States
    Its up to you, if you install a lot of wads then going back to 3.2 and installing starfall will prevent banner bricks. The wii shop hack is only if you buy vc or wiiware games so if you dont buy them then really point in installing the hack, but I recommend going back to the 3.2 firmware since its the most homebrew friendly of all of them.
     
  6. EmperorOfCanada

    EmperorOfCanada GBAtemp Maniac

    Member
    1,479
    96
    Aug 4, 2008
    Canada
    Canada
    Fixed
     
  7. wally7

    wally7 Newbie

    Newcomer
    3
    0
    Dec 29, 2008
    Canada
    Hi,

    My unit is at version 3.1U, how do I update it to 3.2 using Mariokart. Do I need to connect to the net in order for the update, I'd rather not if possible. I checked through all the menus with mariokart in but I couldn't see where it asks if I want to update.

    Any help on this would be great, thanks.

    Do I need to update to 3.2 to use softmod?
     
  8. WiiPower

    WiiPower GBAtemp Guru

    Member
    8,165
    72
    Oct 17, 2008
    Gambia, The
    If you don't have any update blockers enabled and the game doesn't prompt you to update when you run it from the disc channel, you can't update with the game. There are lots of people believing Mario Kart has the 3.2 update, but i'm not sure.