Hacking What's the most ideal IOS configuration?

wootwo

Member
OP
Newcomer
Joined
Sep 3, 2010
Messages
12
Trophies
0
XP
130
Country
United States
Hey all, wanted to firstly apologize if this is a constantly reoccurring topic since it seems like it would be, but I searched with what I could think of ('ios configuration', could be worded a handful of other ways), checked the last five pages and multiple Black Ops topics in regards to new compatible IOS setups and didn't find anything. *breath* So with that said, I was interested in hearing what was considered the best or most ideal layout of IOSes currently, with Black Ops being included for compatibility. I know nothing about SNEEK and Triiforce or how safe they are so I'm not sure if that's worth including, but I've seen that they usually require a certain cIOS revision.

When I softmodded my wii, I used GAF's homebrew tutorial and what that currently leaves you with is:

QUOTE said:
The tutorial gives you the following setup:

* 249 rev20 based on 56 - for everything.
* 222 v4 based on 38 merged with 37 - Most compatible Hermes' v4 version
* 223 v4 based on 38 merged with 60 - There is no real use for this, but it's there.

I considered GAF's tutorial to be the safest of everything I've seen since Dr. Clipper's really upfront about what the risks are and explains in detail what's being performed and I've seen in a recent discussion topic on the tutorial he's eventually planning a new configuration, but in the meantime, what do you all think? Thanks in advance.
 

PPSainity

Blinded by Science
Member
Joined
Jun 6, 2009
Messages
646
Trophies
0
XP
188
Country
Canada
Most find that with recent games like CoD: Black Ops, that installing cIOSx 249 rev20b with an IOS57 base is the best choice currently. There is also a movement to stay with older revisions of Waninkoko's cIOS, like rev17, but I have had no issues with rev20b.

-[]D
 

chop

Well-Known Member
Member
Joined
Apr 14, 2010
Messages
495
Trophies
0
Age
50
Location
Pontefract
XP
267
Country
These are my custom IOS
202[57], For homebrew
222[38] & 223[37] 224[57] [Hermes v5],
249[56] & 250[37] [Waninkoko v20]

Some people are now recommending 250[57] for COD:BO rather than the 224[57] that I have here.
 

xfcrowman

Well-Known Member
Member
Joined
Mar 14, 2009
Messages
431
Trophies
0
XP
195
Country
United States
Here is my setup:

Hermes 5.1 - for using uloader NAND emulation and for conventional game playing
222 [38]
223 [37]
224 [57] - for COD black ops (works just as well as Wanin's cIOSx rev 20 [57])

Waninkoko
249 [56] rev20 - for (almost) everything
250 [38] rev17 - for triiforce

The cIOS you have installed should depend on the apps you use. For example, if you don't care about NAND emulation (either from triiforce or uloader), then installing Wanin's cIOSx rev 20 [56] and [57] would probably be sufficient.

In my case, I do not have cIOS202 installed because I have never needed it.
 

xfcrowman

Well-Known Member
Member
Joined
Mar 14, 2009
Messages
431
Trophies
0
XP
195
Country
United States
chop said:
xfcrowman said:
....In my case, I do not have cIOS202 installed because I have never needed it.

Now that HBC runs off IOS58 is 202 still needed?

I don't think IOS202 is needed anymore, but someone correct me if I'm wrong.

All the Tantric emulators (fceugx, vbagx etc) wiimc, and wiixplorer use IOS58 with AHB_PROT instead of IOS202.

I know that the last official build of wii64 (beta 1.1) came out a long time ago so it doesn't use IOS58 with AHB_PROT. Someone did modify the source so that you could run wii64 using IOS202 and get improved speeds, so wii64 is the only thing I can think of that still uses IOS202.

I recently made a small modification to the wii64 MOD so that wii64 will run using IOS224 instead of IOS202, thus eliminating any need for IOS202.

If anyone can think of any apps other than the wii64 MOD that use IOS202, please let me know as well.
 

PPSainity

Blinded by Science
Member
Joined
Jun 6, 2009
Messages
646
Trophies
0
XP
188
Country
Canada
xfcrowman said:
chop said:
xfcrowman said:
....In my case, I do not have cIOS202 installed because I have never needed it.

Now that HBC runs off IOS58 is 202 still needed?

I don't think IOS202 is needed anymore, but someone correct me if I'm wrong.

All the Tantric emulators (fceugx, vbagx etc) wiimc, and wiixplorer use IOS58 with AHB_PROT instead of IOS202.

I know that the last official build of wii64 (beta 1.1) came out a long time ago so it doesn't use IOS58 with AHB_PROT. Someone did modify the source so that you could run wii64 using IOS202 and get improved speeds, so wii64 is the only thing I can think of that still uses IOS202.

I recently made a small modification to the wii64 MOD so that wii64 will run using IOS224 instead of IOS202, thus eliminating any need for IOS202.

If anyone can think of any apps other than the wii64 MOD that use IOS202, please let me know as well.
MPlayer_CE still uses cIOS202, and many people still use that as a fallback for WiiMC on those Twilight Zone days.
WiiXplorer can run using AHBPROT and IOS58 for full system access and official USB2 code, but cIOS202 still offer better FTP performance and broader USB2 compatibility.

Heck, I still have DVDx installed for FTPii, but I'm weird like that.

-[]D
 

Hielkenator

Well-Known Member
Member
Joined
Feb 7, 2010
Messages
4,210
Trophies
0
XP
679
Country
Netherlands
PPSainity said:
xfcrowman said:
chop said:
xfcrowman said:
....In my case, I do not have cIOS202 installed because I have never needed it.

Now that HBC runs off IOS58 is 202 still needed?

I don't think IOS202 is needed anymore, but someone correct me if I'm wrong.

All the Tantric emulators (fceugx, vbagx etc) wiimc, and wiixplorer use IOS58 with AHB_PROT instead of IOS202.

I know that the last official build of wii64 (beta 1.1) came out a long time ago so it doesn't use IOS58 with AHB_PROT. Someone did modify the source so that you could run wii64 using IOS202 and get improved speeds, so wii64 is the only thing I can think of that still uses IOS202.

I recently made a small modification to the wii64 MOD so that wii64 will run using IOS224 instead of IOS202, thus eliminating any need for IOS202.

If anyone can think of any apps other than the wii64 MOD that use IOS202, please let me know as well.
MPlayer_CE still uses cIOS202, and many people still use that as a fallback for WiiMC on those Twilight Zone days.
WiiXplorer can run using AHBPROT and IOS58 for full system access and official USB2 code, but cIOS202 still offer better FTP performance and broader USB2 compatibility.

Heck, I still have DVDx installed for FTPii, but I'm weird like that.

-[]D

No your not, you are absolutely correct. also thought you needed an special version ( older ) of 202 to use the FTP server in Wiixplorer?
 

Hielkenator

Well-Known Member
Member
Joined
Feb 7, 2010
Messages
4,210
Trophies
0
XP
679
Country
Netherlands
steveo1978 said:
wiixplorer's ftp works with ios58 which I am using version 207 right now. I have not used 202 in a while

Cool, So I can read and write to my Wii's sd card using FTP server in Wiixplorer?
Using ios 58?

Previously I could'nt connect.
 

Gassy

Well-Known Member
Newcomer
Joined
Jul 24, 2009
Messages
86
Trophies
0
XP
247
Country
United States
xfcrowman said:
Waninkoko
249 [56] rev20 - for (almost) everything
250 [38] rev17 - for triiforce

xfcrowman,
How did you install into the 250 slot? I thought later cios versions supported slots, not 17.
Does Triiforce look at slot 250, or did you have to modify the source?

I'm asking this stuff because I've been considering going back to 17 so I can Triiforce again, but if I can get it to run off 17 in slot 250, that would solve that problem nicely.

Thanks,
Gassy
 

xfcrowman

Well-Known Member
Member
Joined
Mar 14, 2009
Messages
431
Trophies
0
XP
195
Country
United States
Gassy said:
xfcrowman said:
Waninkoko
249 [56] rev20 - for (almost) everything
250 [38] rev17 - for triiforce

xfcrowman,
How did you install into the 250 slot? I thought later cios versions supported slots, not 17.
Does Triiforce look at slot 250, or did you have to modify the source?

I'm asking this stuff because I've been considering going back to 17 so I can Triiforce again, but if I can get it to run off 17 in slot 250, that would solve that problem nicely.

Thanks,
Gassy

I used blue dump to pack cIOS38 rev 17 into a wad, and then I used showmiiwads 1.4 to change the IOS slot for cIOS38 rev 17 from 249 to 250.

Next, I modified the source code of triiforce mrc so that it would use IOS250 instead of IOS249.

For me, this setup is ideal because I get the benefits of Wanin's latest cIOS (better speed, compatibility) in slot 249, and then I get triiforce on slot 250.

If you want the modified .dol, let me know and I can upload it to Mediafire, along with the modified source.
 

Hielkenator

Well-Known Member
Member
Joined
Feb 7, 2010
Messages
4,210
Trophies
0
XP
679
Country
Netherlands
You could keep rev 17 in 249. And just change the way the Backuploaders load the games.
What you are doing is not neccisary at all Imho.
PS : In the past Waninkoko's installers copied the exact Cios in the 250 slot. In case of emergency.
I think rev 17 does this also. With the CIOSX rev 20 installers you could just reinstall slot 249 with what you like. And keep the content of slot 250.
 

xfcrowman

Well-Known Member
Member
Joined
Mar 14, 2009
Messages
431
Trophies
0
XP
195
Country
United States
Hielkenator said:
You could keep rev 17 in 249. And just change the way the Backuploaders load the games.
What you are doing is not neccisary at all Imho.
PS : In the past Waninkoko's installers copied the exact Cios in the 250 slot. In case of emergency.
I think rev 17 does this also. With the CIOSX rev 20 installers you could just reinstall slot 249 with what you like. And keep the content of slot 250.

True, you could just install rev 17 first and then use the cIOSX rev 20 installer to reinstall slot 249.

In my case, I like having rev 20 in slot 249 and rev 17 in slot 250, because I have used 249 to play games since the days of gamma loader 0.3.
Ultimately, it really doesn't matter what slot these cIOS are installed in - the only thing that does matter to me is that one can be used for triiforce and the other can be used for games.

If Wanin releases cIOSx rev21 and Triiforce works, then I will no longer have any need for the rev 17 cIOS.
 

RetroHero

Active Member
Newcomer
Joined
Jun 19, 2009
Messages
34
Trophies
0
XP
93
Country
For me this is what I use. About 50 games or so (all the good ones) work flawlessly.

rev 20 249 base 57 (everything works with this except monster hunter and COD:BO
223 v4 37 and 38 merged (monster hunter)
224 v5 base 57 (COD works with this and not 249 for me)
 

PPSainity

Blinded by Science
Member
Joined
Jun 6, 2009
Messages
646
Trophies
0
XP
188
Country
Canada
Hielkenator said:
...
No your not, you are absolutely correct. also thought you needed an special version ( older ) of 202 to use the FTP server in Wiixplorer?Yeah, it's posted as a note on the WiiXplorer site:
QUOTE said:
FTP Server doesn't work for Ethernet-Adapters (maybe for some Wifis too) if you install IOS202 v5 based on IOS57. Also there is no Channel list in the StartMenu with that.
It is recommended to use the very old Hermes IOS202v2 base 36 merged 60 for the FTP to work. You'll have all features of WiiXplorer with it. If this doesn't work try another variant of it like v4 base 38 merged 60. If you don't want the old version installed on your Wii (which gives no disadvantages btw) live with FTP Server not working!!
QUOTE(steveo1978 @ Dec 3 2010, 12:06 AM)
wiixplorer's ftp works with ios58 which I am using version 207 right now. I have not used 202 in a while
Not saying FTP does not work with when using AHBPROT and IOS58, just not as well as with cIOS202. Though with each new update it is getting better, the most noticeable change was my USB2 HDD speeds with r200. As of now, I still find Wiixplorer to have better FTP and USB2 performance with cIOS202. I do like the way dimok is able to use AHBPROT to patch any IOS in use, and not just IOS58 now. I don't know exactly how he does it and to what extent yet, but it would be nice to benefit from the USB2 code in IOS202 and the complete system access from AHBPROT, best of both worlds.

Steering back on to the OPs topic, at least in the next lane. I do look forward to the day that with AHBPROT, apps can take any IOS as a base, and patch their own additions on the fly. This way we do not have to maintain any cIOS, and we can leave the official IOS alone. We would still be at the mercy of the integrity of the patched code that was patched on the fly to not go berserk, but the rub's gotta lie somewhere.

-[]D
 

VashTS

Beat it, son
Member
Joined
Mar 14, 2009
Messages
4,270
Trophies
1
Age
38
Location
Upstate NY
XP
3,310
Country
United States
ideal set up for me:

202 - wiimc installer base 60 (i believe?)
222 - hermes v4/5 base 38
223 - hermes v4/5 base 37
224 - hermes v5 base 57
248 - waninkoko rev20 base 57
249 - waninkoko rev17
250 - waninkoko rev20 base 37

i might install 247 using waninkoko rev20 base 56, but i don't think i need it. this setup works great for everything. 17 is there for nand emulation, rev20 base 37 for music games, hermes for compatibility.
 

PPSainity

Blinded by Science
Member
Joined
Jun 6, 2009
Messages
646
Trophies
0
XP
188
Country
Canada
steveo1978 said:
http://wiibrew.org/wiki/IOS58_Installer

ios202 doesnt have USB2.0 support thats why must loaders and other apps that need faster usb support use ios58.
Ummm, no, that is totally wrong. USB2 support for the Wii began with cIOS202 albeit unofficially as it was from the homebrew community, and not directly from Nintendo. IOS58 is the first IOS to contain official USB2 code from Nintendo. IOS58 is recommended over cIOS202 by some people who believe using official code is always better than cIOS. Sadly, although IOS58 contains official code, the USB2 module in cIOS202 is compatible with more USB HDDs and for now also provides better performance; the latter might change as code gets optimized, but I doubt by much and the former is totally at the mercy of Nintendo which only cares for its licensed devices..

-[]D

EDIT: Here's my setup too:
sysCheck v2.0.1 by Double_A
...runs on IOS58 (rev 6176).

Region: NTSC-U
System Menu 4.3U (v513)
Hollywood v0x11
Console ID: xxxxxxxx
Boot2 v4

Found 116 titles.
Found 47 IOS on this console. 11 of them are stub.

IOS4 (rev 65280): Stub
IOS9 (rev 1034): No Patches
IOS10 (rev 768): Stub
IOS11 (rev 256): Stub
IOS12 (rev 526): No Patches
IOS13 (rev 1032): No Patches
IOS14 (rev 1032): No Patches
IOS15 (rev 1032): No Patches
IOS16 (rev 257): Trucha Bug, ES Identify, Flash Access
IOS17 (rev 1032): No Patches
IOS20 (rev 256): Stub
IOS21 (rev 1039): No Patches
IOS22 (rev 1294): No Patches
IOS28 (rev 1807): No Patches
IOS30 (rev 2816): Stub
IOS31 (rev 3608): No Patches
IOS33 (rev 3608): No Patches
IOS34 (rev 3608): No Patches
IOS35 (rev 3608): No Patches
IOS36 (rev 3608): No Patches
IOS37 (rev 5663): No Patches
IOS38 (rev 4124): No Patches
IOS40 (rev 3072): Stub
IOS41 (rev 3607): No Patches
IOS43 (rev 3607): No Patches
IOS45 (rev 3607): No Patches
IOS46 (rev 3607): No Patches
IOS48 (rev 4124): No Patches
IOS50 (rev 5120): Stub
IOS51 (rev 4864): Stub
IOS52 (rev 5888): Stub
IOS53 (rev 5663): No Patches
IOS55 (rev 5663): No Patches
IOS56 (rev 5662): No Patches
IOS57 (rev 5919): No Patches
IOS58 (rev 6176): No Patches
IOS60 (rev 6400): Stub
IOS61 (rev 5662): No Patches
IOS70 (rev 6912): Stub
IOS80 (rev 6944): Trucha Bug, NAND Access
IOS202 (rev 4): Trucha Bug, ES Identify, USB 2.0 *Hermes v4 with IOS38 base
IOS222 (rev 65535): Trucha Bug, ES Identify, NAND Access, USB 2.0 *Hermes v5 with IOS38 base
IOS223 (rev 65535): Trucha Bug, NAND Access, USB 2.0 *Hermes v5 with IOS37 base
IOS224 (rev 65535): Trucha Bug, NAND Access, USB 2.0 *Hermes v5 with IOS57 base
IOS236 (rev 65535): Trucha Bug, ES Identify, NAND Access *Copy of IOS36 Patched
IOS249 (rev 20): Trucha Bug, NAND Access, USB 2.0 *Waninikoko's cIOSx rev20b with IOS57 base
IOS250 (rev 65535): Trucha Bug, NAND Access, USB 2.0 *Waninikoko's cIOSx rev20b with IOS38 base
BC v6
MIOS v10 *Waninikoko's cMIOS rev5 with MIOS v10 base

Report generated on 2010/11/23.
 

mauifrog

DA KINE WiiHacker
Member
Joined
Jan 21, 2010
Messages
1,587
Trophies
0
Website
Visit site
XP
392
Country
United States
Here is my setup
sysCheck v1.6.1 by Erik Spyder

Region: NTSC-U
The system menu v385 is running under IOS58 (rev 6176) I usually have 4.1 patched to v54321, but this is just test.
Hollywood v0x11
Boot2 v4
Found 66 titles
Found 39 IOS on this console
Found 2 IOS Stubs on this console

IOS (revision),IOS Stub,Trucha Bug,ES Identify,Flash Access,NAND Access,Boot2 Access,USB 2.0
IOS9 (rev 54321),No,Enabled,Disabled,Disabled,Disabled,Disabled,Disabled ios60-v6174 with dip
IOS11 (rev 54321),No,Enabled,Disabled,Disabled,Disabled,Disabled,Disabled ios60-v6174 with dip
IOS13 (rev 273),No,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled
IOS14 (rev 520),No,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled
IOS15 (rev 523),No,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled
IOS16 (rev 54321),No,Enabled,Enabled,Enabled,Enabled,Disabled,Disabled ios16-v257
IOS17 (rev 775),No,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled
IOS20 (rev 54321),No,Enabled,Disabled,Disabled,Disabled,Disabled,Disabled ios60-v6174 with dip
IOS21 (rev 782),No,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled
IOS22 (rev 1037),No,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled
IOS28 (rev 1550),No,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled
IOS30 (rev 54321),No,Enabled,Disabled,Disabled,Disabled,Disabled,Disabled
IOS31 (rev 3349),No,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled ios60-v6174 with dip
IOS33 (rev 3091),No,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled
IOS34 (rev 3348),No,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled
IOS35 (rev 3349),No,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled
IOS36 (rev 54321),No,Enabled,Enabled,Disabled,Enabled,Disabled,Disabled
IOS37 (rev 3869),No,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled
IOS38 (rev 3867),No,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled
IOS50 (rev 54321),No,Enabled,Disabled,Disabled,Disabled,Disabled,Disabled ios50 with dip
IOS53 (rev 5120),Yes,?,?,?,?,?,? this is just a stupid test
IOS55 (rev 5406),No,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled
IOS56 (rev 5405),No,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled
IOS57 (rev 5661),No,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled
IOS58 (rev 6176),No,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled
IOS60 (rev 54321),No,Enabled,Disabled,Disabled,Disabled,Disabled,Disabled ios60-v6174 with dip
IOS61 (rev 5662),No,Disabled,Disabled,Disabled,Disabled,Disabled,Disabled
IOS70 (rev 54321),No,Enabled,Disabled,Disabled,Disabled,Disabled,Disabled ios60-v6174 with dip
IOS80 (rev 54321),No,Enabled,Disabled,Disabled,Disabled,Disabled,Disabled ios60-v6174 with dip
IOS90 (rev 54321),No,Enabled,Disabled,Disabled,Disabled,Disabled,Disabled ios60-v6174 with dip
IOS202 (rev 65535),No,Enabled,Disabled,Disabled,Enabled,Disabled,Enabled v5.1 base60
IOS222 (rev 4),No,Enabled,Enabled,Disabled,Enabled,Disabled,Enabled v4 base38
IOS223 (rev 4),No,Enabled,Enabled,Disabled,Enabled,Disabled,Enabled v4 base 37/38
IOS224 (rev 65535),No,Enabled,Disabled,Disabled,Enabled,Disabled,Enabled v5.1 base57
IOS236 (rev 54321),No,Enabled,Enabled,Disabled,Enabled,Disabled,Disabled patched ios36
IOS247 (rev 65535),No,Enabled,Disabled,Disabled,Enabled,Disabled,Enabled -r20 base 37
IOS248 (rev 65535),No,Enabled,Disabled,Disabled,Enabled,Disabled,Enabled -r20 base56
IOS249 (rev 17),No,Enabled,Enabled,Disabled,Enabled,Disabled,Enabled -r17 base38
IOS250 (rev 65535),No,Enabled,Disabled,Disabled,Enabled,Disabled,Enabled -r20 base50
IOS254 (rev 65281),Yes,?,?,?,?,?,? bootmii ios
 

You may also like...

General chit-chat
Help Users
    AncientBoi @ AncientBoi: Skittles? Sure! Thanks :D